]> git.pld-linux.org Git - packages/libnotify.git/blob - libnotify.spec
- updated to 0.7.8
[packages/libnotify.git] / libnotify.spec
1 # TODO: actually run tests (broken after switching to meson)
2 #
3 # Conditional build:
4 %bcond_without  apidocs         # gtk-doc API documentation
5 %bcond_without  static_libs     # static library
6 %bcond_without  tests           # tests build
7
8 Summary:        Desktop notifications library
9 Summary(hu.UTF-8):      Desktop értesítő könyvtár
10 Summary(pl.UTF-8):      Biblioteka powiadomień dla pulpitu
11 Name:           libnotify
12 Version:        0.7.8
13 Release:        1
14 License:        LGPL v2.1+ (library), GPL v2+ (tools)
15 Group:          Libraries
16 Source0:        http://ftp.gnome.org/pub/GNOME/sources/libnotify/0.7/%{name}-%{version}.tar.xz
17 # Source0-md5:  babb4b07b5f21bef42a386d3d7019599
18 URL:            http://developer.gnome.org/notification-spec/
19 BuildRequires:  docbook-dtd412-xml
20 BuildRequires:  gdk-pixbuf2-devel >= 2.0
21 BuildRequires:  glib2-devel >= 1:2.26.0
22 BuildRequires:  gobject-introspection-devel >= 0.9.12
23 %{?with_tests:BuildRequires:    gtk+3-devel >= 3.0.0}
24 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.14}
25 BuildRequires:  meson >= 0.47.0
26 BuildRequires:  ninja >= 1.5
27 BuildRequires:  pkgconfig
28 BuildRequires:  rpmbuild(macros) >= 1.736
29 BuildRequires:  sed >= 4.0
30 BuildRequires:  tar >= 1:1.22
31 BuildRequires:  xmlto
32 BuildRequires:  xz
33 Requires:       glib2 >= 1:2.26.0
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 A library that sends desktop notifications to a notification daemon,
38 as defined in the Desktop Notifications spec. These notifications can
39 be used to inform the user about an event or display some form of
40 information without getting in the user's way.
41
42 %description -l hu.UTF-8
43 Könyvtár, amely értesítéseket küld egy üzenetkezelő démonnak, ahogy a
44 Desktop Notifications szabványnak megfelel. Ezek az értesítések
45 tájékoztathatják a felhasználót eseményről vagy információt jeleníthet
46 meg.
47
48 %description -l pl.UTF-8
49 Biblioteka wysyłająca powiadomienia dla pulpitu do demona powiadomień
50 zgodnie ze specyfikacją Desktop Notifications. Powiadomienia te mogą
51 być używane do informowania użytkownika o zdarzeniu lub wyświetlania
52 jakiejś formy informacji bez wchodzenia użytkownikowi w drogę.
53
54 %package devel
55 Summary:        libnotify header files
56 Summary(hu.UTF-8):      libnotify fejléc fájlok
57 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libnotify
58 License:        LGPL v2.1+
59 Group:          Development/Libraries
60 Requires:       %{name} = %{version}-%{release}
61 Requires:       gdk-pixbuf2-devel >= 2.0
62 Requires:       glib2-devel >= 1:2.26.0
63
64 %description devel
65 Header files for libnotify-based programs development.
66
67 %description devel -l hu.UTF-8
68 Fejléc fájlok libnotify-t használó programok fejlesztéséhez.
69
70 %description devel -l pl.UTF-8
71 Pliki nagłówkowe do tworzenia programów opartych o libnotify.
72
73 %package static
74 Summary:        Static libnotify library
75 Summary(hu.UTF-8):      Libnotify statikus könyvtár
76 Summary(pl.UTF-8):      Statyczna biblioteka libnotify
77 License:        LGPL v2.1+
78 Group:          Development/Libraries
79 Requires:       %{name}-devel = %{version}-%{release}
80
81 %description static
82 Static libnotify library.
83
84 %description static -l hu.UTF-8
85 Libnotify statikus könyvtár.
86
87 %description static -l pl.UTF-8
88 Statyczna biblioteka libnotify.
89
90 %package apidocs
91 Summary:        libnotify API documentation
92 Summary(hu.UTF-8):      libnotify API dokumentáció
93 Summary(pl.UTF-8):      Dokumentacja API biblioteki libnotify
94 Group:          Documentation
95 Requires:       gtk-doc-common
96 %if "%{_rpmversion}" >= "5"
97 BuildArch:      noarch
98 %endif
99
100 %description apidocs
101 libnotify API documentation.
102
103 %description apidocs -l hu.UTF-8
104 libnotify API dokumentáció.
105
106 %description apidocs -l pl.UTF-8
107 Dokumentacja API biblioteki libnotify.
108
109 %prep
110 %setup -q
111
112 %if %{with static_libs}
113 %{__sed} -i -e '/libnotify_lib/ s/shared_library/library/' libnotify/meson.build
114 %endif
115
116 %build
117 %meson build \
118         %{!?with_apidocs:-Dgtk_doc=false} \
119         %{!?with_tests:-Dtests=false}
120
121 %ninja_build -C build
122
123 %install
124 rm -rf $RPM_BUILD_ROOT
125
126 %ninja_install -C build
127
128 # packaged as %doc
129 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/libnotify/spec
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %post   -p /sbin/ldconfig
135 %postun -p /sbin/ldconfig
136
137 %files
138 %defattr(644,root,root,755)
139 %doc AUTHORS ChangeLog NEWS build/docs/notification-spec.html
140 %attr(755,root,root) %{_bindir}/notify-send
141 %attr(755,root,root) %{_libdir}/libnotify.so.*.*.*
142 %attr(755,root,root) %ghost %{_libdir}/libnotify.so.4
143 %{_libdir}/girepository-1.0/Notify-0.7.typelib
144
145 %files devel
146 %defattr(644,root,root,755)
147 %attr(755,root,root) %{_libdir}/libnotify.so
148 %{_pkgconfigdir}/libnotify.pc
149 %{_includedir}/libnotify
150 %{_datadir}/gir-1.0/Notify-0.7.gir
151
152 %if %{with static_libs}
153 %files static
154 %defattr(644,root,root,755)
155 %{_libdir}/libnotify.a
156 %endif
157
158 %if %{with apidocs}
159 %files apidocs
160 %defattr(644,root,root,755)
161 %{_gtkdocdir}/libnotify
162 %endif
This page took 0.035598 seconds and 3 git commands to generate.