]> git.pld-linux.org Git - packages/libnfs.git/blob - libnfs.spec
e16cb77bbbc2d3df9c2ae11a0c8ffb7b6287fd01
[packages/libnfs.git] / libnfs.spec
1 Summary:        Client library for accessing NFS shares over network
2 Summary(pl.UTF-8):      Biblioteka kliencka do dostępu do udziałów NFS poprzez sieć
3 Name:           libnfs
4 Version:        2.0.0
5 Release:        1
6 # library code is LGPL, protocol definition files are BSD licensed
7 License:        LGPL v2.1+ and BSD
8 Group:          Libraries
9 Source0:        https://sites.google.com/site/libnfstarballs/li/%{name}-%{version}.tar.gz
10 # Source0-md5:  87d913e26b9c4b7fe0b0460fa4e4cd99
11 URL:            https://github.com/sahlberg/libnfs
12 BuildRequires:  pkgconfig
13 BuildRequires:  popt-devel
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 Client library for accessing NFS shares over network.
18
19 %description -l pl.UTF-8
20 Biblioteka kliencka do dostępu do udziałów NFS poprzez sieć.
21
22 %package devel
23 Summary:        Header files for libnfs library
24 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libnfs
25 License:        LGPL v2.1+ and BSD
26 Group:          Development/Libraries
27 Requires:       %{name} = %{version}-%{release}
28
29 %description devel
30 Header files and examples for libnfs library.
31
32 %description devel -l pl.UTF-8
33 Pliki nagłówkowe oraz przykłady dla biblioteki libnfs.
34
35 %package static
36 Summary:        Static libnfs library
37 Summary(pl.UTF-8):      Statyczna biblioteka libnfs
38 License:        LGPL v2.1+ and BSD
39 Group:          Development/Libraries
40 Requires:       %{name}-devel = %{version}-%{release}
41
42 %description static
43 Static libnfs library.
44
45 %description static -l pl.UTF-8
46 Statyczna biblioteka libnfs.
47
48 %package examples
49 Summary:        Example code for libnfs library
50 Summary(pl.UTF-8):      Przykładowy kod źródłowy wykorzystujący bibliotekę libnfs
51 License:        GPL v3+
52 Group:          Documentation
53
54 %description examples
55 Example code for libnfs library.
56
57 %description examples -l pl.UTF-8
58 Przykładowy kod źródłowy wykorzystujący bibliotekę libnfs.
59
60 %package utils
61 Summary:        Utils for accessing NFS servers
62 Summary(pl.UTF-8):      Narzędzia służące do dostępu do serwerów NFS
63 License:        GPL v3+
64 Group:          Applications/Networking
65 Requires:       %{name} = %{version}-%{release}
66
67 %description utils
68 Simple client programs for accessing NFS servers using libnfs.
69
70 %description utils -l pl.UTF-8
71 Proste programy klienckie służące do dostępu do serwerów NFS przy
72 użyciu biblioteki libnfs.
73
74 %prep
75 %setup -q
76
77 %build
78 # XXX: remove this hack when autoconf supports glibc major/minor/makedev changes
79 # (or removes them from sys/types.h completely)
80 CPPFLAGS="%{rpmcppflags} -DMAJOR_IN_SYSMACROS"
81
82 %configure
83 %{__make}
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87
88 %{__make} install \
89         DESTDIR=$RPM_BUILD_ROOT
90
91 # obsoleted by pkg-config
92 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libnfs.la
93
94 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
95 cp -p examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
96
97 %clean
98 rm -rf $RPM_BUILD_ROOT
99
100 %post   -p /sbin/ldconfig
101 %postun -p /sbin/ldconfig
102
103 %files
104 %defattr(644,root,root,755)
105 %doc COPYING README
106 %attr(755,root,root) %{_libdir}/libnfs.so.*.*.*
107 %attr(755,root,root) %ghost %{_libdir}/libnfs.so.11
108
109 %files devel
110 %defattr(644,root,root,755)
111 %attr(755,root,root) %{_libdir}/libnfs.so
112 %{_includedir}/nfsc
113 %{_pkgconfigdir}/libnfs.pc
114
115 %files static
116 %defattr(644,root,root,755)
117 %{_libdir}/libnfs.a
118
119 %files examples
120 %defattr(644,root,root,755)
121 %{_examplesdir}/%{name}-%{version}
122
123 %files utils
124 %defattr(644,root,root,755)
125 %attr(755,root,root) %{_bindir}/nfs-cat
126 %attr(755,root,root) %{_bindir}/nfs-cp
127 %attr(755,root,root) %{_bindir}/nfs-ls
128 %{_mandir}/man1/nfs-cat.1*
129 %{_mandir}/man1/nfs-cp.1*
130 %{_mandir}/man1/nfs-ls.1*
This page took 0.081353 seconds and 2 git commands to generate.