]> git.pld-linux.org Git - packages/libmysofa.git/blob - libmysofa.spec
1443d1be7020b052eeb536a5501fc3e23b892f28
[packages/libmysofa.git] / libmysofa.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build tests
4
5 Summary:        Library to read AES SOFA files
6 Summary(pl.UTF-8):      Biblioteka do odczytu plików AES SOFA
7 Name:           libmysofa
8 Version:        1.2.1
9 Release:        1
10 License:        BSD
11 Group:          Libraries
12 #Source0Download: https://github.com/hoene/libmysofa/releases
13 Source0:        https://github.com/hoene/libmysofa/archive/v%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  de55b79f2687c824f2134e677f437601
15 URL:            https://github.com/hoene/libmysofa
16 %{?with_tests:BuildRequires:    CUnit}
17 BuildRequires:  cmake >= 2.8.12
18 BuildRequires:  rpmbuild(macros) >= 1.742
19 BuildRequires:  zlib-devel
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 This is a simple set of C functions to read AES SOFA files, if they
24 contain HRTFs stored according to the AES69-2015 standard
25 <http://www.aes.org/publications/standards/search.cfm?docID=99>.
26
27 %description -l pl.UTF-8
28 Prosty zbiór funkcji C do odczytu plików AES SOFA, zawierających dane
29 HRTF zapisane zgodnie ze standardem AES69-2015
30 <http://www.aes.org/publications/standards/search.cfm?docID=99>.
31
32 %package devel
33 Summary:        Header files for libmysofa library
34 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libmysofa
35 Group:          Development/Libraries
36 Requires:       %{name} = %{version}-%{release}
37 Requires:       zlib-devel
38
39 %description devel
40 Header files for libmysofa library.
41
42 %description devel -l pl.UTF-8
43 Pliki nagłówkowe biblioteki libmysofa.
44
45 %package static
46 Summary:        Static libmysofa library
47 Summary(pl.UTF-8):      Statyczna biblioteka libmysofa
48 Group:          Development/Libraries
49 Requires:       %{name}-devel = %{version}-%{release}
50
51 %description static
52 Static libmysofa library.
53
54 %description static -l pl.UTF-8
55 Statyczna biblioteka libmysofa.
56
57 %prep
58 %setup -q
59
60 %build
61 install -d build
62 cd build
63 %cmake .. \
64         %{cmake_on_off tests BUILD_TESTS} \
65         -DCODE_COVERAGE:BOOL=OFF
66
67 %{__make}
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71
72 %{__make} -C build install \
73         DESTDIR=$RPM_BUILD_ROOT
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %post   -p /sbin/ldconfig
79 %postun -p /sbin/ldconfig
80
81 %files
82 %defattr(644,root,root,755)
83 %doc LICENSE README.md
84 %{?with_tests:%attr(755,root,root) %{_bindir}/mysofa2json}
85 %attr(755,root,root) %{_libdir}/libmysofa.so.*.*.*
86 %attr(755,root,root) %ghost %{_libdir}/libmysofa.so.1
87 %{_datadir}/libmysofa
88
89 %files devel
90 %defattr(644,root,root,755)
91 %attr(755,root,root) %{_libdir}/libmysofa.so
92 %{_includedir}/mysofa.h
93 %{_pkgconfigdir}/libmysofa.pc
94
95 %files static
96 %defattr(644,root,root,755)
97 %{_libdir}/libmysofa.a
This page took 0.080099 seconds and 2 git commands to generate.