]> git.pld-linux.org Git - packages/libmediainfo.git/blob - libmediainfo.spec
up to 22.12
[packages/libmediainfo.git] / libmediainfo.spec
1 # TODO: system libs:
2 # - pkgconfig(aes_gladman)
3 # - pkgconfig(sha1_gladman)
4 # - pkgconfig(sha2_gladman)
5 # - pkgconfig(hmac_gladman)
6 # - md5? (which implementation? pkgconfig(md5) is checked)
7 #
8 # Conditional build:
9 %bcond_without  curl            # cURL support
10 %bcond_without  mms             # MMS support
11 %bcond_without  graphviz        # graphviz support
12 %bcond_without  apidocs         # API documentation (doxygen generated)
13 %bcond_without  static_libs     # static library
14
15 %define libzen_ver 0.4.40
16 Summary:        Supplies technical and tag information about a video or audio file
17 Summary(pl.UTF-8):      Informacje techniczne i znaczniki dla plików wideo i dźwiękowych
18 Name:           libmediainfo
19 Version:        22.12
20 Release:        1
21 License:        BSD or Apache v2.0+ or LGPL v2.1+ or GPL v2+ or MPL v2.0+
22 Group:          Libraries
23 Source0:        https://github.com/MediaArea/MediaInfoLib/archive/v%{version}/MediaInfoLib-%{version}.tar.gz
24 # Source0-md5:  6b1632d958b184eb1985021c0da90302
25 URL:            https://github.com/MediaArea/MediaInfoLib
26 BuildRequires:  autoconf >= 2.50
27 BuildRequires:  automake >= 1:1.11
28 %{?with_curl:BuildRequires:     curl-devel}
29 BuildRequires:  doxygen
30 %{?with_graphviz:BuildRequires: graphviz-devel}
31 %{?with_mms:BuildRequires:      libmms-devel}
32 BuildRequires:  libstdc++-devel
33 BuildRequires:  libtool >= 2:1.5
34 BuildRequires:  libzen-devel >= %{libzen_ver}
35 BuildRequires:  pkgconfig
36 BuildRequires:  rpm-build >= 4.6
37 BuildRequires:  rpmbuild(macros) >= 1.752
38 BuildRequires:  tar >= 1:1.22
39 BuildRequires:  tinyxml2-devel
40 BuildRequires:  xz
41 BuildRequires:  zlib-devel
42 Requires:       libzen >= %{libzen_ver}
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 MediaInfo supplies technical and tag information about a video or
47 audio file.
48
49 What information can I get from MediaInfo?
50 - General: title, author, director, album, track number, date,
51   duration...
52 - Video: codec, aspect, fps, bitrate...
53 - Audio: codec, sample rate, channels, language, bitrate...
54 - Text: language of subtitle
55 - Chapters: number of chapters, list of chapters
56
57 Supported files: DivX, XviD, H263, H.263, H264, x264, ASP, AVC,
58 iTunes, MPEG-1, MPEG1, MPEG-2, MPEG2, MPEG-4, MPEG4, MP4, M4A, M4V,
59 QuickTime, RealVideo, RealAudio, RA, RM, MSMPEG4v1, MSMPEG4v2,
60 MSMPEG4v3, VOB, DVD, WMA, VMW, ASF, 3GP, 3GPP, 3GP2
61
62 Supported formats/containers:
63 - Video: MKV, OGM, AVI, DivX, WMV, QuickTime, Real, MPEG-1, MPEG-2,
64   MPEG-4, DVD (VOB) (Codecs: DivX, XviD, MSMPEG4, ASP, H.264, AVC...)
65 - Audio: OGG, MP3, WAV, RA, AC3, DTS, AAC, M4A, AU, AIFF
66 - Subtitles: SRT, SSA, ASS, SAMI
67
68 This package contains the shared library for MediaInfo.
69
70 %description -l pl.UTF-8
71 MediaInfo udostępnia informacje techniczne oraz znaczniki dla plików
72 wideo i dźwiękowych.
73
74 Dostępne są informacje:
75 - ogólne: tytuł, autor, reżyser, album, numer ścieżki, data, czas
76   trwania...
77 - wideo: kodek, proporcje, liczba klatek na sekundę, pasmo...
78 - dźwięk: kodek, częstotliwość próbkowania, liczba kanałów, język,
79   pasmo...
80 - tekst: język napisów
81 - książki: liczba rozdziałów, ich lista
82
83 Obsługiwane pliki: DivX, XviD, H263, H.263, H264, x264, ASP, AVC,
84 iTunes, MPEG-1, MPEG1, MPEG-2, MPEG2, MPEG-4, MPEG4, MP4, M4A, M4V,
85 QuickTime, RealVideo, RealAudio, RA, RM, MSMPEG4v1, MSMPEG4v2,
86 MSMPEG4v3, VOB, DVD, WMA, VMW, ASF, 3GP, 3GPP, 3GP2
87
88 Obsługiwane formaty/kontenery:
89 - wideo: MKV, OGM, AVI, DivX, WMV, QuickTime, Real, MPEG-1, MPEG-2,
90   MPEG-4, DVD (VOB) (kodeki: DivX, XviD, MSMPEG4, ASP, H.264, AVC...)
91 - dźwięk: OGG, MP3, WAV, RA, AC3, DTS, AAC, M4A, AU, AIFF
92 - napisy: SRT, SSA, ASS, SAMI
93
94 Ten pakiet zawiera bibliotekę współdzieloną MediaInfo.
95
96 %package devel
97 Summary:        Header files for MediaInfo library
98 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki MediaInfo
99 Group:          Development/Libraries
100 Requires:       %{name} = %{version}-%{release}
101 %{?with_curl:Requires:  curl-devel}
102 %{?with_mms:Requires:   libmms-devel}
103 Requires:       libstdc++-devel
104 Requires:       libzen-devel >= %{libzen_ver}
105 Requires:       tinyxml2-devel
106 Requires:       zlib-devel
107
108 %description devel
109 Header files for MediaInfo library.
110
111 %description devel -l pl.UTF-8
112 Pliki nagłówkowe biblioteki MediaInfo.
113
114 %package static
115 Summary:        Static MediaInfo library
116 Summary(pl.UTF-8):      Statyczna biblioteka MediaInfo
117 Group:          Development/Libraries
118 Requires:       %{name}-devel = %{version}-%{release}
119
120 %description static
121 Static MediaInfo library.
122
123 %description static -l pl.UTF-8
124 Statyczna biblioteka MediaInfo.
125
126 %package apidocs
127 Summary:        API documentation for MediaInfo library
128 Summary(pl.UTF-8):      Dokumentacja API biblioteki MediaInfo
129 Group:          Documentation
130 BuildArch:      noarch
131
132 %description apidocs
133 API documentation for MediaInfo library.
134
135 %description apidocs -l pl.UTF-8
136 Dokumentacja API biblioteki MediaInfo.
137
138 %prep
139 %setup -q -n MediaInfoLib-%{version}
140 cp -p Release/ReadMe_DLL_Linux.txt ReadMe.txt
141 %{__mv} History_DLL.txt History.txt
142 %undos *.txt *.html Source/Doc/*.html
143 chmod 644 *.txt *.html Source/Doc/*.html
144
145 %build
146 cd Project/GNU/Library
147 %{__libtoolize}
148 %{__aclocal}
149 %{__autoconf}
150 %{__automake}
151 %configure \
152         %{?with_static_libs:--enable-static} \
153         %{?with_graphviz:--with-graphviz} \
154         %{?with_curl:--with-libcurl} \
155         %{?with_mms:--with-libmms} \
156         --with-libtinyxml2
157
158 %{__make} clean
159 %{__make}
160
161 %if %{with apidocs}
162 cd ../../../Source/Doc
163 doxygen Doxyfile
164 %endif
165
166 %install
167 rm -rf $RPM_BUILD_ROOT
168
169 %{__make} -C Project/GNU/Library install \
170         DESTDIR=$RPM_BUILD_ROOT
171
172 # obsoleted by pkg-config
173 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libmediainfo.la
174
175 %clean
176 rm -rf $RPM_BUILD_ROOT
177
178 %post   -p /sbin/ldconfig
179 %postun -p /sbin/ldconfig
180
181 %files
182 %defattr(644,root,root,755)
183 %doc Changes.txt History.txt License.html README.md ReadMe.txt
184 %attr(755,root,root) %{_libdir}/libmediainfo.so.*.*.*
185 %attr(755,root,root) %ghost %{_libdir}/libmediainfo.so.0
186
187 %files devel
188 %defattr(644,root,root,755)
189 %attr(755,root,root) %{_libdir}/libmediainfo.so
190 %{_includedir}/MediaInfo
191 %{_includedir}/MediaInfoDLL
192 %{_pkgconfigdir}/libmediainfo.pc
193
194 %if %{with static_libs}
195 %files static
196 %defattr(644,root,root,755)
197 %{_libdir}/libmediainfo.a
198 %endif
199
200 %if %{with apidocs}
201 %files apidocs
202 %defattr(644,root,root,755)
203 # Documentation.html expects Doc/index.html
204 %doc Source/Doc/Documentation.html Doc Source/Example/HowToUse*
205 %endif
This page took 0.067403 seconds and 3 git commands to generate.