]> git.pld-linux.org Git - packages/libmbim.git/blob - libmbim.spec
99f2e3630116d44db2b046a1461ca46c40a92eb6
[packages/libmbim.git] / libmbim.spec
1 # TODO: --enable-mbim-username=???
2 #
3 # Conditional build:
4 %bcond_without  apidocs         # do not build and package API docs
5
6 Summary:        GLib library for talking to WWAN modems and devices using MBIM protocol
7 Summary(pl.UTF-8):      Biblioteka GLib do komunikacji z modemami i urządzeniami WWAN z użyciem protokołu MBIM
8 Name:           libmbim
9 Version:        1.26.0
10 Release:        1
11 License:        LGPL v2
12 Group:          Libraries
13 Source0:        https://www.freedesktop.org/software/libmbim/%{name}-%{version}.tar.xz
14 # Source0-md5:  552d498d891c93ee9ed2684a8a6a723e
15 URL:            https://www.freedesktop.org/wiki/Software/libmbim
16 BuildRequires:  autoconf >= 2.68
17 BuildRequires:  automake >= 1:1.11
18 BuildRequires:  glib2-devel >= 1:2.56
19 BuildRequires:  gobject-introspection-devel >= 0.9.6
20 BuildRequires:  gtk-doc >= 1.0
21 BuildRequires:  help2man
22 BuildRequires:  libtool >= 2:2.2
23 BuildRequires:  pkgconfig
24 BuildRequires:  python
25 BuildRequires:  rpm-build >= 4.6
26 BuildRequires:  rpmbuild(macros) >= 1.673
27 Requires:       glib2 >= 1:2.56
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 libmbim is a GLib library for talking to WWAN modems and devices which
32 speak the Mobile Interface Broadband Model (MBIM) protocol.
33
34 %description -l pl.UTF-8
35 libmbim to biblioteka GLib do komunikacji z modemami i urządzeniami
36 WWAN, obsługującymi protokół MBIM (Mobile Interface Broadband Model).
37
38 %package devel
39 Summary:        Header files for libmbim library
40 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libmbim
41 Group:          Development/Libraries
42 Requires:       %{name} = %{version}-%{release}
43 Requires:       glib2-devel >= 1:2.56
44
45 %description devel
46 Header files for libmbim library.
47
48 %description devel -l pl.UTF-8
49 Pliki nagłówkowe biblioteki libmbim.
50
51 %package static
52 Summary:        Static libmbim library
53 Summary(pl.UTF-8):      Statyczna biblioteka libmbim
54 Group:          Development/Libraries
55 Requires:       %{name}-devel = %{version}-%{release}
56
57 %description static
58 Static libmbim library.
59
60 %description static -l pl.UTF-8
61 Statyczna biblioteka libmbim.
62
63 %package apidocs
64 Summary:        libmbim API documentation
65 Summary(pl.UTF-8):      Dokumentacja API biblioteki libmbim
66 Group:          Documentation
67 Requires:       gtk-doc-common
68 BuildArch:      noarch
69
70 %description apidocs
71 API documentation for libmbim library.
72
73 %description apidocs -l pl.UTF-8
74 Dokumentacja API biblioteki libmbim.
75
76 %package -n bash-completion-libmbim
77 Summary:        Bash completion for libmbim commands
78 Summary(pl.UTF-8):      Bashowe dopełnianie składni poleceń libmbim
79 Group:          Applications/Shells
80 Requires:       %{name} = %{version}-%{release}
81 Requires:       bash-completion >= 2.0
82
83 %description -n bash-completion-libmbim
84 Bash completion for libmbim commands (mbimcli).
85
86 %description -n bash-completion-libmbim -l pl.UTF-8
87 Bashowe dopełnianie składni poleceń libmbim (mbimcli).
88
89 %prep
90 %setup -q
91
92 %build
93 %{__libtoolize}
94 %{__aclocal} -I m4
95 %{__autoconf}
96 %{__autoheader}
97 %{__automake}
98 %configure \
99         %{__enable_disable apidocs gtk-doc} \
100         --disable-silent-rules \
101         --with-html-dir=%{_gtkdocdir}
102 %{__make}
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106
107 %{__make} install \
108         DESTDIR=$RPM_BUILD_ROOT
109
110 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %post   -p /sbin/ldconfig
116 %postun -p /sbin/ldconfig
117
118 %files
119 %defattr(644,root,root,755)
120 %doc AUTHORS NEWS README
121 %attr(755,root,root) %{_bindir}/mbim-network
122 %attr(755,root,root) %{_bindir}/mbimcli
123 %attr(755,root,root) %{_libexecdir}/mbim-proxy
124 %attr(755,root,root) %{_libdir}/libmbim-glib.so.*.*.*
125 %attr(755,root,root) %ghost %{_libdir}/libmbim-glib.so.4
126 %{_libdir}/girepository-1.0/Mbim-1.0.typelib
127 %{_mandir}/man1/mbim-network.1*
128 %{_mandir}/man1/mbimcli.1*
129
130 %files devel
131 %defattr(644,root,root,755)
132 %attr(755,root,root) %{_libdir}/libmbim-glib.so
133 %{_includedir}/libmbim-glib
134 %{_datadir}/gir-1.0/Mbim-1.0.gir
135 %{_pkgconfigdir}/mbim-glib.pc
136
137 %files static
138 %defattr(644,root,root,755)
139 %{_libdir}/libmbim-glib.a
140
141 %if %{with apidocs}
142 %files apidocs
143 %defattr(644,root,root,755)
144 %{_gtkdocdir}/libmbim-glib
145 %endif
146
147 %files -n bash-completion-libmbim
148 %defattr(644,root,root,755)
149 %{bash_compdir}/mbimcli
This page took 0.087744 seconds and 2 git commands to generate.