]> git.pld-linux.org Git - packages/libmatroska.git/blob - libmatroska.spec
01f4ae2d023c9fcba5b2aaa91b900b01f8d7c9f4
[packages/libmatroska.git] / libmatroska.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4
5 Summary:        Extensible Binary Meta Language access library
6 Summary(pl.UTF-8):      Biblioteka dostępu rozszerzalnego metajęzyka binarnego
7 Name:           libmatroska
8 Version:        1.5.2
9 Release:        1
10 License:        LGPL v2.1+
11 Group:          Libraries
12 Source0:        https://dl.matroska.org/downloads/libmatroska/%{name}-%{version}.tar.xz
13 # Source0-md5:  df59a50db89296cad8662abf596355a9
14 URL:            https://www.matroska.org/
15 BuildRequires:  cmake >= 3.1.2
16 BuildRequires:  libebml-devel >= 1.3.9
17 BuildRequires:  libstdc++-devel
18 BuildRequires:  pkgconfig
19 BuildRequires:  rpmbuild(macros) >= 1.605
20 Requires:       libebml >= 1.3.9
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Matroska is an extensible open standard Audio/Video container format,
25 aiming to become the standard of Multimedia Container Formats one day.
26 It is based on EBML (Extensible Binary Meta Language), a kind of
27 binary version of XML. This way the significant advantages in terms of
28 future format extensibility are gained without breaking file support
29 in old parsers.
30
31 %description -l pl.UTF-8
32 Matroska to rozszerzalny otwarty format kodowania dźwięku i obrazu,
33 dążący do stania się pewnego dnia standardem formatów zawierających
34 multimedia. Jest on oparty na EBML (rozszerzalnym metajęzyku
35 binarnym), binarnym odpowiedniku XML-a. W ten sposób ma on przewagę
36 nad innymi formatami pod względem przyszłej rozszerzalności przy
37 jednoczesnym zachowaniu kompatybilności wstecz.
38
39 %package devel
40 Summary:        Header files for matroska library
41 Summary(pl.UTF-8):      Nagłówki dla biblioteki matroska
42 Group:          Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44 Requires:       libebml-devel >= 1.3.9
45 Requires:       libstdc++-devel
46
47 %description devel
48 Header files for matroska library.
49
50 %description devel -l pl.UTF-8
51 Nagłówki dla biblioteki matroska.
52
53 %package static
54 Summary:        Static version of matroska library
55 Summary(pl.UTF-8):      Statyczna wersja biblioteki matroska
56 Group:          Development/Libraries
57 Requires:       %{name}-devel = %{version}-%{release}
58
59 %description static
60 Static version of matroska library.
61
62 %description static -l pl.UTF-8
63 Statyczna wersja biblioteki matroska.
64
65 %prep
66 %setup -q
67
68 %build
69 # .pc file generation expects relative CMAKE_INSTALL_{INCLUDE,LIB}DIR
70 %if %{with static_libs}
71 install -d build-static
72 cd build-static
73 %cmake .. \
74         -DBUILD_SHARED_LIBS:BOOL=OFF \
75         -DCMAKE_INSTALL_INCLUDEDIR=include \
76         -DCMAKE_INSTALL_LIBDIR=%{_lib}
77
78 %{__make}
79 cd ..
80 %endif
81
82 install -d build
83 cd build
84 %cmake .. \
85         -DCMAKE_INSTALL_INCLUDEDIR=include \
86         -DCMAKE_INSTALL_LIBDIR=%{_lib}
87
88 %{__make}
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92
93 %if %{with static_libs}
94 %{__make} -C build-static install \
95         DESTDIR=$RPM_BUILD_ROOT
96 %endif
97
98 %{__make} -C build install \
99         DESTDIR=$RPM_BUILD_ROOT
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %post   -p /sbin/ldconfig
105 %postun -p /sbin/ldconfig
106
107 %files
108 %defattr(644,root,root,755)
109 %doc ChangeLog README.md
110 %attr(755,root,root) %{_libdir}/libmatroska.so.*.*.*
111 %attr(755,root,root) %ghost %{_libdir}/libmatroska.so.6
112
113 %files devel
114 %defattr(644,root,root,755)
115 %attr(755,root,root) %{_libdir}/libmatroska.so
116 %{_includedir}/matroska
117 %{_pkgconfigdir}/libmatroska.pc
118 %{_libdir}/cmake/Matroska
119
120 %if %{with static_libs}
121 %files static
122 %defattr(644,root,root,755)
123 %{_libdir}/libmatroska.a
124 %endif
This page took 0.056573 seconds and 2 git commands to generate.