]> git.pld-linux.org Git - packages/libisal.git/blob - libisal.spec
- new
[packages/libisal.git] / libisal.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 #
5 Summary:        Optimized low-level functions library for storage systems
6 Summary(pl.UTF-8):      Biblioteka zoptymalizowanych funkcji niskopoziomowych do systemów przechowywania danych
7 Name:           libisal
8 Version:        2.29.0
9 Release:        1
10 License:        BSD
11 Group:          Libraries
12 #Source0Download: https://github.com/intel/isa-l/releases
13 Source0:        https://github.com/intel/isa-l/archive/v%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  c24762075dde2a552a041d7f47c3af8a
15 Patch0:         isa-l-x86.patch
16 URL:            https://github.com/01org/isa-l
17 BuildRequires:  autoconf >= 2.69
18 BuildRequires:  automake >= 1:1.11
19 BuildRequires:  libtool >= 2:2
20 %ifarch %{ix86} %{x8664} x32
21 # nasm or yasm, whichever has higher "feature number" (max=10 for AVX512+)
22 BuildRequires:  nasm >= 2.13
23 BuildRequires:  yasm >= 1.2.0
24 %endif
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 ISA-L is a collection of optimized low-level functions targeting
29 storage applications. ISA-L includes:
30  - Erasure codes - fast block Reed-Solomon type erasure codes for any
31    encode/decode matrix in GF(2^8).
32  - CRC - Fast implementations of cyclic redundancy check. Six
33    different polynomials supported.
34  - iscsi32, ieee32, t10dif, ecma64, iso64, jones64.
35  - RAID - calculate and operate on XOR and P+Q parity found in common
36    RAID implementations.
37  - Compression - Fast deflate-compatible data compression.
38  - De-compression - Fast inflate-compatible data compression.
39
40 %description -l pl.UTF-8
41 ISA-L to zbiór zoptymalizowanych funkcji niskopoziomowych,
42 przeznaczonych do zastosowań związanych z przechowywaniem danych.
43 Biblioteka zawiera:
44 - kody korekcyjne (erasure codes) - szybkie kody korekcyjne typu
45   Reeda-Solomona dla dowolnej macierzy kodowania/dekodowania w GF(2^8)
46 - CRC - szybkie implementacje cyklicznej kontroli nadmiarowej;
47   obsługiwane jest sześć różnych wielomianów
48 - iscsi32, ieee32, t10dif, ecma64, iso64, jones64
49 - RAID - obliczanie i operacje na parzystości XOR oraz P+Q, używanych
50   w popularnych implementacjach RAID
51 - kompresja - szybka kompresja danych zgodna z metodą deflate
52 - dekompresja - szybka kompresja danych zgodna z metodą inflate
53
54 %package devel
55 Summary:        Header files for ISA-L library
56 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki ISA-L
57 Group:          Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59
60 %description devel
61 Header files for ISA-L library.
62
63 %description devel -l pl.UTF-8
64 Pliki nagłówkowe biblioteki ISA-L.
65
66 %package static
67 Summary:        Static ISA-L library
68 Summary(pl.UTF-8):      Statyczna biblioteka ISA-L
69 Group:          Development/Libraries
70 Requires:       %{name}-devel = %{version}-%{release}
71
72 %description static
73 Static ISA-L library.
74
75 %description static -l pl.UTF-8
76 Statyczna biblioteka ISA-L.
77
78 %prep
79 %setup -q -n isa-l-%{version}
80 %patch0 -p1
81
82 %build
83 %{__libtoolize}
84 %{__aclocal}
85 %{__autoconf}
86 %{__automake}
87 %configure \
88         --disable-silent-rules \
89         %{!?with_static_libs:--disable-static}
90 %{__make} \
91 %ifarch %{ix86}
92         yasm_args="-f elf32" \
93 %endif
94 %ifarch x32
95         yasm_args="-f elfx32"
96 %endif
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100
101 %{__make} install \
102         DESTDIR=$RPM_BUILD_ROOT
103
104 # no external dependencies, obsoleted by pkg-config
105 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %post   -p /sbin/ldconfig
111 %postun -p /sbin/ldconfig
112
113 %files
114 %defattr(644,root,root,755)
115 %doc LICENSE README.md Release_notes.txt
116 %attr(755,root,root) %{_bindir}/igzip
117 %attr(755,root,root) %{_libdir}/libisal.so.*.*.*
118 %attr(755,root,root) %ghost %{_libdir}/libisal.so.2
119 %{_mandir}/man1/igzip.1*
120
121 %files devel
122 %defattr(644,root,root,755)
123 %attr(755,root,root) %{_libdir}/libisal.so
124 %{_includedir}/isa-l
125 %{_includedir}/isa-l.h
126 %{_pkgconfigdir}/libisal.pc
127
128 %if %{with static_libs}
129 %files static
130 %defattr(644,root,root,755)
131 %{_libdir}/libisal.a
132 %endif
This page took 0.074571 seconds and 3 git commands to generate.