]> git.pld-linux.org Git - packages/libirecovery.git/blob - libirecovery.spec
- updated to 1.0.0
[packages/libirecovery.git] / libirecovery.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4
5 Summary:        Library and utility to talk to iBoot/iBSS via USB
6 Summary(pl.UTF-8):      Biblioteka i narzędzie do komunikacji z iBoot/iBSS po USB
7 Name:           libirecovery
8 Version:        1.0.0
9 Release:        1
10 License:        LGPL v2.1
11 Group:          Libraries
12 #Source0Download: https://libimobiledevice.org/
13 Source0:        https://github.com/libimobiledevice/libirecovery/releases/download/%{version}/%{name}-%{version}.tar.bz2
14 # Source0-md5:  ff4aff474e8d58f70b55091519c4015b
15 Patch0:         %{name}-sh.patch
16 URL:            https://github.com/libimobiledevice/libirecovery
17 BuildRequires:  autoconf >= 2.64
18 BuildRequires:  automake
19 BuildRequires:  libtool
20 BuildRequires:  libusb-devel >= 1.0.3
21 BuildRequires:  pkgconfig
22 BuildRequires:  readline-devel
23 Requires:       libusb >= 1.0.3
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 libirecovery is a cross-platform library which implements
28 communication to iBoot/iBSS found on Apple's iOS devices via USB. A
29 command-line utility is also provided.
30
31 %description -l pl.UTF-8
32 libirecovery to wieloplatformowa biblioteka implementująca komunikację
33 po USB z iBoot/iBSS, które można spotkać w urządzeniach z systemem iOS
34 Apple'a. Dołączone jest także narzędzie działające z linii poleceń.
35
36 %package devel
37 Summary:        Header files for libirecovery library
38 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libirecovery
39 Group:          Development/Libraries
40 Requires:       %{name} = %{version}-%{release}
41 Requires:       libusb-devel >= 1.0.3
42
43 %description devel
44 Header files for libirecovery library.
45
46 %description devel -l pl.UTF-8
47 Pliki nagłówkowe biblioteki libirecovery.
48
49 %package static
50 Summary:        Static libirecovery library
51 Summary(pl.UTF-8):      Statyczna biblioteka libirecovery
52 Group:          Development/Libraries
53 Requires:       %{name}-devel = %{version}-%{release}
54
55 %description static
56 Static libirecovery library.
57
58 %description static -l pl.UTF-8
59 Statyczna biblioteka libirecovery.
60
61 %prep
62 %setup -q
63 %patch0 -p1
64
65 %build
66 %{__libtoolize}
67 %{__aclocal} -I m4
68 %{__autoconf}
69 %{__autoheader}
70 %{__automake}
71 %configure \
72         %{!?with_openssl:--disable-openssl} \
73         %{!?with_static_libs:--disable-static} \
74         --disable-silent-rules \
75         --with-udev \
76         --with-udevrule='OWNER="root", GROUP="usb", MODE="0660"' \
77         --with-udevrulesdir=/lib/udev/rules.d
78
79 %{__make}
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83
84 %{__make} install \
85         DESTDIR=$RPM_BUILD_ROOT
86
87 # obsoleted by pkg-config
88 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libirecovery-1.0.la
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %post   -p /sbin/ldconfig
94 %postun -p /sbin/ldconfig
95
96 %files
97 %defattr(644,root,root,755)
98 %doc NEWS README.md
99 %attr(755,root,root) %{_bindir}/irecovery
100 %attr(755,root,root) %{_libdir}/libirecovery-1.0.so.*.*.*
101 %attr(755,root,root) %ghost %{_libdir}/libirecovery-1.0.so.3
102 /lib/udev/rules.d/39-libirecovery.rules
103
104 %files devel
105 %defattr(644,root,root,755)
106 %attr(755,root,root) %{_libdir}/libirecovery-1.0.so
107 %{_includedir}/libirecovery.h
108 %{_pkgconfigdir}/libirecovery-1.0.pc
109
110 %if %{with static_libs}
111 %files static
112 %defattr(644,root,root,755)
113 %{_libdir}/libirecovery-1.0.a
114 %endif
This page took 0.057086 seconds and 3 git commands to generate.