]> git.pld-linux.org Git - packages/libhubbub.git/blob - libhubbub.spec
- new
[packages/libhubbub.git] / libhubbub.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 Summary:        HTML5 compliant parsing library
6 Name:           libhubbub
7 Version:        0.2.0
8 Release:        1
9 License:        MIT
10 Group:          Libraries
11 Source0:        http://download.netsurf-browser.org/libs/releases/%{name}-%{version}-src.tar.gz
12 # Source0-md5:  625ea927b9134276d82960ab9bc03cb1
13 URL:            http://www.netsurf-browser.org/projects/libhubbub/
14 BuildRequires:  libparserutils-devel >= 0.1.2
15 BuildRequires:  netsurf-buildsystem
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 Hubbub is an HTML5 compliant parsing library, written in C. It was
20 developed as part of the NetSurf project and is available for use by
21 other software under the MIT licence.
22
23 The HTML5 specification defines a parsing algorithm, based on the
24 behaviour of mainstream browsers, which provides instructions for how
25 to parse all markup, both valid and invalid. As a result, Hubbub
26 parses web content well.
27
28 If you are looking for an HTML5 parser in Python or Ruby, you may wish
29 to look at html5lib.
30
31 Features:
32
33 - Parses HTML, good and bad
34 - Simple C API
35 - Fast
36 - Character encoding detection
37 - Well-tested (~90% test coverage)
38 - Portable
39 - Shared library
40
41 %package devel
42 Summary:        libhubbub library headers
43 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libhubbub
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46
47 %description devel
48 This is the libraries, include files and other resources you can use
49 to incorporate libhubbub into applications.
50
51 %description devel -l pl.UTF-8
52 Pliki nagłówkowe pozwalające na używanie biblioteki libhubbub w swoich
53 programach.
54
55 %package static
56 Summary:        libhubbub static libraries
57 Summary(pl.UTF-8):      Statyczne biblioteki libhubbub
58 Group:          Development/Libraries
59 Requires:       %{name}-devel = %{version}-%{release}
60
61 %description static
62 This is package with static libhubbub libraries.
63
64 %description static -l pl.UTF-8
65 Statyczna biblioteka libhubbub.
66
67 %prep
68 %setup -q
69
70 %build
71 CFLAGS="%{rpmcflags}"
72 LDFLAGS="%{rpmldflags}"
73 export CFLAGS
74 export LDFLAGS
75
76 %{__make} PREFIX=%{_prefix} COMPONENT_TYPE=lib-shared Q='' \
77         -Iinclude -Isrc"
78 %if %{with static_libs}
79 %{__make} PREFIX=%{_prefix} COMPONENT_TYPE=lib-static Q='' \
80         -Iinclude -Isrc"
81 %endif
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85
86 %{__make} install \
87         DESTDIR=$RPM_BUILD_ROOT \
88         PREFIX=%{_prefix} \
89         COMPONENT_TYPE=lib-shared \
90         Q=''
91
92 %if %{with static_libs}
93 %{__make} install \
94         DESTDIR=$RPM_BUILD_ROOT \
95         PREFIX=%{_prefix} \
96         COMPONENT_TYPE=lib-static \
97         Q=''
98 %endif
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %post   -p /sbin/ldconfig
104 %postun -p /sbin/ldconfig
105
106 %files
107 %defattr(644,root,root,755)
108 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
109
110 %files devel
111 %defattr(644,root,root,755)
112 %attr(755,root,root) %{_libdir}/lib*.so
113 %{_includedir}/hubbub
114 %{_pkgconfigdir}/*pc
115
116 %if %{with static_libs}
117 %files static
118 %defattr(644,root,root,755)
119 %{_libdir}/lib*.a
120 %endif
This page took 0.072253 seconds and 4 git commands to generate.