]> git.pld-linux.org Git - packages/libhsts.git/blob - libhsts.spec
5325a9ce0b8bc15ca485c2011c69ae25cb8bbbaa
[packages/libhsts.git] / libhsts.spec
1 %bcond_without  tests
2 #
3 Summary:        C library to access the HSTS preload list
4 Name:           libhsts
5 Version:        0.1.0
6 Release:        1
7 License:        BSD
8 Group:          Libraries
9 Source0:        https://gitlab.com/rockdaboot/libhsts/uploads/4753f61b5a3c6253acf4934217816e3f/%{name}-%{version}.tar.gz
10 # Source0-md5:  5599c8b2530df6b26ed5e766a8d9ed3c
11 URL:            https://gitlab.com/rockdaboot/libhsts
12 BuildRequires:  doxygen
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 The HSTS preload list is a list of domains that support HTTPS. The
17 list is compiled by Google and is utilised by Chrome, Firefox and
18 others. With this information, a HTTP client may contact a website
19 without trying a plain-text HTTP connection first. It prevents
20 interception with redirects that take place over HTTP. None of the
21 sent data will ever be unencrypted.
22
23 %package devel
24 Summary:        Header files and develpment documentation for libhsts
25 Summary(es.UTF-8):      Arquivos de cabeçalho e bibliotecas de desenvolvimento para libhsts
26 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumetacja do libhsts
27 Summary(pt_BR.UTF-8):   Bibliotecas e arquivos de inclusão para a libhsts
28 Summary(ru.UTF-8):      Хедеры и библиотеки програмиста для libhsts
29 Summary(uk.UTF-8):      Хедери та бібліотеки програміста для libhsts
30 Group:          Development/Libraries
31 Requires:       %{name} = %{?epoch}:%{version}-%{release}
32
33 %description devel
34 The HSTS preload list is a list of domains that support HTTPS. The
35 list is compiled by Google and is utilised by Chrome, Firefox and
36 others. With this information, a HTTP client may contact a website
37 without trying a plain-text HTTP connection first. It prevents
38 interception with redirects that take place over HTTP. None of the
39 sent data will ever be unencrypted.
40
41 %description devel -l pl.UTF-8
42 Pliki nagłówkowe i dokumentacja do libhsts.
43
44 %package static
45 Summary:        Static libhsts library
46 Summary(es.UTF-8):      Biblioteca estática usada no desenvolvimento de aplicativos com libhsts
47 Summary(pl.UTF-8):      Biblioteka statyczna libhsts
48 Summary(pt_BR.UTF-8):   Biblioteca estática de desenvolvimento
49 Summary(ru.UTF-8):      Статическая библиотека libhsts
50 Summary(uk.UTF-8):      Статична бібліотека libhsts
51 Group:          Development/Libraries
52 Requires:       %{name}-devel = %{?epoch}:%{version}-%{release}
53
54 %description static
55 Static libhsts library.
56
57 %description static -l pl.UTF-8
58 Biblioteka statyczna libhsts.
59
60 %description static -l ru.UTF-8
61 Статическая библиотека, необходимая для программирования с libhsts.
62
63 %description static -l uk.UTF-8
64 Статична бібліотека, необхідна для програмування з libhsts.
65
66 %prep
67 %setup -q
68
69 %build
70 %configure  \
71         --disable-silent-rules
72
73 %{__make}
74
75 %{?with_tests:%{__make} check}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79
80 %{__make} install \
81         DESTDIR=$RPM_BUILD_ROOT
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %post   -p /sbin/ldconfig
87 %postun -p /sbin/ldconfig
88
89 %files
90 %defattr(644,root,root,755)
91 %doc AUTHORS NEWS
92 %attr(755,root,root) %{_bindir}/hsts
93 %attr(755,root,root) %{_libdir}/libhsts.so.*.*
94 %attr(755,root,root) %ghost %{_libdir}/libhsts.so.0
95 %{_mandir}/man1/hsts.1*
96 %{_mandir}/man1/hsts-make-dafsa.1*
97
98 %files devel
99 %defattr(644,root,root,755)
100 %attr(755,root,root) %{_libdir}/libhsts.so
101 %{_includedir}/libhsts.h
102 %{_libdir}/libhsts.la
103 %{_pkgconfigdir}/libhsts.pc
104 %{_mandir}/man3/libhsts.3*
105
106 %files static
107 %defattr(644,root,root,755)
108 %{_libdir}/libhsts.a
This page took 0.062043 seconds and 2 git commands to generate.