]> git.pld-linux.org Git - packages/libheif.git/blob - libheif.spec
f77b87b118119260d6a9af8007e587dad0b0b88e
[packages/libheif.git] / libheif.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # don't perform "make check"
4 #
5 Summary:        ISO/IEC 23008-12:2017 HEIF file format decoder and encoder
6 Summary(pl.UTF-8):      Koder i dekoder formatu plików HEIF zgodnego z ISO/IEC 23008-12:2017
7 Name:           libheif
8 Version:        1.6.2
9 Release:        1
10 License:        LGPL v3+ (library), GPL v3+ (tools)
11 Group:          Libraries
12 #Source0Download: https://github.com/strukturag/libheif/releases/
13 Source0:        https://github.com/strukturag/libheif/releases/download/v%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  8e6084cdd575267e5f1ef33e79cf3d9c
15 Patch0:         %{name}-pc.patch
16 Patch1:         %{name}-gdkpixbuf.patch
17 URL:            https://github.com/strukturag/libheif
18 BuildRequires:  autoconf >= 2.68
19 BuildRequires:  automake >= 1:1.13
20 BuildRequires:  gdk-pixbuf2-devel >= 2.0
21 BuildRequires:  libde265-devel
22 BuildRequires:  libjpeg-devel
23 BuildRequires:  libpng-devel
24 BuildRequires:  libstdc++-devel >= 6:4.7
25 BuildRequires:  libtool >= 2:2
26 BuildRequires:  libx265-devel
27 BuildRequires:  rpmbuild(macros) >= 1.734
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 libheif is an ISO/IEC 23008-12:2017 HEIF file format decoder and
32 encoder.
33
34 HEIF is a new image file format employing HEVC (h.265) image coding
35 for the best compression ratios currently possible.
36
37 libheif makes use of libde265 for the actual image decoding and x265
38 for encoding. Alternative codecs for, e.g., AVC and JPEG can be
39 provided as plugins.
40
41 %description -l pl.UTF-8
42 libheif to koder i dekoder formatu plików HEIF, zgodnego z ISO/IEC
43 23008-12:2017.
44
45 HEIF to nowy format plików obrazów wykorzystujący kodowanie obrazu
46 HEVC (h.265) w celu osiągnięcia najwyższych dostepnych obecnie
47 współczynników kompresji.
48
49 libheif wykorzystuje libde265 do właściwego procesu dekodowania obrazu
50 oraz x265 do kodowania. Alternatywne kodeki do np. AVC czy JPEG mogą
51 być dostarczone jako wtyczki.
52
53 %package devel
54 Summary:        Header files for libheif
55 Summary(de.UTF-8):      libheif Headers
56 Summary(pl.UTF-8):      Pliki nagłówkowe libheif
57 License:        LGPL v3+
58 Group:          Development/Libraries
59 Requires:       %{name} = %{version}-%{release}
60 Requires:       libde265-devel
61 Requires:       libstdc++-devel >= 6:4.7
62 Requires:       libx265-devel
63
64 %description devel
65 The header files are only needed for development of programs using the
66 libheif library.
67
68 %description devel -l pl.UTF-8
69 Pliki nagłówkowe, potrzebne jedynie do rozwijania oprogramowania
70 wykorzystującego bibliotekę libheif.
71
72 %package static
73 Summary:        Static libheif library
74 Summary(pl.UTF-8):      Statyczna biblioteka libheif
75 License:        LGPL v3+
76 Group:          Development/Libraries
77 Requires:       %{name}-devel = %{version}-%{release}
78
79 %description static
80 Static libheif library.
81
82 %description static -l pl.UTF-8
83 Statyczna biblioteka libheif.
84
85 %package progs
86 Summary:        libheif utility programs
87 Summary(pl.UTF-8):      Programy narzędziowe libheif
88 License:        GPL v3+
89 Group:          Applications/Graphics
90 Requires:       %{name} = %{version}-%{release}
91
92 %description progs
93 This package contains utility programs to convert HEIF files.
94
95 %description progs -l pl.UTF-8
96 Ten pakiet zawiera programy narzędziowe do konwersji plików HEIF.
97
98 %package -n gdk-pixbuf2-loader-heif
99 Summary:        gdk-pixbuf plugin to handle HEIF files
100 Summary(pl.UTF-8):      Wtyczka gdk-pixbuf do obsługi plików HEIF
101 Group:          Libraries
102 Requires:       %{name} = %{version}-%{release}
103
104 %description -n gdk-pixbuf2-loader-heif
105 gdk-pixbuf plugin to handle HEIF files.
106
107 %description -n gdk-pixbuf2-loader-heif -l pl.UTF-8
108 Wtyczka gdk-pixbuf do obsługi plików HEIF.
109
110 %prep
111 %setup -q
112 %patch0 -p1
113 %patch1 -p1
114
115 %build
116 %{__libtoolize}
117 %{__aclocal} -I m4
118 %{__autoconf}
119 %{__autoheader}
120 %{__automake}
121 %configure \
122 %ifarch x32
123         --disable-go
124 %endif
125
126 %{__make}
127
128 %{?with_tests:%{__make} check}
129
130 %install
131 rm -rf $RPM_BUILD_ROOT
132
133 %{__make} install \
134         DESTDIR=$RPM_BUILD_ROOT
135
136 # module loaded via gmodule
137 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gdk-pixbuf-2.0/2.*/loaders/*.la
138 # obsoleted by pkg-config
139 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libheif.la
140
141 %clean
142 rm -rf $RPM_BUILD_ROOT
143
144 %post   -p /sbin/ldconfig
145 %postun -p /sbin/ldconfig
146
147 %files
148 %defattr(644,root,root,755)
149 %doc README.md
150 %attr(755,root,root) %{_libdir}/libheif.so.*.*.*
151 %attr(755,root,root) %ghost %{_libdir}/libheif.so.1
152
153 %files devel
154 %defattr(644,root,root,755)
155 %attr(755,root,root) %{_libdir}/libheif.so
156 %{_includedir}/libheif
157 %{_pkgconfigdir}/libheif.pc
158
159 %files static
160 %defattr(644,root,root,755)
161 %{_libdir}/libheif.a
162
163 %files progs
164 %defattr(644,root,root,755)
165 %attr(755,root,root) %{_bindir}/heif-convert
166 %attr(755,root,root) %{_bindir}/heif-enc
167 %attr(755,root,root) %{_bindir}/heif-info
168 %attr(755,root,root) %{_bindir}/heif-thumbnailer
169 %{_datadir}/mime/packages/heif.xml
170 %{_datadir}/thumbnailers/heif.thumbnailer
171 %{_mandir}/man1/heif-convert.1*
172 %{_mandir}/man1/heif-enc.1*
173 %{_mandir}/man1/heif-info.1*
174 %{_mandir}/man1/heif-thumbnailer.1*
175
176 %files -n gdk-pixbuf2-loader-heif
177 %defattr(644,root,root,755)
178 %attr(755,root,root) %{_libdir}/gdk-pixbuf-2.0/2.*/loaders/libpixbufloader-heif.so
This page took 0.048361 seconds and 2 git commands to generate.