]> git.pld-linux.org Git - packages/libhandy1.git/blob - libhandy1.spec
6a52a5b378e14f1ab3886c70f9c79a9fdc0063fc
[packages/libhandy1.git] / libhandy1.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs # API documentation
4 %bcond_without  glade   # Glade module+catalog
5 %bcond_without  vala    # Vala API
6
7 Summary:        Library with GTK+ widgets for mobile phones
8 Summary(pl.UTF-8):      Biblioteka z kontrolkami GTK+ dla telefonów komórkowych
9 Name:           libhandy1
10 Version:        1.0.3
11 Release:        1
12 License:        LGPL v2.1+
13 Group:          Libraries
14 Source0:        https://download.gnome.org/sources/libhandy/1.0/libhandy-%{version}.tar.xz
15 # Source0-md5:  b2a93c1344f4c78afc0e8a84a6642cf3
16 URL:            https://gitlab.gnome.org/GNOME/libhandy/
17 # -std=gnu11
18 BuildRequires:  gcc >= 6:4.7
19 %{?with_glade:BuildRequires:    glade-devel >= 3.38}
20 BuildRequires:  glib2-devel >= 1:2.44
21 BuildRequires:  gobject-introspection-devel
22 BuildRequires:  gtk+3-devel >= 3.24.1
23 BuildRequires:  gtk-doc
24 BuildRequires:  meson >= 0.49.0
25 BuildRequires:  ninja >= 1.5
26 BuildRequires:  pkgconfig
27 BuildRequires:  rpmbuild(macros) >= 1.752
28 BuildRequires:  tar >= 1:1.22
29 %{?with_vala:BuildRequires:     vala >= 2:0.27.0}
30 BuildRequires:  xz
31 Requires:       glib2 >= 1:2.44
32 Requires:       gtk+3 >= 3.24.1
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 libhandy provides GTK+ widgets and GObjects to ease developing
37 applications for mobile phones.
38
39 %description -l pl.UTF-8
40 libhandy dostarcza kontrolki GTK+ i GObjects, upraszczając tworzenie
41 aplikacji dla telefonów komórkowych.
42
43 %package devel
44 Summary:        Header files for libhandy library
45 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libhandy
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 Requires:       glib2-devel >= 1:2.44
49 Requires:       gtk+3-devel >= 3.24.1
50
51 %description devel
52 Header files for libhandy library
53
54 %description devel -l pl.UTF-8
55 Pliki nagłówkowe biblioteki libhandy
56
57 %package glade
58 Summary:        libhandy module for Glade
59 Summary(pl.UTF-8):      Moduł libhandy dla Glade
60 Group:          X11/Development/Libraries
61 Requires:       %{name}-devel = %{version}-%{release}
62 Requires:       glade >= 3.38
63
64 %description glade
65 libhandy module for Glade.
66
67 %description glade -l pl.UTF-8
68 Moduł libhandy dla Glade.
69
70 %package apidocs
71 Summary:        API documentation for libhandy library
72 Summary(pl.UTF-8):      Dokumentacja API biblioteki libhandy
73 Group:          Documentation
74 BuildArch:      noarch
75
76 %description apidocs
77 API documentation for libhandy library.
78
79 %description apidocs -l pl.UTF-8
80 Dokumentacja API biblioteki libhandy
81
82 %package -n vala-libhandy1
83 Summary:        Vala API for libhandy libraries
84 Summary(pl.UTF-8):      API języka Vala do bibliotek libhandy
85 Group:          Development/Libraries
86 Requires:       %{name}-devel = %{version}-%{release}
87 Requires:       vala >= 2:0.16.0
88 BuildArch:      noarch
89
90 %description -n vala-libhandy1
91 Vala API for libhandy library.
92
93 %description -n vala-libhandy1 -l pl.UTF-8
94 API języka VALA do biblioteki libhandy.
95
96 %prep
97 %setup -q -n libhandy-%{version}
98
99 %build
100 %meson build \
101         -Dexamples=false \
102         %{!?with_glade:-Dglade_catalog=disabled} \
103         %{?with_apidocs:-Dgtk_doc=true} \
104         %{!?with_vala:-Dvapi=false}
105
106 %ninja_build -C build
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110
111 %ninja_install -C build
112
113 %find_lang libhandy
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %post   -p /sbin/ldconfig
119 %postun -p /sbin/ldconfig
120
121 %files -f libhandy.lang
122 %defattr(644,root,root,755)
123 %doc AUTHORS NEWS README.md
124 %attr(755,root,root) %{_libdir}/libhandy-1.so.0
125 %{_libdir}/girepository-1.0/Handy-1.typelib
126
127 %files devel
128 %defattr(644,root,root,755)
129 %attr(755,root,root) %{_libdir}/libhandy-1.so
130 %{_includedir}/libhandy-1
131 %{_pkgconfigdir}/libhandy-1.pc
132 %{_datadir}/gir-1.0/Handy-1.gir
133
134 %if %{with glade}
135 %files glade
136 %defattr(644,root,root,755)
137 %attr(755,root,root) %{_libdir}/glade/modules/libglade-handy-1.so
138 %{_datadir}/glade/catalogs/libhandy-1.xml
139 %endif
140
141 %if %{with apidocs}
142 %files apidocs
143 %defattr(644,root,root,755)
144 %{_gtkdocdir}/libhandy-1
145 %endif
146
147 %if %{with vala}
148 %files -n vala-libhandy1
149 %defattr(644,root,root,755)
150 %{_datadir}/vala/vapi/libhandy-1.deps
151 %{_datadir}/vala/vapi/libhandy-1.vapi
152 %endif
This page took 0.047536 seconds and 2 git commands to generate.