]> git.pld-linux.org Git - packages/libhandy1.git/blob - libhandy1.spec
- updated to 1.2.0
[packages/libhandy1.git] / libhandy1.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs # API documentation
4 %bcond_without  glade   # Glade module+catalog
5 %bcond_without  vala    # Vala API
6
7 Summary:        Library with GTK+ widgets for mobile phones
8 Summary(pl.UTF-8):      Biblioteka z kontrolkami GTK+ dla telefonów komórkowych
9 Name:           libhandy1
10 Version:        1.2.0
11 Release:        1
12 License:        LGPL v2.1+
13 Group:          Libraries
14 Source0:        https://download.gnome.org/sources/libhandy/1.2/libhandy-%{version}.tar.xz
15 # Source0-md5:  18d868a77fe846b926e09508e3dce288
16 URL:            https://gitlab.gnome.org/GNOME/libhandy/
17 # -std=gnu11
18 BuildRequires:  gcc >= 6:4.7
19 %{?with_glade:BuildRequires:    glade-devel >= 3.38}
20 BuildRequires:  glib2-devel >= 1:2.44
21 BuildRequires:  gobject-introspection-devel
22 BuildRequires:  gtk+3-devel >= 3.24.1
23 BuildRequires:  gtk-doc
24 BuildRequires:  meson >= 0.49.0
25 BuildRequires:  ninja >= 1.5
26 BuildRequires:  pkgconfig
27 BuildRequires:  rpm-build >= 4.6
28 BuildRequires:  rpmbuild(macros) >= 1.752
29 BuildRequires:  tar >= 1:1.22
30 %{?with_vala:BuildRequires:     vala >= 2:0.27.0}
31 BuildRequires:  xz
32 Requires:       glib2 >= 1:2.44
33 Requires:       gtk+3 >= 3.24.1
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 libhandy provides GTK+ widgets and GObjects to ease developing
38 applications for mobile phones.
39
40 %description -l pl.UTF-8
41 libhandy dostarcza kontrolki GTK+ i GObjects, upraszczając tworzenie
42 aplikacji dla telefonów komórkowych.
43
44 %package devel
45 Summary:        Header files for libhandy library
46 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libhandy
47 Group:          Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49 Requires:       glib2-devel >= 1:2.44
50 Requires:       gtk+3-devel >= 3.24.1
51
52 %description devel
53 Header files for libhandy library
54
55 %description devel -l pl.UTF-8
56 Pliki nagłówkowe biblioteki libhandy
57
58 %package glade
59 Summary:        libhandy module for Glade
60 Summary(pl.UTF-8):      Moduł libhandy dla Glade
61 Group:          X11/Development/Libraries
62 Requires:       %{name}-devel = %{version}-%{release}
63 Requires:       glade >= 3.38
64
65 %description glade
66 libhandy module for Glade.
67
68 %description glade -l pl.UTF-8
69 Moduł libhandy dla Glade.
70
71 %package apidocs
72 Summary:        API documentation for libhandy library
73 Summary(pl.UTF-8):      Dokumentacja API biblioteki libhandy
74 Group:          Documentation
75 BuildArch:      noarch
76
77 %description apidocs
78 API documentation for libhandy library.
79
80 %description apidocs -l pl.UTF-8
81 Dokumentacja API biblioteki libhandy
82
83 %package -n vala-libhandy1
84 Summary:        Vala API for libhandy libraries
85 Summary(pl.UTF-8):      API języka Vala do bibliotek libhandy
86 Group:          Development/Libraries
87 Requires:       %{name}-devel = %{version}-%{release}
88 Requires:       vala >= 2:0.16.0
89 BuildArch:      noarch
90
91 %description -n vala-libhandy1
92 Vala API for libhandy library.
93
94 %description -n vala-libhandy1 -l pl.UTF-8
95 API języka VALA do biblioteki libhandy.
96
97 %prep
98 %setup -q -n libhandy-%{version}
99
100 %build
101 %meson build \
102         -Dexamples=false \
103         %{!?with_glade:-Dglade_catalog=disabled} \
104         %{?with_apidocs:-Dgtk_doc=true} \
105         %{!?with_vala:-Dvapi=false}
106
107 %ninja_build -C build
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111
112 %ninja_install -C build
113
114 %find_lang libhandy
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %post   -p /sbin/ldconfig
120 %postun -p /sbin/ldconfig
121
122 %files -f libhandy.lang
123 %defattr(644,root,root,755)
124 %doc AUTHORS NEWS README.md
125 %attr(755,root,root) %{_libdir}/libhandy-1.so.0
126 %{_libdir}/girepository-1.0/Handy-1.typelib
127
128 %files devel
129 %defattr(644,root,root,755)
130 %attr(755,root,root) %{_libdir}/libhandy-1.so
131 %{_includedir}/libhandy-1
132 %{_pkgconfigdir}/libhandy-1.pc
133 %{_datadir}/gir-1.0/Handy-1.gir
134
135 %if %{with glade}
136 %files glade
137 %defattr(644,root,root,755)
138 %attr(755,root,root) %{_libdir}/glade/modules/libglade-handy-1.so
139 %{_datadir}/glade/catalogs/libhandy-1.xml
140 %endif
141
142 %if %{with apidocs}
143 %files apidocs
144 %defattr(644,root,root,755)
145 %{_gtkdocdir}/libhandy-1
146 %endif
147
148 %if %{with vala}
149 %files -n vala-libhandy1
150 %defattr(644,root,root,755)
151 %{_datadir}/vala/vapi/libhandy-1.deps
152 %{_datadir}/vala/vapi/libhandy-1.vapi
153 %endif
This page took 0.068185 seconds and 3 git commands to generate.