]> git.pld-linux.org Git - packages/libhandy1.git/blob - libhandy1.spec
24a64bdc62c168bd74bd9988159382849a638e77
[packages/libhandy1.git] / libhandy1.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs # API documentation
4 %bcond_without  glade   # Glade module+catalog
5 %bcond_without  vala    # Vala API
6
7 Summary:        Library with GTK+ widgets for mobile phones
8 Summary(pl.UTF-8):      Biblioteka z kontrolkami GTK+ dla telefonów komórkowych
9 Name:           libhandy1
10 Version:        1.2.0
11 Release:        2
12 License:        LGPL v2.1+
13 Group:          Libraries
14 Source0:        https://download.gnome.org/sources/libhandy/1.2/libhandy-%{version}.tar.xz
15 # Source0-md5:  18d868a77fe846b926e09508e3dce288
16 Patch0:         %{name}-pc.patch
17 URL:            https://gitlab.gnome.org/GNOME/libhandy/
18 # -std=gnu11
19 BuildRequires:  gcc >= 6:4.7
20 %{?with_glade:BuildRequires:    glade-devel >= 3.38}
21 BuildRequires:  glib2-devel >= 1:2.44
22 BuildRequires:  gobject-introspection-devel
23 BuildRequires:  gtk+3-devel >= 3.24.1
24 BuildRequires:  gtk-doc
25 BuildRequires:  meson >= 0.49.0
26 BuildRequires:  ninja >= 1.5
27 BuildRequires:  pkgconfig
28 BuildRequires:  rpm-build >= 4.6
29 BuildRequires:  rpmbuild(macros) >= 1.752
30 BuildRequires:  tar >= 1:1.22
31 %{?with_vala:BuildRequires:     vala >= 2:0.27.0}
32 BuildRequires:  xz
33 Requires:       glib2 >= 1:2.44
34 Requires:       gtk+3 >= 3.24.1
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 libhandy provides GTK+ widgets and GObjects to ease developing
39 applications for mobile phones.
40
41 %description -l pl.UTF-8
42 libhandy dostarcza kontrolki GTK+ i GObjects, upraszczając tworzenie
43 aplikacji dla telefonów komórkowych.
44
45 %package devel
46 Summary:        Header files for libhandy library
47 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libhandy
48 Group:          Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50 Requires:       glib2-devel >= 1:2.44
51 Requires:       gtk+3-devel >= 3.24.1
52
53 %description devel
54 Header files for libhandy library
55
56 %description devel -l pl.UTF-8
57 Pliki nagłówkowe biblioteki libhandy
58
59 %package glade
60 Summary:        libhandy module for Glade
61 Summary(pl.UTF-8):      Moduł libhandy dla Glade
62 Group:          X11/Development/Libraries
63 Requires:       %{name}-devel = %{version}-%{release}
64 Requires:       glade >= 3.38
65
66 %description glade
67 libhandy module for Glade.
68
69 %description glade -l pl.UTF-8
70 Moduł libhandy dla Glade.
71
72 %package apidocs
73 Summary:        API documentation for libhandy library
74 Summary(pl.UTF-8):      Dokumentacja API biblioteki libhandy
75 Group:          Documentation
76 BuildArch:      noarch
77
78 %description apidocs
79 API documentation for libhandy library.
80
81 %description apidocs -l pl.UTF-8
82 Dokumentacja API biblioteki libhandy
83
84 %package -n vala-libhandy1
85 Summary:        Vala API for libhandy libraries
86 Summary(pl.UTF-8):      API języka Vala do bibliotek libhandy
87 Group:          Development/Libraries
88 Requires:       %{name}-devel = %{version}-%{release}
89 Requires:       vala >= 2:0.16.0
90 BuildArch:      noarch
91
92 %description -n vala-libhandy1
93 Vala API for libhandy library.
94
95 %description -n vala-libhandy1 -l pl.UTF-8
96 API języka VALA do biblioteki libhandy.
97
98 %prep
99 %setup -q -n libhandy-%{version}
100 %patch0 -p1
101
102 %build
103 %meson build \
104         -Dexamples=false \
105         %{!?with_glade:-Dglade_catalog=disabled} \
106         %{?with_apidocs:-Dgtk_doc=true} \
107         %{!?with_vala:-Dvapi=false}
108
109 %ninja_build -C build
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113
114 %ninja_install -C build
115
116 %find_lang libhandy
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %post   -p /sbin/ldconfig
122 %postun -p /sbin/ldconfig
123
124 %files -f libhandy.lang
125 %defattr(644,root,root,755)
126 %doc AUTHORS NEWS README.md
127 %attr(755,root,root) %{_libdir}/libhandy-1.so.0
128 %{_libdir}/girepository-1.0/Handy-1.typelib
129
130 %files devel
131 %defattr(644,root,root,755)
132 %attr(755,root,root) %{_libdir}/libhandy-1.so
133 %{_includedir}/libhandy-1
134 %{_pkgconfigdir}/libhandy-1.pc
135 %{_datadir}/gir-1.0/Handy-1.gir
136
137 %if %{with glade}
138 %files glade
139 %defattr(644,root,root,755)
140 %attr(755,root,root) %{_libdir}/glade/modules/libglade-handy-1.so
141 %{_datadir}/glade/catalogs/libhandy-1.xml
142 %endif
143
144 %if %{with apidocs}
145 %files apidocs
146 %defattr(644,root,root,755)
147 %{_gtkdocdir}/libhandy-1
148 %endif
149
150 %if %{with vala}
151 %files -n vala-libhandy1
152 %defattr(644,root,root,755)
153 %{_datadir}/vala/vapi/libhandy-1.deps
154 %{_datadir}/vala/vapi/libhandy-1.vapi
155 %endif
This page took 0.087424 seconds and 2 git commands to generate.