]> git.pld-linux.org Git - packages/libhandy.git/blob - libhandy.spec
- added glade3.38 patch (adapt to glade 3.38 API changes); release 4
[packages/libhandy.git] / libhandy.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs # API documentation
4 %bcond_without  glade   # Glade module+catalog
5 %bcond_without  vala    # Vala API
6
7 Summary:        Library with GTK+ widgets for mobile phones
8 Summary(pl.UTF-8):      Biblioteka z kontrolkami GTK+ dla telefonów komórkowych
9 Name:           libhandy
10 Version:        0.0.13
11 Release:        4
12 License:        LGPL v2.1+
13 Group:          Libraries
14 #Source0Download: https://source.puri.sm/Librem5/libhandy/-/tags
15 Source0:        https://source.puri.sm/Librem5/libhandy/-/archive/v%{version}/%{name}-v%{version}.tar.bz2
16 # Source0-md5:  932ba6e80908c7579fa0392d6e0d0ceb
17 Patch0:         %{name}-glade3.36.patch
18 Patch1:         %{name}-glade3.38.patch
19 URL:            https://source.puri.sm/Librem5/libhandy/
20 # -std=gnu11
21 BuildRequires:  gcc >= 6:4.7
22 %{?with_glade:BuildRequires:    glade-devel >= 3.36}
23 BuildRequires:  glib2-devel >= 1:2.44
24 BuildRequires:  gobject-introspection-devel
25 BuildRequires:  gtk+3-devel >= 3.24.1
26 BuildRequires:  gtk-doc
27 BuildRequires:  meson >= 0.49.0
28 BuildRequires:  ninja >= 1.5
29 BuildRequires:  pkgconfig
30 BuildRequires:  rpmbuild(macros) >= 1.736
31 %{?with_vala:BuildRequires:     vala >= 2:0.27.0}
32 Requires:       glib2 >= 1:2.44
33 Requires:       gtk+3 >= 3.24.1
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 libhandy provides GTK+ widgets and GObjects to ease developing
38 applications for mobile phones.
39
40 %description -l pl.UTF-8
41 libhandy dostarcza kontrolki GTK+ i GObjects, upraszczając tworzenie
42 aplikacji dla telefonów komórkowych.
43
44 %package devel
45 Summary:        Header files for libhandy library
46 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libhandy
47 Group:          Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49 Requires:       glib2-devel >= 1:2.44
50 Requires:       gtk+3-devel >= 3.24.1
51
52 %description devel
53 Header files for libhandy library
54
55 %description devel -l pl.UTF-8
56 Pliki nagłówkowe biblioteki libhandy
57
58 %package glade
59 Summary:        libhandy module for Glade
60 Summary(pl.UTF-8):      Moduł libhandy dla Glade
61 Group:          X11/Development/Libraries
62 Requires:       %{name}-devel = %{version}-%{release}
63 Requires:       glade >= 3.36
64
65 %description glade
66 libhandy module for Glade.
67
68 %description glade -l pl.UTF-8
69 Moduł libhandy dla Glade.
70
71 %package apidocs
72 Summary:        API documentation for libhandy library
73 Summary(pl.UTF-8):      Dokumentacja API biblioteki libhandy
74 Group:          Documentation
75 %if "%{_rpmversion}" >= "4.6"
76 BuildArch:      noarch
77 %endif
78
79 %description apidocs
80 API documentation for libhandy library.
81
82 %description apidocs -l pl.UTF-8
83 Dokumentacja API biblioteki libhandy
84
85 %package -n vala-libhandy
86 Summary:        Vala API for libhandy libraries
87 Summary(pl.UTF-8):      API języka Vala do bibliotek libhandy
88 Group:          Development/Libraries
89 Requires:       %{name}-devel = %{version}-%{release}
90 Requires:       vala >= 2:0.16.0
91 %if "%{_rpmversion}" >= "4.6"
92 BuildArch:      noarch
93 %endif
94
95 %description -n vala-libhandy
96 Vala API for libhandy library.
97
98 %description -n vala-libhandy -l pl.UTF-8
99 API języka VALA do biblioteki libhandy.
100
101 %prep
102 %setup -q -n %{name}-v%{version}
103 %patch0 -p1
104 %patch1 -p1
105
106 %build
107 %meson build \
108         -Dexamples=false \
109         %{!?with_glade:-Dglade_catalog=disabled} \
110         %{?with_apidocs:-Dgtk_doc=true} \
111         %{!?with_vala:-Dvapi=false}
112
113 %ninja_build -C build
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117
118 %ninja_install -C build
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %post   -p /sbin/ldconfig
124 %postun -p /sbin/ldconfig
125
126 %files
127 %defattr(644,root,root,755)
128 %doc AUTHORS README.md
129 %attr(755,root,root) %{_libdir}/libhandy-0.0.so.0
130 %{_libdir}/girepository-1.0/Handy-0.0.typelib
131
132 %files devel
133 %defattr(644,root,root,755)
134 %attr(755,root,root) %{_libdir}/libhandy-0.0.so
135 %{_includedir}/libhandy-0.0
136 %{_pkgconfigdir}/libhandy-0.0.pc
137 %{_datadir}/gir-1.0/Handy-0.0.gir
138
139 %if %{with glade}
140 %files glade
141 %defattr(644,root,root,755)
142 %attr(755,root,root) %{_libdir}/glade/modules/libglade-handy.so
143 %{_datadir}/glade/catalogs/libhandy.xml
144 %endif
145
146 %if %{with apidocs}
147 %files apidocs
148 %defattr(644,root,root,755)
149 %{_gtkdocdir}/libhandy
150 %endif
151
152 %if %{with vala}
153 %files -n vala-libhandy
154 %defattr(644,root,root,755)
155 %{_datadir}/vala/vapi/libhandy-0.0.deps
156 %{_datadir}/vala/vapi/libhandy-0.0.vapi
157 %endif
This page took 0.080397 seconds and 3 git commands to generate.