]> git.pld-linux.org Git - packages/libhandy.git/blob - libhandy.spec
- release 3 (libgladeui soname change)
[packages/libhandy.git] / libhandy.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs # API documentation
4 %bcond_without  glade   # Glade module+catalog
5 %bcond_without  vala    # Vala API
6
7 Summary:        Library with GTK+ widgets for mobile phones
8 Summary(pl.UTF-8):      Biblioteka z kontrolkami GTK+ dla telefonów komórkowych
9 Name:           libhandy
10 Version:        0.0.13
11 Release:        3
12 License:        LGPL v2.1+
13 Group:          Libraries
14 #Source0Download: https://source.puri.sm/Librem5/libhandy/-/tags
15 Source0:        https://source.puri.sm/Librem5/libhandy/-/archive/v%{version}/%{name}-v%{version}.tar.bz2
16 # Source0-md5:  932ba6e80908c7579fa0392d6e0d0ceb
17 Patch0:         %{name}-glade3.36.patch
18 URL:            https://source.puri.sm/Librem5/libhandy/
19 # -std=gnu11
20 BuildRequires:  gcc >= 6:4.7
21 %{?with_glade:BuildRequires:    glade-devel >= 3.36}
22 BuildRequires:  glib2-devel >= 1:2.44
23 BuildRequires:  gobject-introspection-devel
24 BuildRequires:  gtk+3-devel >= 3.24.1
25 BuildRequires:  gtk-doc
26 BuildRequires:  meson >= 0.49.0
27 BuildRequires:  ninja >= 1.5
28 BuildRequires:  pkgconfig
29 BuildRequires:  rpmbuild(macros) >= 1.736
30 %{?with_vala:BuildRequires:     vala >= 2:0.27.0}
31 Requires:       glib2 >= 1:2.44
32 Requires:       gtk+3 >= 3.24.1
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 libhandy provides GTK+ widgets and GObjects to ease developing
37 applications for mobile phones.
38
39 %description -l pl.UTF-8
40 libhandy dostarcza kontrolki GTK+ i GObjects, upraszczając tworzenie
41 aplikacji dla telefonów komórkowych.
42
43 %package devel
44 Summary:        Header files for libhandy library
45 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libhandy
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 Requires:       glib2-devel >= 1:2.44
49 Requires:       gtk+3-devel >= 3.24.1
50
51 %description devel
52 Header files for libhandy library
53
54 %description devel -l pl.UTF-8
55 Pliki nagłówkowe biblioteki libhandy
56
57 %package glade
58 Summary:        libhandy module for Glade
59 Summary(pl.UTF-8):      Moduł libhandy dla Glade
60 Group:          X11/Development/Libraries
61 Requires:       %{name}-devel = %{version}-%{release}
62 Requires:       glade >= 3.36
63
64 %description glade
65 libhandy module for Glade.
66
67 %description glade -l pl.UTF-8
68 Moduł libhandy dla Glade.
69
70 %package apidocs
71 Summary:        API documentation for libhandy library
72 Summary(pl.UTF-8):      Dokumentacja API biblioteki libhandy
73 Group:          Documentation
74 %if "%{_rpmversion}" >= "4.6"
75 BuildArch:      noarch
76 %endif
77
78 %description apidocs
79 API documentation for libhandy library.
80
81 %description apidocs -l pl.UTF-8
82 Dokumentacja API biblioteki libhandy
83
84 %package -n vala-libhandy
85 Summary:        Vala API for libhandy libraries
86 Summary(pl.UTF-8):      API języka Vala do bibliotek libhandy
87 Group:          Development/Libraries
88 Requires:       %{name}-devel = %{version}-%{release}
89 Requires:       vala >= 2:0.16.0
90 %if "%{_rpmversion}" >= "4.6"
91 BuildArch:      noarch
92 %endif
93
94 %description -n vala-libhandy
95 Vala API for libhandy library.
96
97 %description -n vala-libhandy -l pl.UTF-8
98 API języka VALA do biblioteki libhandy.
99
100 %prep
101 %setup -q -n %{name}-v%{version}
102 %patch0 -p1
103
104 %build
105 %meson build \
106         -Dexamples=false \
107         %{!?with_glade:-Dglade_catalog=disabled} \
108         %{?with_apidocs:-Dgtk_doc=true} \
109         %{!?with_vala:-Dvapi=false}
110
111 %ninja_build -C build
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115
116 %ninja_install -C build
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %post   -p /sbin/ldconfig
122 %postun -p /sbin/ldconfig
123
124 %files
125 %defattr(644,root,root,755)
126 %doc AUTHORS README.md
127 %attr(755,root,root) %{_libdir}/libhandy-0.0.so.0
128 %{_libdir}/girepository-1.0/Handy-0.0.typelib
129
130 %files devel
131 %defattr(644,root,root,755)
132 %attr(755,root,root) %{_libdir}/libhandy-0.0.so
133 %{_includedir}/libhandy-0.0
134 %{_pkgconfigdir}/libhandy-0.0.pc
135 %{_datadir}/gir-1.0/Handy-0.0.gir
136
137 %if %{with glade}
138 %files glade
139 %defattr(644,root,root,755)
140 %attr(755,root,root) %{_libdir}/glade/modules/libglade-handy.so
141 %{_datadir}/glade/catalogs/libhandy.xml
142 %endif
143
144 %if %{with apidocs}
145 %files apidocs
146 %defattr(644,root,root,755)
147 %{_gtkdocdir}/libhandy
148 %endif
149
150 %if %{with vala}
151 %files -n vala-libhandy
152 %defattr(644,root,root,755)
153 %{_datadir}/vala/vapi/libhandy-0.0.deps
154 %{_datadir}/vala/vapi/libhandy-0.0.vapi
155 %endif
This page took 0.670995 seconds and 3 git commands to generate.