]> git.pld-linux.org Git - packages/libgta.git/blob - libgta.spec
db00ea10695edd816785b369b9e9e468e97e0c9c
[packages/libgta.git] / libgta.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4
5 Summary:        Library to read and write Generic Tagged Arrays (GTAs)
6 Summary(pl.UTF-8):      Biblioteka od odczytu i zapisu GTA (ogólnych tablic etykietowanych)
7 Name:           libgta
8 Version:        1.2.1
9 Release:        1
10 License:        LGPL v2.1+
11 Group:          Libraries
12 #Source0Download: https://marlam.de/gta/download/
13 Source0:        https://marlam.de/gta/releases/%{name}-%{version}.tar.xz
14 # Source0-md5:  84fbd03883fb8cdcf7e80d0966f0b1c5
15 URL:            https://marlam.de/gta/
16 BuildRequires:  bzip2-devel
17 %{?with_apidocs:BuildRequires:  doxygen}
18 BuildRequires:  rpmbuild(macros) >= 1.752
19 BuildRequires:  tar >= 1:1.22
20 BuildRequires:  xz
21 BuildRequires:  xz-devel
22 BuildRequires:  zlib-devel
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Libgta is a portable library that implements the Generic Tagged Array
27 (GTA) file format. This file format has the following features:
28
29 - GTAs can store any kind of data in multidimensional arrays
30 - GTAs can optionally use simple tags to store rich metadata
31 - GTAs are streamable, which allows direct reading from and writing to
32   pipes, network sockets, and other non-seekable media
33 - GTA files allow easy out-of-core data access for very large arrays.
34
35 %description -l pl.UTF-8
36 libgta to przenośna biblioteka zawierająca implementację formatu GTA
37 (Generic Tagged Array - ogólnych tablic etykietowanych). Format ten ma
38 następujące cechy:
39 - może przechowywać dowolny rodzaj danych w tablicach wielowymiarowych
40 - opcjonalnie może wykorzystywać proste etykiety do przechowywania
41   bogatych metadanych
42 - daje się obrabiać strumieniowo, co pozwala na bezpośredni odczyt i
43   zapis do potoków, gniazd sieciowych i innych nośników nie
44   obsługujących przewijania
45 - możliwy jest łatwy dostęp do danych nawet dla bardzo dużych tablic.
46
47 %package devel
48 Summary:        Header files for GTA library
49 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GTA
50 Group:          Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52 Requires:       bzip2-devel
53 Requires:       xz-devel
54 Requires:       zlib-devel
55
56 %description devel
57 Header files for GTA library.
58
59 %description devel -l pl.UTF-8
60 Pliki nagłówkowe biblioteki GTA.
61
62 %package static
63 Summary:        Static GTA library
64 Summary(pl.UTF-8):      Statyczna biblioteka GTA
65 Group:          Development/Libraries
66 Requires:       %{name}-devel = %{version}-%{release}
67
68 %description static
69 Static GTA library.
70
71 %description static -l pl.UTF-8
72 Statyczna biblioteka GTA.
73
74 %package apidocs
75 Summary:        GTA API documentation
76 Summary(pl.UTF-8):      Dokumentacja API biblioteki GTA
77 Group:          Documentation
78 %{?noarchpackage}
79
80 %description apidocs
81 API and internal documentation for GTA library.
82
83 %description apidocs -l pl.UTF-8
84 Dokumentacja API biblioteki GTA.
85
86 %prep
87 %setup -q
88
89 %build
90 %configure \
91         %{!?with_apidocs:--disable-reference} \
92         --disable-silent-rules \
93         --with-compression
94 %{__make}
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98
99 %{__make} install \
100         DESTDIR=$RPM_BUILD_ROOT
101
102 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
103 %{__mv} $RPM_BUILD_ROOT%{_docdir}/%{name}/example-*.c* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
104 # packaged in -apidocs
105 %{?with_apidocs:%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}/reference}
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %post   -p /sbin/ldconfig
111 %postun -p /sbin/ldconfig
112
113 %files
114 %defattr(644,root,root,755)
115 %doc AUTHORS ChangeLog README
116 %attr(755,root,root) %{_libdir}/libgta.so.*.*.*
117 %attr(755,root,root) %ghost %{_libdir}/libgta.so.1
118
119 %files devel
120 %defattr(644,root,root,755)
121 %attr(755,root,root) %{_libdir}/libgta.so
122 %{_includedir}/gta
123 %{_pkgconfigdir}/gta.pc
124 %{_examplesdir}/%{name}-%{version}
125
126 %files static
127 %defattr(644,root,root,755)
128 %{_libdir}/libgta.a
129
130 %if %{with apidocs}
131 %files apidocs
132 %defattr(644,root,root,755)
133 %doc doc/reference/*.{css,html,js,png}
134 %endif
This page took 0.075125 seconds and 2 git commands to generate.