]> git.pld-linux.org Git - packages/libgsystem.git/blob - libgsystem.spec
e0f92cb2c178a32c1e5cd23791a0b96ee9b4a501
[packages/libgsystem.git] / libgsystem.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 #
5 Summary:        LibGSystem - GIO-based library for use by operating system components
6 Summary(pl.UTF-8):      LibGSystem - biblioteka oparta na GIO przeznaczona dla komponentów systemu operacyjnego
7 Name:           libgsystem
8 Version:        2014.1
9 Release:        1
10 License:        LGPL v2+
11 Group:          Libraries
12 Source0:        http://ftp.gnome.org/pub/GNOME/sources/libgsystem/%{version}/%{name}-%{version}.tar.xz
13 # Source0-md5:  5d4d4cd4ae0cf7f774d87ebccf5615f2
14 URL:            https://wiki.gnome.org/Projects/LibGSystem
15 BuildRequires:  attr-devel
16 BuildRequires:  autoconf >= 2.63
17 BuildRequires:  automake >= 1:1.11
18 BuildRequires:  glib2-devel >= 1:2.34.0
19 BuildRequires:  gobject-introspection-devel >= 1.34.0
20 BuildRequires:  gtk-doc >= 1.15
21 BuildRequires:  libtool >= 2:2.2.4
22 BuildRequires:  libxslt-progs
23 BuildRequires:  pkgconfig
24 BuildRequires:  systemd-devel >= 1:200
25 BuildRequires:  tar >= 1:1.22
26 BuildRequires:  xz
27 Requires:       glib2 >= 1:2.34.0
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 LibGSystem is a GIO-based library, targeted primarily for use by
32 operating system components. It has a few goals:
33 - Provide macros for the GCC attribute(cleanup) that work with GLib
34   data types. Using these can dramatically simplify local memory
35   management inside functions.
36 - Prototype and test APIs that will eventually be in GLib. Currently
37   these include "GSSubprocess" for launching child processes, and
38   some GFile helpers.
39 - Provide Linux-specific APIs in a nicer GLib fashion, such as
40   O_NOATIME.
41
42 %description -l pl.UTF-8
43 LibGSystem to oparta na GIO biblioteka przeznaczona głównie do
44 wykorzystania w komponentach systemu operacyjnego. Ma kilka zadań:
45 - dostarczenie makr dla attribute(cleanup) w GCC, działających z
46   typami danych GLiba; przy ich użyciu można znacząco uprościć
47   lokalne zarządzanie pamięcią wewnątrz funkcji
48 - prototypowe i testowe API, które ewentualnie znajdą się w GLibie;
49   obecnie obejmują "GSSubprocess" do uruchamiania procesów potomnych
50   oraz kilka funkcji pomocniczych GFile
51 - dostarczenie API specyficznych dla Linuksa w stylu GLiba, takich jak
52   O_NOATIME.
53
54 %package devel
55 Summary:        Header files for libgsystem library
56 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libgsystem
57 Group:          Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59 Requires:       glib2-devel >= 1:2.34.0
60
61 %description devel
62 Header files for libgsystem library.
63
64 %description devel -l pl.UTF-8
65 Pliki nagłówkowe biblioteki libgsystem.
66
67 %package static
68 Summary:        Static libgsystem library
69 Summary(pl.UTF-8):      Statyczna biblioteka libgsystem
70 Group:          Development/Libraries
71 Requires:       %{name}-devel = %{version}-%{release}
72
73 %description static
74 Static libgsystem library.
75
76 %description static -l pl.UTF-8
77 Statyczna biblioteka libgsystem.
78
79 %package apidocs
80 Summary:        GSystem API documentation
81 Summary(pl.UTF-8):      Dokumentacja API biblioteki GSystem
82 Group:          Documentation
83
84 %description apidocs
85 GSystem API documentation.
86
87 %description apidocs -l pl.UTF-8
88 Dokumentacja API biblioteki GSystem.
89
90 %package -n dracut-libgsystem
91 Summary:        GSystem support for Dracut
92 Summary(pl.UTF-8):      Obsługa GSystem dla Dracuta
93 Group:          Applications/System
94 Requires:       %{name} = %{version}-%{release}
95 Requires:       dracut
96
97 %description -n dracut-libgsystem
98 GSystem support for Dracut.
99
100 %description -n dracut-libgsystem -l pl.UTF-8
101 Obsługa GSystem dla Dracuta.
102
103 %prep
104 %setup -q
105
106 %build
107 # rebuild ac/am to get as-needed working
108 %{__libtoolize}
109 %{__gtkdocize}
110 %{__aclocal} -I m4
111 %{__autoconf}
112 %{__autoheader}
113 %{__automake}
114 %configure \
115         --enable-gtk-doc \
116         --disable-silent-rules \
117         %{?with_static_libs:--enable-static} \
118         --with-html-dir=%{_gtkdocdir}
119 %{__make}
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123
124 %{__make} install \
125         DESTDIR=$RPM_BUILD_ROOT
126
127 # obsoleted by pkg-config
128 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgsystem.la
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %post   -p /sbin/ldconfig
134 %postun -p /sbin/ldconfig
135
136 %files
137 %defattr(644,root,root,755)
138 %doc README
139 %attr(755,root,root) %{_libdir}/libgsystem.so.*.*.*
140 %attr(755,root,root) %ghost %{_libdir}/libgsystem.so.0
141 %{_libdir}/girepository-1.0/GSystem-1.0.typelib
142
143 %files devel
144 %defattr(644,root,root,755)
145 %attr(755,root,root) %{_libdir}/libgsystem.so
146 %{_includedir}/libgsystem
147 %{_datadir}/gir-1.0/GSystem-1.0.gir
148 %{_pkgconfigdir}/libgsystem.pc
149
150 %if %{with static_libs}
151 %files static
152 %defattr(644,root,root,755)
153 %{_libdir}/libgsystem.a
154 %endif
This page took 0.070909 seconds and 2 git commands to generate.