]> git.pld-linux.org Git - packages/libgsf.git/blob - libgsf.spec
- merged from DEVEL
[packages/libgsf.git] / libgsf.spec
1 #
2 # Conditional build:
3 %bcond_without  gnome   # without GNOME extensions packages
4 #
5 Summary:        GNOME Structured File library
6 Summary(pl):    Biblioteka plików strukturalnych dla GNOME
7 Name:           libgsf
8 Version:        1.13.2
9 Release:        1
10 License:        GPL v2
11 Group:          Libraries
12 Source0:        http://ftp.gnome.org/pub/gnome/sources/libgsf/1.13/%{name}-%{version}.tar.bz2
13 # Source0-md5:  0894afd88f9e43eada27e52cb22cd0f1
14 URL:            http://www.gnumeric.org/
15 %{?with_gnome:BuildRequires:    ORBit2-devel >= 2.8.1}
16 BuildRequires:  autoconf >= 2.54
17 BuildRequires:  automake
18 BuildRequires:  bzip2-devel
19 BuildRequires:  glib2-devel >= 1:2.6.0
20 %{?with_gnome:BuildRequires:    gnome-vfs2-devel >= 2.4.0}
21 BuildRequires:  gtk-doc >= 1.0
22 %{?with_gnome:BuildRequires:    libbonobo-devel >= 2.4.0}
23 BuildRequires:  libtool
24 BuildRequires:  libxml2-devel >= 2.4.16
25 BuildRequires:  pkgconfig
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 A library for reading and writing structured files (e.g. MS OLE and
30 Zip).
31
32 %description -l pl
33 Biblioteka do odczytu i zapisu plików strukturalnych (np. MS OLE lub
34 Zip).
35
36 %package devel
37 Summary:        Support files necessary to compile applications with libgsf
38 Summary(pl):    Pliki do kompilowania aplikacji u¿ywaj±cych libgsf
39 Group:          Development/Libraries
40 Requires:       %{name} = %{version}-%{release}
41 Requires:       bzip2-devel
42 Requires:       glib2-devel >= 1:2.6.0
43 Requires:       gtk-doc-common >= 1.0
44 Requires:       libxml2-devel >= 2.4.16
45
46 %description devel
47 Headers, and support files necessary to compile applications using
48 libgsf.
49
50 %description devel -l pl
51 Pliki nag³ówkowe i inne potrzebne do kompilowania aplikacji
52 u¿ywaj±cych libgsf.
53
54 %package static
55 Summary:        libgsf static libraries
56 Summary(pl):    Statyczne biblioteki libgsf
57 Group:          Development/Libraries
58 Requires:       %{name}-devel = %{version}-%{release}
59
60 %description static
61 Package contains static libraries.
62
63 %description static -l pl
64 Statyczne biblioteki libgsf.
65
66 %package gnome
67 Summary:        GNOME specific extensions to libgsf
68 Summary(pl):    Rozszerzenia GNOME do biblioteki libgsf
69 Group:          Libraries
70 Requires:       %{name} = %{version}-%{release}
71
72 %description gnome
73 GNOME specific extensions to libgsf.
74
75 %description gnome -l pl
76 Rozszerzenia GNOME do biblioteki libgsf.
77
78 %package gnome-devel
79 Summary:        libgsf-gnome header files
80 Summary(pl):    Pliki nag³ówkowe libgsf-gnome
81 Group:          Development/Libraries
82 Requires:       %{name}-devel = %{version}-%{release}
83 Requires:       %{name}-gnome = %{version}-%{release}
84 Requires:       gnome-vfs2-devel >= 2.4.0
85 Requires:       libbonobo-devel >= 2.4.0
86
87 %description gnome-devel
88 libgsf-gnome header files.
89
90 %description gnome-devel -l pl
91 Pliki nag³ówkowe libgsf-gnome.
92
93 %package gnome-static
94 Summary:        Static libgsf-gnome library
95 Summary(pl):    Statyczna biblioteka libgsf-gnome
96 Group:          Development/Libraries
97 Requires:       %{name}-gnome-devel = %{version}-%{release}
98
99 %description gnome-static
100 Static libgsf-gnome library.
101
102 %description gnome-static -l pl
103 Statyczna biblioteka libgsf-gnome.
104
105 %package -n gsf-office-thumbnailer
106 Summary:        Simple document thumbnailer
107 Summary(pl):    Prosty generator miniatur dokumentów
108 Group:          X11/Applications
109 Requires(post,preun):   GConf2
110 Requires:       %{name}-gnome = %{version}-%{release}
111
112 %description -n gsf-office-thumbnailer
113 Simple document thumbnailer.
114
115 %description -n gsf-office-thumbnailer -l pl
116 Prosty program tworz±cy miniaturki dokumentów.
117
118 %prep
119 %setup -q
120
121 %build
122 rm -f acinclude.m4
123 %{__libtoolize}
124 %{__aclocal}
125 %{__autoconf}
126 %{__automake}
127 %configure \
128         --enable-gtk-doc \
129         --with-html-dir=%{_gtkdocdir}/%{name} \
130         %{!?with_gnome:--without-gnome}
131 %{__make}
132
133 %install
134 rm -rf $RPM_BUILD_ROOT
135
136 %{__make} install \
137         DESTDIR=$RPM_BUILD_ROOT
138
139 rm -rf $RPM_BUILD_ROOT%{_includedir}/%{name}-1/gsf-win32
140
141 %clean
142 rm -rf $RPM_BUILD_ROOT
143
144 %post   -p /sbin/ldconfig
145 %postun -p /sbin/ldconfig
146
147 %post   gnome -p /sbin/ldconfig
148 %postun gnome -p /sbin/ldconfig
149
150 %post -n gsf-office-thumbnailer
151 %gconf_schema_install gsf-office-thumbnailer.schemas
152
153 %preun -n gsf-office-thumbnailer
154 %gconf_schema_uninstall gsf-office-thumbnailer.schemas
155
156 %files
157 %defattr(644,root,root,755)
158 %doc AUTHORS README NEWS
159 %attr(755,root,root) %{_libdir}/libgsf-?.so.*.*
160
161 %files devel
162 %defattr(644,root,root,755)
163 %{_libdir}/libgsf-?.la
164 %attr(755,root,root) %{_libdir}/libgsf-?.so
165 %dir %{_includedir}/libgsf-1
166 %{_includedir}/libgsf-1/gsf
167 %{_pkgconfigdir}/libgsf-?.pc
168 %{_gtkdocdir}/%{name}
169
170 %files static
171 %defattr(644,root,root,755)
172 %{_libdir}/libgsf-?.a
173
174 %if %{with gnome}
175 %files gnome
176 %defattr(644,root,root,755)
177 %attr(755,root,root) %{_libdir}/libgsf-gnome-?.so.*.*
178
179 %files gnome-devel
180 %defattr(644,root,root,755)
181 %{_libdir}/libgsf-gnome-?.la
182 %attr(755,root,root) %{_libdir}/libgsf-gnome-?.so
183 %{_includedir}/libgsf-1/gsf-gnome
184 %{_pkgconfigdir}/libgsf-gnome-?.pc
185
186 %files gnome-static
187 %defattr(644,root,root,755)
188 %{_libdir}/libgsf-gnome-?.a
189 %endif
190
191 %files -n gsf-office-thumbnailer
192 %defattr(644,root,root,755)
193 %attr(755,root,root) %{_bindir}/gsf-office-thumbnailer
194 %{_sysconfdir}/gconf/schemas/gsf-office-thumbnailer.schemas
195 %{_mandir}/man1/gsf-office-thumbnailer.1*
This page took 0.155137 seconds and 4 git commands to generate.