]> git.pld-linux.org Git - packages/libgsf.git/blob - libgsf.spec
- 1.11.0 (it's stable for gnumeric 1.4.0)
[packages/libgsf.git] / libgsf.spec
1 #
2 # Conditional build:
3 %bcond_without  gnome   # without GNOME extensions packages
4 #
5 Summary:        GNOME Structured File library
6 Summary(pl):    Biblioteka plików strukturalnych dla GNOME
7 Name:           libgsf
8 Version:        1.11.0
9 Release:        1
10 License:        GPL v2
11 Group:          Libraries
12 Source0:        http://ftp.gnome.org/pub/gnome/sources/%{name}/1.11/%{name}-%{version}.tar.bz2
13 # Source0-md5:  75a8a807d02e7940714dbc5da477ed96
14 URL:            http://www.gnumeric.org/
15 %{?with_gnome:BuildRequires:    ORBit2-devel >= 2.8.1}
16 BuildRequires:  autoconf >= 2.52
17 BuildRequires:  automake
18 BuildRequires:  bzip2-devel
19 BuildRequires:  glib2-devel >= 2.2.3
20 %{?with_gnome:BuildRequires:    gnome-vfs2-devel >= 2.4.0}
21 BuildRequires:  gtk-doc >= 1.0
22 %{?with_gnome:BuildRequires:    libbonobo-devel >= 2.4.0}
23 BuildRequires:  libtool
24 BuildRequires:  libxml2-devel >= 2.4.16
25 BuildRequires:  pkgconfig
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 A library for reading and writing structured files (e.g. MS OLE and
30 Zip).
31
32 %description -l pl
33 Biblioteka do odczytu i zapisu plików strukturalnych (np. MS OLE lub
34 Zip).
35
36 %package devel
37 Summary:        Support files necessary to compile applications with libgsf
38 Summary(pl):    Pliki do kompilowania aplikacji u¿ywaj±cych libgsf
39 Group:          Development/Libraries
40 Requires:       %{name} = %{version}-%{release}
41 Requires:       bzip2-devel
42 Requires:       glib2-devel >= 2.2.3
43 Requires:       gtk-doc-common >= 1.0
44 Requires:       libxml2-devel >= 2.5.11
45
46 %description devel
47 Headers, and support files necessary to compile applications using
48 libgsf.
49
50 %description devel -l pl
51 Pliki nag³ówkowe i inne potrzebne do kompilowania aplikacji
52 u¿ywaj±cych libgsf.
53
54 %package static
55 Summary:        libgsf static libraries
56 Summary(pl):    Statyczne biblioteki libgsf
57 Group:          Development/Libraries
58 Requires:       %{name}-devel = %{version}-%{release}
59
60 %description static
61 Package contains static libraries.
62
63 %description static -l pl
64 Statyczne biblioteki libgsf.
65
66 %package gnome
67 Summary:        GNOME specific extensions to libgsf
68 Summary(pl):    Rozszerzenia GNOME do biblioteki libgsf
69 Group:          Libraries
70 Requires:       %{name} = %{version}-%{release}
71
72 %description gnome
73 GNOME specific extensions to libgsf.
74
75 %description gnome -l pl
76 Rozszerzenia GNOME do biblioteki libgsf.
77
78 %package gnome-devel
79 Summary:        libgsf-gnome header files
80 Summary(pl):    Pliki nag³ówkowe libgsf-gnome
81 Group:          Development/Libraries
82 Requires:       %{name}-devel = %{version}-%{release}
83 Requires:       %{name}-gnome = %{version}-%{release}
84 Requires:       gnome-vfs2-devel >= 2.4.0
85 Requires:       libbonobo-devel >= 2.4.0
86
87 %description gnome-devel
88 libgsf-gnome header files.
89
90 %description gnome-devel -l pl
91 Pliki nag³ówkowe libgsf-gnome.
92
93 %package gnome-static
94 Summary:        Static libgsf-gnome library
95 Summary(pl):    Statyczna biblioteka libgsf-gnome
96 Group:          Development/Libraries
97 Requires:       %{name}-gnome-devel = %{version}-%{release}
98
99 %description gnome-static
100 Static libgsf-gnome library.
101
102 %description gnome-static -l pl
103 Statyczna biblioteka libgsf-gnome.
104
105 %prep
106 %setup -q
107
108 %build
109 rm -f acinclude.m4
110 %{__libtoolize}
111 %{__aclocal}
112 %{__autoconf}
113 %{__automake}
114 %configure \
115         --enable-gtk-doc \
116         --with-html-dir=%{_gtkdocdir}/%{name} \
117         %{!?with_gnome:--without-gnome}
118
119 %{__make}
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123
124 %{__make} install \
125         DESTDIR=$RPM_BUILD_ROOT
126
127 rm -rf $RPM_BUILD_ROOT%{_includedir}/%{name}-1/gsf-win32
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %post   -p /sbin/ldconfig
133 %postun -p /sbin/ldconfig
134
135 %post   gnome -p /sbin/ldconfig
136 %postun gnome -p /sbin/ldconfig
137
138 %files
139 %defattr(644,root,root,755)
140 %doc AUTHORS README NEWS
141 %attr(755,root,root) %{_libdir}/libgsf-?.so.*.*
142
143 %files devel
144 %defattr(644,root,root,755)
145 %{_libdir}/libgsf-?.la
146 %attr(755,root,root) %{_libdir}/libgsf-?.so
147 %dir %{_includedir}/libgsf-1
148 %{_includedir}/libgsf-1/gsf
149 %{_pkgconfigdir}/libgsf-?.pc
150 %{_gtkdocdir}/%{name}
151
152 %files static
153 %defattr(644,root,root,755)
154 %{_libdir}/libgsf-?.a
155
156 %if %{with gnome}
157 %files gnome
158 %defattr(644,root,root,755)
159 %attr(755,root,root) %{_libdir}/libgsf-gnome-?.so.*.*
160
161 %files gnome-devel
162 %defattr(644,root,root,755)
163 %{_libdir}/libgsf-gnome-?.la
164 %attr(755,root,root) %{_libdir}/libgsf-gnome-?.so
165 %{_includedir}/libgsf-1/gsf-gnome
166 %{_pkgconfigdir}/libgsf-gnome-?.pc
167
168 %files gnome-static
169 %defattr(644,root,root,755)
170 %{_libdir}/libgsf-gnome-?.a
171 %endif
This page took 0.066047 seconds and 4 git commands to generate.