]> git.pld-linux.org Git - packages/libgsf.git/blob - libgsf.spec
- make BR human readable
[packages/libgsf.git] / libgsf.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_without  gnome           # without GNOME extensions packages
5 #
6 Summary:        GNOME Structured File library
7 Summary(pl):    Biblioteka plików strukturalnych dla GNOME
8 Name:           libgsf
9 Version:        1.13.3
10 Release:        1
11 License:        GPL v2
12 Group:          Libraries
13 Source0:        http://ftp.gnome.org/pub/gnome/sources/libgsf/1.13/%{name}-%{version}.tar.bz2
14 # Source0-md5:  b35e95f6bd7b8add9981b6cf6336674a
15 Patch0:         %{name}-no_GConf2_macros.patch
16 URL:            http://www.gnumeric.org/
17 BuildRequires:  autoconf >= 2.54
18 BuildRequires:  automake
19 BuildRequires:  bzip2-devel
20 BuildRequires:  glib2-devel >= 1:2.6.0
21 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.0}
22 BuildRequires:  gtk-doc-automake
23 BuildRequires:  libtool
24 BuildRequires:  libxml2-devel >= 2.4.16
25 BuildRequires:  pkgconfig
26 # GNOME BR
27 %if %{with gnome}
28 BuildRequires:  GConf2-devel
29 BuildRequires:  ORBit2-devel >= 2.8.1
30 BuildRequires:  gnome-vfs2-devel >= 2.4.0
31 BuildRequires:  libbonobo-devel >= 2.4.0
32 %endif
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 A library for reading and writing structured files (e.g. MS OLE and
37 Zip).
38
39 %description -l pl
40 Biblioteka do odczytu i zapisu plików strukturalnych (np. MS OLE lub
41 Zip).
42
43 %package devel
44 Summary:        Support files necessary to compile applications with libgsf
45 Summary(pl):    Pliki do kompilowania aplikacji u¿ywaj±cych libgsf
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 Requires:       bzip2-devel
49 Requires:       glib2-devel >= 1:2.6.0
50 Requires:       gtk-doc-common >= 1.0
51 Requires:       libxml2-devel >= 2.4.16
52
53 %description devel
54 Headers, and support files necessary to compile applications using
55 libgsf.
56
57 %description devel -l pl
58 Pliki nag³ówkowe i inne potrzebne do kompilowania aplikacji
59 u¿ywaj±cych libgsf.
60
61 %package static
62 Summary:        libgsf static libraries
63 Summary(pl):    Statyczne biblioteki libgsf
64 Group:          Development/Libraries
65 Requires:       %{name}-devel = %{version}-%{release}
66
67 %description static
68 Package contains static libraries.
69
70 %description static -l pl
71 Statyczne biblioteki libgsf.
72
73 %package gnome
74 Summary:        GNOME specific extensions to libgsf
75 Summary(pl):    Rozszerzenia GNOME do biblioteki libgsf
76 Group:          Libraries
77 Requires:       %{name} = %{version}-%{release}
78
79 %description gnome
80 GNOME specific extensions to libgsf.
81
82 %description gnome -l pl
83 Rozszerzenia GNOME do biblioteki libgsf.
84
85 %package gnome-devel
86 Summary:        libgsf-gnome header files
87 Summary(pl):    Pliki nag³ówkowe libgsf-gnome
88 Group:          Development/Libraries
89 Requires:       %{name}-devel = %{version}-%{release}
90 Requires:       %{name}-gnome = %{version}-%{release}
91 Requires:       gnome-vfs2-devel >= 2.4.0
92 Requires:       libbonobo-devel >= 2.4.0
93
94 %description gnome-devel
95 libgsf-gnome header files.
96
97 %description gnome-devel -l pl
98 Pliki nag³ówkowe libgsf-gnome.
99
100 %package gnome-static
101 Summary:        Static libgsf-gnome library
102 Summary(pl):    Statyczna biblioteka libgsf-gnome
103 Group:          Development/Libraries
104 Requires:       %{name}-gnome-devel = %{version}-%{release}
105
106 %description gnome-static
107 Static libgsf-gnome library.
108
109 %description gnome-static -l pl
110 Statyczna biblioteka libgsf-gnome.
111
112 %package -n gsf-office-thumbnailer
113 Summary:        Simple document thumbnailer
114 Summary(pl):    Prosty generator miniatur dokumentów
115 Group:          X11/Applications
116 Requires(post,preun):   GConf2
117 Requires:       %{name}-gnome = %{version}-%{release}
118
119 %description -n gsf-office-thumbnailer
120 Simple document thumbnailer.
121
122 %description -n gsf-office-thumbnailer -l pl
123 Prosty program tworz±cy miniaturki dokumentów.
124
125 %prep
126 %setup -q
127 %{!?with_gnome:%patch0 -p1}
128
129 %build
130 rm -f acinclude.m4
131 %{__libtoolize}
132 %{__aclocal}
133 %{__autoconf}
134 %{__automake}
135 %configure \
136         %{?with_apidocs:--enable-gtk-doc} \
137         --with-html-dir=%{_gtkdocdir}/%{name} \
138         %{!?with_gnome:--without-gnome}
139 %{__make}
140
141 %install
142 rm -rf $RPM_BUILD_ROOT
143
144 %{__make} install \
145         DESTDIR=$RPM_BUILD_ROOT
146
147 rm -rf $RPM_BUILD_ROOT%{_includedir}/%{name}-1/gsf-win32
148
149 %clean
150 rm -rf $RPM_BUILD_ROOT
151
152 %post   -p /sbin/ldconfig
153 %postun -p /sbin/ldconfig
154
155 %post   gnome -p /sbin/ldconfig
156 %postun gnome -p /sbin/ldconfig
157
158 %post -n gsf-office-thumbnailer
159 %gconf_schema_install gsf-office-thumbnailer.schemas
160
161 %preun -n gsf-office-thumbnailer
162 %gconf_schema_uninstall gsf-office-thumbnailer.schemas
163
164 %files
165 %defattr(644,root,root,755)
166 %doc AUTHORS README NEWS
167 %attr(755,root,root) %{_libdir}/libgsf-?.so.*.*
168
169 %files devel
170 %defattr(644,root,root,755)
171 %{_libdir}/libgsf-?.la
172 %attr(755,root,root) %{_libdir}/libgsf-?.so
173 %dir %{_includedir}/libgsf-1
174 %{_includedir}/libgsf-1/gsf
175 %{_pkgconfigdir}/libgsf-?.pc
176 %{_gtkdocdir}/%{name}
177
178 %files static
179 %defattr(644,root,root,755)
180 %{_libdir}/libgsf-?.a
181
182 %if %{with gnome}
183 %files gnome
184 %defattr(644,root,root,755)
185 %attr(755,root,root) %{_libdir}/libgsf-gnome-?.so.*.*
186
187 %files gnome-devel
188 %defattr(644,root,root,755)
189 %{_libdir}/libgsf-gnome-?.la
190 %attr(755,root,root) %{_libdir}/libgsf-gnome-?.so
191 %{_includedir}/libgsf-1/gsf-gnome
192 %{_pkgconfigdir}/libgsf-gnome-?.pc
193
194 %files gnome-static
195 %defattr(644,root,root,755)
196 %{_libdir}/libgsf-gnome-?.a
197
198 %files -n gsf-office-thumbnailer
199 %defattr(644,root,root,755)
200 %attr(755,root,root) %{_bindir}/gsf-office-thumbnailer
201 %{_sysconfdir}/gconf/schemas/gsf-office-thumbnailer.schemas
202 %{_mandir}/man1/gsf-office-thumbnailer.1*
203 %endif
This page took 0.184953 seconds and 4 git commands to generate.