]> git.pld-linux.org Git - packages/libgsf.git/blob - libgsf.spec
- Added apidocs bcond
[packages/libgsf.git] / libgsf.spec
1 #
2 # Conditional build:
3 %bcond_without apidocs          # disable gtk-doc
4 %bcond_without gnome            # without GNOME extensions packages
5 #
6 Summary:        GNOME Structured File library
7 Summary(pl):    Biblioteka plików strukturalnych dla GNOME
8 Name:           libgsf
9 Version:        1.13.3
10 Release:        1
11 License:        GPL v2
12 Group:          Libraries
13 Source0:        http://ftp.gnome.org/pub/gnome/sources/libgsf/1.13/%{name}-%{version}.tar.bz2
14 # Source0-md5:  b35e95f6bd7b8add9981b6cf6336674a
15 Patch0:         %{name}-no_GConf2_macros.patch
16 URL:            http://www.gnumeric.org/
17 %{?with_gnome:BuildRequires:    GConf2-devel}
18 %{?with_gnome:BuildRequires:    ORBit2-devel >= 2.8.1}
19 BuildRequires:  autoconf >= 2.54
20 BuildRequires:  automake
21 BuildRequires:  bzip2-devel
22 BuildRequires:  glib2-devel >= 1:2.6.0
23 %{?with_gnome:BuildRequires:    gnome-vfs2-devel >= 2.4.0}
24 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.0}
25 BuildRequires:  gtk-doc-automake
26 %{?with_gnome:BuildRequires:    libbonobo-devel >= 2.4.0}
27 BuildRequires:  libtool
28 BuildRequires:  libxml2-devel >= 2.4.16
29 BuildRequires:  pkgconfig
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 A library for reading and writing structured files (e.g. MS OLE and
34 Zip).
35
36 %description -l pl
37 Biblioteka do odczytu i zapisu plików strukturalnych (np. MS OLE lub
38 Zip).
39
40 %package devel
41 Summary:        Support files necessary to compile applications with libgsf
42 Summary(pl):    Pliki do kompilowania aplikacji u¿ywaj±cych libgsf
43 Group:          Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45 Requires:       bzip2-devel
46 Requires:       glib2-devel >= 1:2.6.0
47 Requires:       gtk-doc-common >= 1.0
48 Requires:       libxml2-devel >= 2.4.16
49
50 %description devel
51 Headers, and support files necessary to compile applications using
52 libgsf.
53
54 %description devel -l pl
55 Pliki nag³ówkowe i inne potrzebne do kompilowania aplikacji
56 u¿ywaj±cych libgsf.
57
58 %package static
59 Summary:        libgsf static libraries
60 Summary(pl):    Statyczne biblioteki libgsf
61 Group:          Development/Libraries
62 Requires:       %{name}-devel = %{version}-%{release}
63
64 %description static
65 Package contains static libraries.
66
67 %description static -l pl
68 Statyczne biblioteki libgsf.
69
70 %package gnome
71 Summary:        GNOME specific extensions to libgsf
72 Summary(pl):    Rozszerzenia GNOME do biblioteki libgsf
73 Group:          Libraries
74 Requires:       %{name} = %{version}-%{release}
75
76 %description gnome
77 GNOME specific extensions to libgsf.
78
79 %description gnome -l pl
80 Rozszerzenia GNOME do biblioteki libgsf.
81
82 %package gnome-devel
83 Summary:        libgsf-gnome header files
84 Summary(pl):    Pliki nag³ówkowe libgsf-gnome
85 Group:          Development/Libraries
86 Requires:       %{name}-devel = %{version}-%{release}
87 Requires:       %{name}-gnome = %{version}-%{release}
88 Requires:       gnome-vfs2-devel >= 2.4.0
89 Requires:       libbonobo-devel >= 2.4.0
90
91 %description gnome-devel
92 libgsf-gnome header files.
93
94 %description gnome-devel -l pl
95 Pliki nag³ówkowe libgsf-gnome.
96
97 %package gnome-static
98 Summary:        Static libgsf-gnome library
99 Summary(pl):    Statyczna biblioteka libgsf-gnome
100 Group:          Development/Libraries
101 Requires:       %{name}-gnome-devel = %{version}-%{release}
102
103 %description gnome-static
104 Static libgsf-gnome library.
105
106 %description gnome-static -l pl
107 Statyczna biblioteka libgsf-gnome.
108
109 %package -n gsf-office-thumbnailer
110 Summary:        Simple document thumbnailer
111 Summary(pl):    Prosty generator miniatur dokumentów
112 Group:          X11/Applications
113 Requires(post,preun):   GConf2
114 Requires:       %{name}-gnome = %{version}-%{release}
115
116 %description -n gsf-office-thumbnailer
117 Simple document thumbnailer.
118
119 %description -n gsf-office-thumbnailer -l pl
120 Prosty program tworz±cy miniaturki dokumentów.
121
122 %prep
123 %setup -q
124 %{!?with_gnome:%patch0 -p1}
125
126 %build
127 rm -f acinclude.m4
128 %{__libtoolize}
129 %{__aclocal}
130 %{__autoconf}
131 %{__automake}
132 %configure \
133         %?with_apidocs:--enable-gtk-doc} \
134         --with-html-dir=%{_gtkdocdir}/%{name} \
135         %{!?with_gnome:--without-gnome}
136 %{__make}
137
138 %install
139 rm -rf $RPM_BUILD_ROOT
140
141 %{__make} install \
142         DESTDIR=$RPM_BUILD_ROOT
143
144 rm -rf $RPM_BUILD_ROOT%{_includedir}/%{name}-1/gsf-win32
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %post   -p /sbin/ldconfig
150 %postun -p /sbin/ldconfig
151
152 %post   gnome -p /sbin/ldconfig
153 %postun gnome -p /sbin/ldconfig
154
155 %post -n gsf-office-thumbnailer
156 %gconf_schema_install gsf-office-thumbnailer.schemas
157
158 %preun -n gsf-office-thumbnailer
159 %gconf_schema_uninstall gsf-office-thumbnailer.schemas
160
161 %files
162 %defattr(644,root,root,755)
163 %doc AUTHORS README NEWS
164 %attr(755,root,root) %{_libdir}/libgsf-?.so.*.*
165
166 %files devel
167 %defattr(644,root,root,755)
168 %{_libdir}/libgsf-?.la
169 %attr(755,root,root) %{_libdir}/libgsf-?.so
170 %dir %{_includedir}/libgsf-1
171 %{_includedir}/libgsf-1/gsf
172 %{_pkgconfigdir}/libgsf-?.pc
173 %{_gtkdocdir}/%{name}
174
175 %files static
176 %defattr(644,root,root,755)
177 %{_libdir}/libgsf-?.a
178
179 %if %{with gnome}
180 %files gnome
181 %defattr(644,root,root,755)
182 %attr(755,root,root) %{_libdir}/libgsf-gnome-?.so.*.*
183
184 %files gnome-devel
185 %defattr(644,root,root,755)
186 %{_libdir}/libgsf-gnome-?.la
187 %attr(755,root,root) %{_libdir}/libgsf-gnome-?.so
188 %{_includedir}/libgsf-1/gsf-gnome
189 %{_pkgconfigdir}/libgsf-gnome-?.pc
190
191 %files gnome-static
192 %defattr(644,root,root,755)
193 %{_libdir}/libgsf-gnome-?.a
194
195 %files -n gsf-office-thumbnailer
196 %defattr(644,root,root,755)
197 %attr(755,root,root) %{_bindir}/gsf-office-thumbnailer
198 %{_sysconfdir}/gconf/schemas/gsf-office-thumbnailer.schemas
199 %{_mandir}/man1/gsf-office-thumbnailer.1*
200 %endif
This page took 0.049642 seconds and 4 git commands to generate.