]> git.pld-linux.org Git - packages/libgsf.git/blob - libgsf.spec
- updated to 1.14.2
[packages/libgsf.git] / libgsf.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_without  gnome           # without GNOME extensions packages
5 #
6 Summary:        GNOME Structured File library
7 Summary(pl):    Biblioteka plików strukturalnych dla GNOME
8 Name:           libgsf
9 Version:        1.14.2
10 Release:        1
11 License:        GPL v2
12 Group:          Libraries
13 Source0:        http://ftp.gnome.org/pub/gnome/sources/libgsf/1.14/%{name}-%{version}.tar.bz2
14 # Source0-md5:  aea16a8408b65f95c308b0db3e3d3d47
15 Patch0:         %{name}-no_GConf2_macros.patch
16 URL:            http://www.gnumeric.org/
17 BuildRequires:  GConf2-devel >= 2.14.0
18 BuildRequires:  ORBit2-devel >= 1:2.14.3
19 BuildRequires:  autoconf >= 2.54
20 BuildRequires:  automake
21 BuildRequires:  bzip2-devel
22 BuildRequires:  glib2-devel >= 1:2.12.4
23 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.7}
24 BuildRequires:  gtk-doc-automake
25 BuildRequires:  libtool
26 BuildRequires:  libxml2-devel >= 1:2.6.26
27 BuildRequires:  pkgconfig
28 BuildRequires:  python-pygtk-devel >= 2:2.10.2
29 # GNOME BR
30 %if %{with gnome}
31 BuildRequires:  gnome-vfs2-devel >= 2.16.1
32 %endif
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 A library for reading and writing structured files (e.g. MS OLE and
37 Zip).
38
39 %description -l pl
40 Biblioteka do odczytu i zapisu plików strukturalnych (np. MS OLE lub
41 Zip).
42
43 %package devel
44 Summary:        Support files necessary to compile applications with libgsf
45 Summary(pl):    Pliki do kompilowania aplikacji u¿ywaj±cych libgsf
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 Requires:       bzip2-devel
49 Requires:       glib2-devel >= 1:2.12.4
50 Requires:       gtk-doc-common >= 1.7
51 Requires:       libxml2-devel >= 1:2.6.26
52
53 %description devel
54 Headers, and support files necessary to compile applications using
55 libgsf.
56
57 %description devel -l pl
58 Pliki nag³ówkowe i inne potrzebne do kompilowania aplikacji
59 u¿ywaj±cych libgsf.
60
61 %package static
62 Summary:        libgsf static libraries
63 Summary(pl):    Statyczne biblioteki libgsf
64 Group:          Development/Libraries
65 Requires:       %{name}-devel = %{version}-%{release}
66
67 %description static
68 Package contains static libraries.
69
70 %description static -l pl
71 Statyczne biblioteki libgsf.
72
73 %package gnome
74 Summary:        GNOME specific extensions to libgsf
75 Summary(pl):    Rozszerzenia GNOME do biblioteki libgsf
76 Group:          Libraries
77 Requires:       %{name} = %{version}-%{release}
78
79 %description gnome
80 GNOME specific extensions to libgsf.
81
82 %description gnome -l pl
83 Rozszerzenia GNOME do biblioteki libgsf.
84
85 %package gnome-devel
86 Summary:        libgsf-gnome header files
87 Summary(pl):    Pliki nag³ówkowe libgsf-gnome
88 Group:          Development/Libraries
89 Requires:       %{name}-devel = %{version}-%{release}
90 Requires:       %{name}-gnome = %{version}-%{release}
91 Requires:       gnome-vfs2-devel >= 2.16.1
92
93 %description gnome-devel
94 libgsf-gnome header files.
95
96 %description gnome-devel -l pl
97 Pliki nag³ówkowe libgsf-gnome.
98
99 %package gnome-static
100 Summary:        Static libgsf-gnome library
101 Summary(pl):    Statyczna biblioteka libgsf-gnome
102 Group:          Development/Libraries
103 Requires:       %{name}-gnome-devel = %{version}-%{release}
104
105 %description gnome-static
106 Static libgsf-gnome library.
107
108 %description gnome-static -l pl
109 Statyczna biblioteka libgsf-gnome.
110
111 %package -n gsf-office-thumbnailer
112 Summary:        Simple document thumbnailer
113 Summary(pl):    Prosty generator miniatur dokumentów
114 Group:          X11/Applications
115 Requires(post,preun):   GConf2
116 Requires:       %{name}-gnome = %{version}-%{release}
117
118 %description -n gsf-office-thumbnailer
119 Simple document thumbnailer.
120
121 %description -n gsf-office-thumbnailer -l pl
122 Prosty program tworz±cy miniaturki dokumentów.
123
124 %package -n python-gsf
125 Summary:        Python gsf module
126 Summary(pl):    Modu³ gsf dla pythona
127 Group:          Libraries
128 %pyrequires_eq  python-libs
129 Requires:       %{name} = %{version}-%{release}
130 Requires:       python-pygtk-gtk >= 2:2.10.2
131
132 %description -n python-gsf
133 Python gsf library.
134
135 %description -n python-gsf -l pl
136 Biblioteka gsf dla pythona.
137
138 %package -n python-gsf-gnome
139 Summary:        Python gsf-gnome module
140 Summary(pl):    Modu³ gsf-gnome dla pythona
141 Group:          Libraries
142 %pyrequires_eq  python-libs
143 Requires:       python-gsf = %{version}-%{release}
144
145 %description -n python-gsf-gnome
146 Python gsf-gnome library.
147
148 %description -n python-gsf-gnome -l pl
149 Biblioteka gsf-gnome dla pythona.
150
151 %prep
152 %setup -q
153 %{!?with_gnome:%patch0 -p1}
154
155 %build
156 rm -f acinclude.m4
157 %{__libtoolize}
158 %{__aclocal} -I m4
159 %{__autoconf}
160 %{__automake}
161 %configure \
162         %{?with_apidocs:--enable-gtk-doc} \
163         --with-html-dir=%{_gtkdocdir}/%{name} \
164         %{!?with_gnome:--without-gnome}
165 %{__make}
166
167 %install
168 rm -rf $RPM_BUILD_ROOT
169
170 %{__make} install \
171         DESTDIR=$RPM_BUILD_ROOT
172
173 rm -rf $RPM_BUILD_ROOT%{_includedir}/%{name}-1/gsf-win32
174 rm -f $RPM_BUILD_ROOT%{py_sitedir}/gsf/*.{la,a}
175 rm -f $RPM_BUILD_ROOT%{py_sitescriptdir}/gsf/*.py
176
177 %find_lang %{name}
178
179 %clean
180 rm -rf $RPM_BUILD_ROOT
181
182 %post   -p /sbin/ldconfig
183 %postun -p /sbin/ldconfig
184
185 %post   gnome -p /sbin/ldconfig
186 %postun gnome -p /sbin/ldconfig
187
188 %post -n gsf-office-thumbnailer
189 %gconf_schema_install gsf-office-thumbnailer.schemas
190
191 %preun -n gsf-office-thumbnailer
192 %gconf_schema_uninstall gsf-office-thumbnailer.schemas
193
194 %files -f %{name}.lang
195 %defattr(644,root,root,755)
196 %doc AUTHORS README NEWS
197 %attr(755,root,root) %{_bindir}/gsf
198 %attr(755,root,root) %{_bindir}/gsf-vba-dump
199 %attr(755,root,root) %{_libdir}/libgsf-?.so.*.*
200
201 %files devel
202 %defattr(644,root,root,755)
203 %{_libdir}/libgsf-?.la
204 %attr(755,root,root) %{_libdir}/libgsf-?.so
205 %dir %{_includedir}/libgsf-1
206 %{_includedir}/libgsf-1/gsf
207 %{_pkgconfigdir}/libgsf-?.pc
208 %{_gtkdocdir}/%{name}
209
210 %files static
211 %defattr(644,root,root,755)
212 %{_libdir}/libgsf-?.a
213
214 %if %{with gnome}
215 %files gnome
216 %defattr(644,root,root,755)
217 %attr(755,root,root) %{_libdir}/libgsf-gnome-?.so.*.*
218
219 %files gnome-devel
220 %defattr(644,root,root,755)
221 %{_libdir}/libgsf-gnome-?.la
222 %attr(755,root,root) %{_libdir}/libgsf-gnome-?.so
223 %{_includedir}/libgsf-1/gsf-gnome
224 %{_pkgconfigdir}/libgsf-gnome-?.pc
225
226 %files gnome-static
227 %defattr(644,root,root,755)
228 %{_libdir}/libgsf-gnome-?.a
229
230 %files -n gsf-office-thumbnailer
231 %defattr(644,root,root,755)
232 %attr(755,root,root) %{_bindir}/gsf-office-thumbnailer
233 %{_sysconfdir}/gconf/schemas/gsf-office-thumbnailer.schemas
234 %{_mandir}/man1/gsf-office-thumbnailer.1*
235 %endif
236
237 %files -n python-gsf
238 %defattr(644,root,root,755)
239 %dir %{py_sitedir}/gsf
240 %attr(755,root,root) %{py_sitedir}/gsf/_gsfmodule.so
241 %dir %{py_sitescriptdir}/gsf
242 %{py_sitescriptdir}/gsf/*.py[co]
243
244 %if %{with gnome}
245 %files -n python-gsf-gnome
246 %defattr(644,root,root,755)
247 %attr(755,root,root) %{py_sitedir}/gsf/gnomemodule.so
248 %endif
This page took 0.073642 seconds and 4 git commands to generate.