]> git.pld-linux.org Git - packages/libgpod.git/blob - libgpod.spec
- release 2
[packages/libgpod.git] / libgpod.spec
1 # TODO
2 # check: http://fred.uwcs.co.uk/diff (from http://www.fredemmott.co.uk/blog_121)
3 Summary:        Shared library to access the contents of an iPod
4 Summary(pl.UTF-8):      Biblioteka współdzielona do dostępu do zawartości iPodów
5 Name:           libgpod
6 Version:        0.7.2
7 Release:        2
8 License:        GPL v2
9 Group:          Libraries
10 Source0:        http://dl.sourceforge.net/gtkpod/%{name}-%{version}.tar.gz
11 # Source0-md5:  1ec69c3a19fb071b1639cdcaf68463c1
12 Patch0:         %{name}-gcc43.patch
13 URL:            http://www.gtkpod.org/libgpod.html
14 BuildRequires:  autoconf >= 2.52
15 BuildRequires:  automake
16 BuildRequires:  dbus-glib-devel >= 0.30
17 BuildRequires:  docbook-dtd412-xml
18 BuildRequires:  gettext-devel
19 BuildRequires:  gtk+2-devel >= 2.0
20 BuildRequires:  gtk-doc >= 1.0
21 BuildRequires:  hal-devel < 0.6
22 BuildRequires:  hal-devel >= 0.5.7.1
23 BuildRequires:  intltool >= 0.35
24 BuildRequires:  libtool
25 BuildRequires:  pkgconfig
26 BuildRequires:  python-devel >= 2.1.1
27 BuildRequires:  python-eyeD3 >= 0.6.6
28 BuildRequires:  python-mutagen >= 1.8
29 BuildRequires:  rpm-pythonprov
30 BuildRequires:  sg3_utils-devel >= 1.26
31 BuildRequires:  swig-python >= 1.3.24
32 # for noinst test only
33 #BuildRequires: taglib-devel
34 Suggests:       hal-libgpod = %{version}-%{release}
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 libgpod is a library meant to abstract access to an iPod content. It
39 provides an easy to use API to retrieve the list of files and playlist
40 stored on an iPod, to modify them and to save them back to the iPod.
41
42 %description -l pl.UTF-8
43 libgpod to biblioteka mająca na celu wyabstrahowanie dostępu do
44 zawartości iPodów. Udostępnia łatwe w użyciu API do pobierania listy
45 plików i playlist zapisanych na iPodzie, modyfikowania ich i
46 zapisywania z powrotem na iPoda.
47
48 %package -n hal-libgpod
49 Summary:        HAL callout program for iPod devices
50 Summary(pl.UTF-8):      Program wywoływany przez HAL dla urządzeń iPod
51 Group:          Applications/System
52 Requires:       %{name} = %{version}-%{release}
53 Requires:       hal >= 0.5
54
55 %description -n hal-libgpod
56 HAL callout program to initialize iPod devices for libgpod library.
57
58 %description -n hal-libgpod -l pl.UTF-8
59 Program wywoływany przez HAL do przygotowywania urządzeń iPod do
60 użytku z biblioteką libgpod.
61
62 %package devel
63 Summary:        Header files for libgpod library
64 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libgpod
65 Group:          Development/Libraries
66 Requires:       %{name} = %{version}-%{release}
67 Requires:       dbus-glib-devel >= 0.30
68 Requires:       gtk+2-devel >= 2.0
69 Requires:       hal-devel >= 0.5.7.1
70
71 %description devel
72 This is the package containing the header files for libgpod library.
73
74 %description devel -l pl.UTF-8
75 Ten pakiet zawiera pliki nagłówkowe biblioteki libgpod.
76
77 %package static
78 Summary:        Static libgpod library
79 Summary(pl.UTF-8):      Statyczna biblioteka libgpod
80 Group:          Development/Libraries
81 Requires:       %{name}-devel = %{version}-%{release}
82
83 %description static
84 Static libgpod library.
85
86 %description static -l pl.UTF-8
87 Statyczna biblioteka libgpod.
88
89 %package apidocs
90 Summary:        libgpod API documentation
91 Summary(pl.UTF-8):      Dokumentacja API biblioteki libgpod
92 Group:          Documentation
93 Requires:       gtk-doc-common
94
95 %description apidocs
96 libgpod API documentation.
97
98 %description apidocs -l pl.UTF-8
99 Dokumentacja API biblioteki libgpod.
100
101 %package -n python-gpod
102 Summary:        Libraries for libgpod access from Python
103 Summary(pl.UTF-8):      Biblioteki Pythona umożliwiające korzystanie z libgpod
104 Group:          Development/Languages/Python
105 Requires:       %{name} = %{version}-%{release}
106 Requires:       python-eyeD3 >= 0.6.6
107 %pyrequires_eq  python-libs
108
109 %description -n python-gpod
110 This is the libgpod Python support package.
111
112 %description -n python-gpod -l pl.UTF-8
113 Biblioteki umożliwiające korzystanie z libgpod z poziomu Pythona.
114
115 %prep
116 %setup -q
117 %patch0 -p1
118
119 %build
120 %{__gtkdocize}
121 %{__glib_gettextize}
122 %{__intltoolize}
123 %{__libtoolize}
124 %{__aclocal} -I m4
125 %{__autoconf}
126 %{__autoheader}
127 %{__automake}
128 %configure \
129         --with-html-dir=%{_gtkdocdir} \
130         --with-python=yes
131 %{__make}
132
133 %install
134 rm -rf $RPM_BUILD_ROOT
135
136 %{__make} install \
137         DESTDIR=$RPM_BUILD_ROOT
138
139 rm -f $RPM_BUILD_ROOT%{py_sitedir}/gpod/*.{la,a}
140
141 %py_postclean
142
143 %find_lang %{name} --all-name
144
145 %clean
146 rm -rf $RPM_BUILD_ROOT
147
148 %post   -p /sbin/ldconfig
149 %postun -p /sbin/ldconfig
150
151 %files -f %{name}.lang
152 %defattr(644,root,root,755)
153 %doc AUTHORS ChangeLog README
154 %attr(755,root,root) %{_bindir}/ipod-read-sysinfo-extended
155 %attr(755,root,root) %{_libdir}/libgpod.so.*.*.*
156 %attr(755,root,root) %ghost %{_libdir}/libgpod.so.4
157
158 %files -n hal-libgpod
159 %defattr(644,root,root,755)
160 %attr(755,root,root) %{_libdir}/hal/scripts/libgpod-callout
161 %{_datadir}/hal/fdi/policy/20thirdparty/20-libgpod-sysinfo-extended.fdi
162
163 %files devel
164 %defattr(644,root,root,755)
165 %attr(755,root,root) %{_libdir}/libgpod.so
166 %{_libdir}/libgpod.la
167 %{_pkgconfigdir}/libgpod-1.0.pc
168 %{_includedir}/gpod-1.0
169
170 %files static
171 %defattr(644,root,root,755)
172 %{_libdir}/libgpod.a
173
174 %files apidocs
175 %defattr(644,root,root,755)
176 %{_gtkdocdir}/libgpod
177
178 %files -n python-gpod
179 %defattr(644,root,root,755)
180 %dir %{py_sitedir}/gpod
181 %{py_sitedir}/gpod/*.py[co]
182 %attr(755,root,root) %{py_sitedir}/gpod/_gpod.so
This page took 0.035863 seconds and 4 git commands to generate.