]> git.pld-linux.org Git - packages/libgpod.git/blob - libgpod.spec
- added generation of mono deps
[packages/libgpod.git] / libgpod.spec
1 # TODO
2 # check: http://fred.uwcs.co.uk/diff (from http://www.fredemmott.co.uk/blog_121)
3 # some warning at doc build:
4 #warning: failed to load external entity "../../docs/reference/xml/*.xml"
5 #unable to parse ../../docs/reference/xml/*.xml
6 #make[3]: [gpod_doc.i] Error 6 (ignored)
7 # - mountdir perms?: %dir %{_localstatedir}/run/%{name}
8 # - dotnet pkg executable bits for .exe?
9 %include        /usr/lib/rpm/macros.mono
10 #
11 Summary:        Shared library to access the contents of an iPod
12 Summary(pl.UTF-8):      Biblioteka współdzielona do dostępu do zawartości iPodów
13 Name:           libgpod
14 Version:        0.8.0
15 Release:        0.1
16 License:        GPL v2
17 Group:          Libraries
18 Source0:        http://downloads.sourceforge.net/gtkpod/%{name}-%{version}.tar.gz
19 # Source0-md5:  6660f74cc53293dcc847407aa5f672ce
20 Patch0:         %{name}-gcc43.patch
21 URL:            http://www.gtkpod.org/libgpod/
22 BuildRequires:  autoconf >= 2.52
23 BuildRequires:  automake
24 BuildRequires:  docbook-dtd412-xml
25 BuildRequires:  dotnet-gtk-sharp2-devel >= 2.12.0
26 BuildRequires:  gdk-pixbuf2-devel >= 2.6.0
27 BuildRequires:  gettext-devel
28 BuildRequires:  glib2-devel >= 1:2.16.0
29 BuildRequires:  gtk-doc >= 1.0
30 BuildRequires:  hal-devel < 0.6
31 BuildRequires:  hal-devel >= 0.5.7.1
32 BuildRequires:  intltool >= 0.35
33 BuildRequires:  libimobiledevice-devel >= 0.9.7
34 BuildRequires:  libplist-devel >= 1.0.0
35 BuildRequires:  libtool
36 BuildRequires:  libusb-devel
37 BuildRequires:  libxml2-devel
38 BuildRequires:  mono-devel >= 1.9.1
39 BuildRequires:  pkgconfig
40 BuildRequires:  python-devel >= 2.1.1
41 BuildRequires:  python-eyeD3 >= 0.6.6
42 BuildRequires:  python-mutagen >= 1.8
43 BuildRequires:  python-pygobject-devel >= 2.8.0
44 BuildRequires:  rpm-pythonprov
45 BuildRequires:  rpmbuild(monoautodeps)
46 BuildRequires:  sg3_utils-devel >= 1.26
47 BuildRequires:  sqlite3-devel
48 BuildRequires:  swig-python >= 1.3.24
49 BuildRequires:  zlib-devel
50 # for noinst test only
51 #BuildRequires: taglib-devel
52 Suggests:       hal-libgpod = %{version}-%{release}
53 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55 %description
56 libgpod is a library meant to abstract access to an iPod content. It
57 provides an easy to use API to retrieve the list of files and playlist
58 stored on an iPod, to modify them and to save them back to the iPod.
59
60 %description -l pl.UTF-8
61 libgpod to biblioteka mająca na celu wyabstrahowanie dostępu do
62 zawartości iPodów. Udostępnia łatwe w użyciu API do pobierania listy
63 plików i playlist zapisanych na iPodzie, modyfikowania ich i
64 zapisywania z powrotem na iPoda.
65
66 %package -n hal-libgpod
67 Summary:        HAL callout program for iPod devices
68 Summary(pl.UTF-8):      Program wywoływany przez HAL dla urządzeń iPod
69 Group:          Applications/System
70 Requires:       %{name} = %{version}-%{release}
71 Requires:       hal >= 0.5
72
73 %description -n hal-libgpod
74 HAL callout program to initialize iPod devices for libgpod library.
75
76 %description -n hal-libgpod -l pl.UTF-8
77 Program wywoływany przez HAL do przygotowywania urządzeń iPod do
78 użytku z biblioteką libgpod.
79
80 %package devel
81 Summary:        Header files for libgpod library
82 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libgpod
83 Group:          Development/Libraries
84 Requires:       %{name} = %{version}-%{release}
85 Requires:       gdk-pixbuf2-devel >= 2.6.0
86 Requires:       glib2-devel >= 1:2.16.0
87
88 %description devel
89 This is the package containing the header files for libgpod library.
90
91 %description devel -l pl.UTF-8
92 Ten pakiet zawiera pliki nagłówkowe biblioteki libgpod.
93
94 %package static
95 Summary:        Static libgpod library
96 Summary(pl.UTF-8):      Statyczna biblioteka libgpod
97 Group:          Development/Libraries
98 Requires:       %{name}-devel = %{version}-%{release}
99
100 %description static
101 Static libgpod library.
102
103 %description static -l pl.UTF-8
104 Statyczna biblioteka libgpod.
105
106 %package apidocs
107 Summary:        libgpod API documentation
108 Summary(pl.UTF-8):      Dokumentacja API biblioteki libgpod
109 Group:          Documentation
110 Requires:       gtk-doc-common
111
112 %description apidocs
113 libgpod API documentation.
114
115 %description apidocs -l pl.UTF-8
116 Dokumentacja API biblioteki libgpod.
117
118 %package -n python-gpod
119 Summary:        Libraries for libgpod access from Python
120 Summary(pl.UTF-8):      Biblioteki Pythona umożliwiające korzystanie z libgpod
121 Group:          Development/Languages/Python
122 Requires:       %{name} = %{version}-%{release}
123 Requires:       python-eyeD3 >= 0.6.6
124 %pyrequires_eq  python-libs
125
126 %description -n python-gpod
127 This is the libgpod Python support package.
128
129 %description -n python-gpod -l pl.UTF-8
130 Biblioteki umożliwiające korzystanie z libgpod z poziomu Pythona.
131
132 %package -n dotnet-%{name}-sharp
133 Summary:        C#/.NET library to access iPod content
134 Group:          Development/Languages
135 Requires:       %{name} = %{version}-%{release}
136
137 %description -n dotnet-%{name}-sharp
138 C#/.NET library to access iPod content. Provides bindings to the
139 libgpod library.
140
141 %package -n dotnet-%{name}-sharp-devel
142 Summary:        Development files for libgpod-sharp
143 Group:          Development/Languages
144 Requires:       dotnet-%{name}-sharp = %{version}-%{release}
145 Requires:       pkgconfig
146
147 %description -n dotnet-%{name}-sharp-devel
148 C#/.NET library to access iPod content. Provides bindings to the
149 libgpod library.
150
151 This package contains the files required to develop programs that will
152 use dotnet-libgpod-sharp.
153
154 %prep
155 %setup -q
156 %patch0 -p1
157
158 %build
159 %{__gtkdocize}
160 %{__glib_gettextize}
161 %{__intltoolize}
162 %{__libtoolize}
163 %{__aclocal} -I m4
164 %{__autoconf}
165 %{__autoheader}
166 %{__automake}
167 %configure \
168         --disable-silent-rules \
169         --enable-gtk-doc \
170         --with-html-dir=%{_gtkdocdir} \
171         --with-temp-mount-dir=%{_localstatedir}/run/%{name} \
172         --with-python=yes
173 %{__make}
174
175 %install
176 rm -rf $RPM_BUILD_ROOT
177
178 %{__make} install \
179         DESTDIR=$RPM_BUILD_ROOT
180
181 rm -f $RPM_BUILD_ROOT%{py_sitedir}/gpod/*.{la,a}
182
183 %py_postclean
184
185 %find_lang %{name} --all-name
186
187 %clean
188 rm -rf $RPM_BUILD_ROOT
189
190 %post   -p /sbin/ldconfig
191 %postun -p /sbin/ldconfig
192
193 %files -f %{name}.lang
194 %defattr(644,root,root,755)
195 %doc AUTHORS ChangeLog README
196 %attr(755,root,root) %{_bindir}/ipod-read-sysinfo-extended
197 %attr(755,root,root) %{_libdir}/libgpod.so.*.*.*
198 %attr(755,root,root) %ghost %{_libdir}/libgpod.so.4
199 %dir %{_localstatedir}/run/%{name}
200
201 %files -n hal-libgpod
202 %defattr(644,root,root,755)
203 %attr(755,root,root) %{_libdir}/hal/scripts/libgpod-callout
204 %attr(755,root,root) %{_libdir}/hal/scripts/iphone-callout
205 %{_datadir}/hal/fdi/policy/20thirdparty/20-libgpod-sysinfo-extended.fdi
206
207 %files devel
208 %defattr(644,root,root,755)
209 %attr(755,root,root) %{_libdir}/libgpod.so
210 %{_libdir}/libgpod.la
211 %{_pkgconfigdir}/libgpod-1.0.pc
212 %{_includedir}/gpod-1.0
213
214 %files static
215 %defattr(644,root,root,755)
216 %{_libdir}/libgpod.a
217
218 %files apidocs
219 %defattr(644,root,root,755)
220 %{_gtkdocdir}/libgpod
221
222 %files -n python-gpod
223 %defattr(644,root,root,755)
224 %dir %{py_sitedir}/gpod
225 %{py_sitedir}/gpod/*.py[co]
226 %attr(755,root,root) %{py_sitedir}/gpod/_gpod.so
227
228 %files -n dotnet-%{name}-sharp
229 %defattr(644,root,root,755)
230 %dir %{_libdir}/libgpod
231 %{_libdir}/libgpod/libgpod-sharp-test.exe
232 %{_libdir}/libgpod/libgpod-sharp-test.exe.mdb
233 %{_libdir}/libgpod/libgpod-sharp.dll
234 %{_libdir}/libgpod/libgpod-sharp.dll.config
235 %{_libdir}/libgpod/libgpod-sharp.dll.mdb
236
237 %files -n dotnet-%{name}-sharp-devel
238 %defattr(644,root,root,755)
239 %{_pkgconfigdir}/libgpod-sharp.pc
This page took 0.109304 seconds and 4 git commands to generate.