]> git.pld-linux.org Git - packages/libgpod.git/blob - libgpod.spec
- build python bindings
[packages/libgpod.git] / libgpod.spec
1 Summary:        Shared library to access the contents of an iPod
2 Summary(pl):    Biblioteka wspó³dzielona do dostêpu do zawarto¶ci iPodów
3 Name:           libgpod
4 Version:        0.4.0
5 Release:        1
6 License:        GPL v2
7 Group:          Libraries
8 Source0:        http://dl.sourceforge.net/gtkpod/%{name}-%{version}.tar.gz
9 # Source0-md5:  e427e0409b0cb2d7e76b17915b1396fa
10 URL:            http://www.gtkpod.org/libgpod.html
11 BuildRequires:  autoconf >= 2.52
12 BuildRequires:  automake
13 BuildRequires:  dbus-glib-devel >= 0.71
14 BuildRequires:  gettext-devel
15 BuildRequires:  gtk+2-devel >= 2:2.10.1
16 BuildRequires:  gtk-doc
17 BuildRequires:  hal-devel < 0.6
18 BuildRequires:  hal-devel >= 0.5.7.1
19 BuildRequires:  intltool >= 0.35
20 BuildRequires:  libtool
21 BuildRequires:  pkgconfig
22 BuildRequires:  python-eyeD3 >= 0.6.6
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 libgpod is a library meant to abstract access to an iPod content. It
27 provides an easy to use API to retrieve the list of files and playlist
28 stored on an iPod, to modify them and to save them back to the iPod.
29
30 %description -l pl
31 libgpod to biblioteka maj±ca na celu wyabstrahowanie dostêpu do
32 zawarto¶ci iPodów. Udostêpnia ³atwe w u¿yciu API do pobierania listy
33 plików i playlist zapisanych na iPodzie, modyfikowania ich i
34 zapisywania z powrotem na iPoda.
35
36 %package devel
37 Summary:        Header files for libgpod library
38 Summary(pl):    Pliki nag³ówkowe biblioteki libgpod
39 Group:          Development/Libraries
40 Requires:       %{name} = %{version}-%{release}
41 Requires:       dbus-glib-devel >= 0.71
42 Requires:       gtk+2-devel >= 2:2.10.1
43 Requires:       hal-devel >= 0.5.7.1
44
45 %description devel
46 This is the package containing the header files for libgpod library.
47
48 %description devel -l pl
49 Ten pakiet zawiera pliki nag³ówkowe biblioteki libgpod.
50
51 %package static
52 Summary:        Static libgpod library
53 Summary(pl):    Statyczna biblioteka libgpod
54 Group:          Development/Libraries
55 Requires:       %{name}-devel = %{version}-%{release}
56
57 %description static
58 Static libgpod library.
59
60 %description static -l pl
61 Statyczna biblioteka libgpod.
62
63 %package -n python-gpod
64 Summary:        Libraries for libgpod access from Python
65 Summary(pl):    Biblioteki Pythona dla biblioteki libgpod
66 Group:          Development/Languages/Python
67 Requires:       %{name} = %{epoch}:%{version}-%{release}
68 Requires:       python-eyeD3 >= 0.6.6
69 %pyrequires_eq  python-libs
70
71 %description -n python-gpod
72 This is the libgpod Python support package.
73
74 %description -n python-gpod -l pl
75 Biblioteki umo¿liwiaj±ce korzystanie z libgpod z poziomu
76 Pythona.
77
78 %prep
79 %setup -q
80
81 %build
82 %{__gtkdocize}
83 %{__glib_gettextize}
84 %{__intltoolize}
85 %{__libtoolize}
86 %{__aclocal} -I m4
87 %{__autoconf}
88 %{__autoheader}
89 %{__automake}
90 %configure \
91         --with-eject-command="/usr/bin/eject" \
92         --with-unmount-command="/bin/umount" \
93         --with-python=yes
94 %{__make}
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98
99 %{__make} install \
100         DESTDIR=$RPM_BUILD_ROOT
101
102 %find_lang %{name} --all-name
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %post   -p /sbin/ldconfig
108 %postun -p /sbin/ldconfig
109
110 %files -f %{name}.lang
111 %defattr(644,root,root,755)
112 %doc AUTHORS ChangeLog README
113 %attr(755,root,root) %{_libdir}/libgpod.so.*.*.*
114
115 %files devel
116 %defattr(644,root,root,755)
117 %{_libdir}/libgpod.la
118 %attr(755,root,root) %{_libdir}/libgpod.so
119 %{_pkgconfigdir}/libgpod-1.0.pc
120 %{_includedir}/gpod-1.0
121
122 %files static
123 %defattr(644,root,root,755)
124 %{_libdir}/libgpod.a
125
126 %files -n python-gpod
127 %defattr(644,root,root,755)
128 %{py_sitescriptdir}/*
This page took 0.066216 seconds and 4 git commands to generate.