]> git.pld-linux.org Git - packages/libgpod.git/blob - libgpod.spec
- release 4 (by relup.sh)
[packages/libgpod.git] / libgpod.spec
1 # TODO
2 # check: http://fred.uwcs.co.uk/diff (from http://www.fredemmott.co.uk/blog_121)
3 # some warning at doc build:
4 #warning: failed to load external entity "../../docs/reference/xml/*.xml"
5 #unable to parse ../../docs/reference/xml/*.xml
6 #make[3]: [gpod_doc.i] Error 6 (ignored)
7 # - mountdir perms?: %dir %{_localstatedir}/run/%{name}
8 #
9 # Conditional build:
10 %bcond_without  dotnet  # without .NET support
11
12 %ifarch x32
13 %undefine       with_dotnet
14 %endif
15
16 %{?with_dotnet:%include /usr/lib/rpm/macros.mono}
17 Summary:        Shared library to access the contents of an iPod
18 Summary(pl.UTF-8):      Biblioteka współdzielona do dostępu do zawartości iPodów
19 Name:           libgpod
20 Version:        0.8.2
21 Release:        4
22 License:        GPL v2
23 Group:          Libraries
24 Source0:        http://downloads.sourceforge.net/gtkpod/%{name}-%{version}.tar.bz2
25 # Source0-md5:  ff0fd875fa08f2a6a49dec57ce3367ab
26 Source1:        %{name}.tmpfiles
27 Patch0:         %{name}-gcc43.patch
28 Patch1:         %{name}-monodir.patch
29 URL:            http://www.gtkpod.org/libgpod/
30 BuildRequires:  autoconf >= 2.52
31 BuildRequires:  automake
32 BuildRequires:  docbook-dtd412-xml
33 %{?with_dotnet:BuildRequires:   dotnet-gtk-sharp2-devel >= 2.12.0}
34 BuildRequires:  gdk-pixbuf2-devel >= 2.6.0
35 BuildRequires:  gettext-tools
36 BuildRequires:  glib2-devel >= 1:2.16.0
37 BuildRequires:  gtk-doc >= 1.0
38 BuildRequires:  intltool >= 0.35
39 BuildRequires:  libimobiledevice-devel >= 0.9.7
40 BuildRequires:  libplist-devel >= 1.0.0
41 BuildRequires:  libsmbios-devel
42 BuildRequires:  libtool
43 BuildRequires:  libusb-devel
44 BuildRequires:  libxml2-devel
45 %{?with_dotnet:BuildRequires:   mono-devel >= 1.9.1}
46 BuildRequires:  pkgconfig
47 BuildRequires:  python-devel >= 2.1.1
48 BuildRequires:  python-eyeD3 >= 0.6.6
49 BuildRequires:  python-mutagen >= 1.8
50 BuildRequires:  python-pygobject-devel >= 2.8.0
51 BuildRequires:  rpm-pythonprov
52 BuildRequires:  rpmbuild(macros) >= 1.647
53 %{?with_dotnet:BuildRequires:   rpmbuild(monoautodeps)}
54 BuildRequires:  sg3_utils-devel >= 1.26
55 BuildRequires:  sqlite3-devel
56 BuildRequires:  swig-python >= 1.3.24
57 BuildRequires:  zlib-devel
58 # for noinst test only
59 #BuildRequires: taglib-devel
60 Suggests:       udev-libgpod = %{version}-%{release}
61 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
62
63 %description
64 libgpod is a library meant to abstract access to an iPod content. It
65 provides an easy to use API to retrieve the list of files and playlist
66 stored on an iPod, to modify them and to save them back to the iPod.
67
68 %description -l pl.UTF-8
69 libgpod to biblioteka mająca na celu wyabstrahowanie dostępu do
70 zawartości iPodów. Udostępnia łatwe w użyciu API do pobierania listy
71 plików i playlist zapisanych na iPodzie, modyfikowania ich i
72 zapisywania z powrotem na iPoda.
73
74 %package -n udev-libgpod
75 Summary:        UDEV rules and programs for iPod devices
76 Summary(pl.UTF-8):      Reguły i programy używane przez UDEV dla urządzeń iPod
77 Group:          Applications/System
78 Requires:       %{name} = %{version}-%{release}
79 Obsoletes:      hal-libgpod
80
81 %description -n udev-libgpod
82 UDEV rules and programs to initialize iPod devices for libgpod
83 library.
84
85 %description -n udev-libgpod -l pl.UTF-8
86 Reguły i program dla UDEV do przygotowywania urządzeń iPod do użytku z
87 biblioteką libgpod.
88
89 %package devel
90 Summary:        Header files for libgpod library
91 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libgpod
92 Group:          Development/Libraries
93 Requires:       %{name} = %{version}-%{release}
94 Requires:       gdk-pixbuf2-devel >= 2.6.0
95 Requires:       glib2-devel >= 1:2.16.0
96
97 %description devel
98 This is the package containing the header files for libgpod library.
99
100 %description devel -l pl.UTF-8
101 Ten pakiet zawiera pliki nagłówkowe biblioteki libgpod.
102
103 %package static
104 Summary:        Static libgpod library
105 Summary(pl.UTF-8):      Statyczna biblioteka libgpod
106 Group:          Development/Libraries
107 Requires:       %{name}-devel = %{version}-%{release}
108
109 %description static
110 Static libgpod library.
111
112 %description static -l pl.UTF-8
113 Statyczna biblioteka libgpod.
114
115 %package apidocs
116 Summary:        libgpod API documentation
117 Summary(pl.UTF-8):      Dokumentacja API biblioteki libgpod
118 Group:          Documentation
119 Requires:       gtk-doc-common
120
121 %description apidocs
122 libgpod API documentation.
123
124 %description apidocs -l pl.UTF-8
125 Dokumentacja API biblioteki libgpod.
126
127 %package -n python-gpod
128 Summary:        Module for libgpod access from Python
129 Summary(pl.UTF-8):      Moduł Pythona umożliwiający korzystanie z biblioteki libgpod
130 Group:          Development/Languages/Python
131 Requires:       %{name} = %{version}-%{release}
132 Requires:       python-eyeD3 >= 0.6.6
133 %pyrequires_eq  python-libs
134
135 %description -n python-gpod
136 This is the libgpod Python support package.
137
138 %description -n python-gpod -l pl.UTF-8
139 Moduł umożliwiający korzystanie z biblioteki libgpod z poziomu
140 Pythona.
141
142 %package -n dotnet-%{name}-sharp
143 Summary:        C#/.NET library to access iPod content
144 Summary(pl.UTF-8):      Biblioteka C#/.NET pozwalajaca na dostęp do iPoda
145 Group:          Development/Languages
146 Requires:       %{name} = %{version}-%{release}
147
148 %description -n dotnet-%{name}-sharp
149 C#/.NET library to access iPod content. Provides bindings to the
150 libgpod library.
151
152 %description -n dotnet-%{name}-sharp -l pl.UTF-8
153 Biblioteka C#/.NET pozwalająca na dostęp do iPoda. Udostępnia wiązania
154 do biblioteki libgpod.
155
156 %package -n dotnet-%{name}-sharp-devel
157 Summary:        Development files for libgpod-sharp
158 Summary(pl.UTF-8):      Development files for libgpod-sharp
159 Group:          Development/Languages
160 Requires:       dotnet-%{name}-sharp = %{version}-%{release}
161 Requires:       pkgconfig
162
163 %description -n dotnet-%{name}-sharp-devel
164 C#/.NET library to access iPod content. Provides bindings to the
165 libgpod library.
166
167 This package contains the files required to develop programs that will
168 use dotnet-libgpod-sharp.
169
170 %description -n dotnet-%{name}-sharp-devel -l pl.UTF-8
171 Pliki programistyczne biblioteki C#/.NET libgpod-sharp.
172
173 %prep
174 %setup -q
175 %patch0 -p1
176 %patch1 -p1
177
178 %build
179 %{__gtkdocize}
180 %{__glib_gettextize}
181 %{__intltoolize}
182 %{__libtoolize}
183 %{__aclocal} -I m4
184 %{__autoconf}
185 %{__autoheader}
186 %{__automake}
187 %configure \
188         --disable-silent-rules \
189         --enable-gtk-doc \
190         --enable-mono%{!?with_dotnet:=no} \
191         --with-html-dir=%{_gtkdocdir} \
192         --with-temp-mount-dir=%{_localstatedir}/run/%{name} \
193         --with-python=yes \
194         --without-hal \
195         --enable-udev
196
197 %{__make}
198
199 %install
200 rm -rf $RPM_BUILD_ROOT
201 install -d $RPM_BUILD_ROOT%{systemdtmpfilesdir}
202
203 %{__make} install \
204         DESTDIR=$RPM_BUILD_ROOT
205
206 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/gpod/*.la \
207         $RPM_BUILD_ROOT%{_libdir}/libgpod.la
208
209 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
210
211 %py_postclean
212
213 %find_lang %{name} --all-name
214
215 %clean
216 rm -rf $RPM_BUILD_ROOT
217
218 %post   -p /sbin/ldconfig
219 %postun -p /sbin/ldconfig
220
221 %files -f %{name}.lang
222 %defattr(644,root,root,755)
223 %doc AUTHORS ChangeLog README
224 %attr(755,root,root) %{_bindir}/ipod-read-sysinfo-extended
225 %attr(755,root,root) %{_libdir}/libgpod.so.*.*.*
226 %attr(755,root,root) %ghost %{_libdir}/libgpod.so.4
227 %dir %{_localstatedir}/run/%{name}
228 %{systemdtmpfilesdir}/%{name}.conf
229
230 %files -n udev-libgpod
231 %defattr(644,root,root,755)
232 %attr(755,root,root) /lib/udev/iphone-set-info
233 %attr(755,root,root) /lib/udev/ipod-set-info
234 /lib/udev/rules.d/90-libgpod.rules
235
236 %files devel
237 %defattr(644,root,root,755)
238 %attr(755,root,root) %{_libdir}/libgpod.so
239 %{_pkgconfigdir}/libgpod-1.0.pc
240 %{_includedir}/gpod-1.0
241
242 %files static
243 %defattr(644,root,root,755)
244 %{_libdir}/libgpod.a
245
246 %files apidocs
247 %defattr(644,root,root,755)
248 %{_gtkdocdir}/libgpod
249
250 %files -n python-gpod
251 %defattr(644,root,root,755)
252 %dir %{py_sitedir}/gpod
253 %{py_sitedir}/gpod/*.py[co]
254 %attr(755,root,root) %{py_sitedir}/gpod/_gpod.so
255
256 %if %{with dotnet}
257 %files -n dotnet-%{name}-sharp
258 %defattr(644,root,root,755)
259 %dir %{_prefix}/lib/libgpod
260 %{_prefix}/lib/libgpod/libgpod-sharp-test.exe
261 %{_prefix}/lib/libgpod/libgpod-sharp-test.exe.mdb
262 %{_prefix}/lib/libgpod/libgpod-sharp.dll
263 %{_prefix}/lib/libgpod/libgpod-sharp.dll.config
264 %{_prefix}/lib/libgpod/libgpod-sharp.dll.mdb
265
266 %files -n dotnet-%{name}-sharp-devel
267 %defattr(644,root,root,755)
268 %{_pkgconfigdir}/libgpod-sharp.pc
269 %endif
This page took 0.043086 seconds and 4 git commands to generate.