]> git.pld-linux.org Git - packages/libgpod.git/blob - libgpod.spec
- added gcc43.patch
[packages/libgpod.git] / libgpod.spec
1 Summary:        Shared library to access the contents of an iPod
2 Summary(pl.UTF-8):      Biblioteka współdzielona do dostępu do zawartości iPodów
3 Name:           libgpod
4 Version:        0.6.0
5 Release:        4
6 License:        GPL v2
7 Group:          Libraries
8 Source0:        http://dl.sourceforge.net/gtkpod/%{name}-%{version}.tar.gz
9 # Source0-md5:  b44d8aee3f6610370b6faf61770c5f3c
10 Patch0:         %{name}-gcc43.patch
11 URL:            http://www.gtkpod.org/libgpod.html
12 BuildRequires:  autoconf >= 2.52
13 BuildRequires:  automake
14 BuildRequires:  dbus-glib-devel >= 0.30
15 BuildRequires:  gettext-devel
16 BuildRequires:  gtk+2-devel >= 2.0
17 BuildRequires:  gtk-doc >= 1.0
18 BuildRequires:  hal-devel < 0.6
19 BuildRequires:  hal-devel >= 0.5.7.1
20 BuildRequires:  intltool >= 0.35
21 BuildRequires:  libtool
22 BuildRequires:  pkgconfig
23 BuildRequires:  python-devel >= 2.1.1
24 BuildRequires:  python-eyeD3 >= 0.6.6
25 BuildRequires:  python-mutagen >= 1.8
26 BuildRequires:  rpm-pythonprov
27 BuildRequires:  sg3_utils-devel
28 BuildRequires:  swig-python >= 1.3.24
29 # for noinst test only
30 #BuildRequires: taglib-devel
31 Suggests:       hal-libgpod = %{version}-%{release}
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 libgpod is a library meant to abstract access to an iPod content. It
36 provides an easy to use API to retrieve the list of files and playlist
37 stored on an iPod, to modify them and to save them back to the iPod.
38
39 %description -l pl.UTF-8
40 libgpod to biblioteka mająca na celu wyabstrahowanie dostępu do
41 zawartości iPodów. Udostępnia łatwe w użyciu API do pobierania listy
42 plików i playlist zapisanych na iPodzie, modyfikowania ich i
43 zapisywania z powrotem na iPoda.
44
45 %package -n hal-libgpod
46 Summary:        HAL callout program for iPod devices
47 Summary(pl.UTF-8):      Program wywoływany przez HAL dla urządzeń iPod
48 Group:          Applications/System
49 Requires:       %{name} = %{version}-%{release}
50 Requires:       hal >= 0.5
51
52 %description -n hal-libgpod
53 HAL callout program to initialize iPod devices for libgpod library.
54
55 %description -n hal-libgpod -l pl.UTF-8
56 Program wywoływany przez HAL do przygotowywania urządzeń iPod do
57 użytku z biblioteką libgpod.
58
59 %package devel
60 Summary:        Header files for libgpod library
61 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libgpod
62 Group:          Development/Libraries
63 Requires:       %{name} = %{version}-%{release}
64 Requires:       dbus-glib-devel >= 0.30
65 Requires:       gtk+2-devel >= 2.0
66 Requires:       hal-devel >= 0.5.7.1
67
68 %description devel
69 This is the package containing the header files for libgpod library.
70
71 %description devel -l pl.UTF-8
72 Ten pakiet zawiera pliki nagłówkowe biblioteki libgpod.
73
74 %package static
75 Summary:        Static libgpod library
76 Summary(pl.UTF-8):      Statyczna biblioteka libgpod
77 Group:          Development/Libraries
78 Requires:       %{name}-devel = %{version}-%{release}
79
80 %description static
81 Static libgpod library.
82
83 %description static -l pl.UTF-8
84 Statyczna biblioteka libgpod.
85
86 %package apidocs
87 Summary:        libgpod API documentation
88 Summary(pl.UTF-8):      Dokumentacja API biblioteki libgpod
89 Group:          Documentation
90 Requires:       gtk-doc-common
91
92 %description apidocs
93 libgpod API documentation.
94
95 %description apidocs -l pl.UTF-8
96 Dokumentacja API biblioteki libgpod.
97
98 %package -n python-gpod
99 Summary:        Libraries for libgpod access from Python
100 Summary(pl.UTF-8):      Biblioteki Pythona umożliwiające korzystanie z libgpod
101 Group:          Development/Languages/Python
102 Requires:       %{name} = %{version}-%{release}
103 Requires:       python-eyeD3 >= 0.6.6
104 %pyrequires_eq  python-libs
105
106 %description -n python-gpod
107 This is the libgpod Python support package.
108
109 %description -n python-gpod -l pl.UTF-8
110 Biblioteki umożliwiające korzystanie z libgpod z poziomu Pythona.
111
112 %prep
113 %setup -q
114 %patch0 -p1
115
116 %build
117 %{__gtkdocize}
118 %{__glib_gettextize}
119 %{__intltoolize}
120 %{__libtoolize}
121 %{__aclocal} -I m4
122 %{__autoconf}
123 %{__autoheader}
124 %{__automake}
125 %configure \
126         --with-html-dir=%{_gtkdocdir} \
127         --with-python=yes
128 %{__make}
129
130 %install
131 rm -rf $RPM_BUILD_ROOT
132
133 %{__make} install \
134         DESTDIR=$RPM_BUILD_ROOT
135
136 rm -f $RPM_BUILD_ROOT%{py_sitedir}/gpod/*.{la,a}
137
138 %py_postclean
139
140 %find_lang %{name} --all-name
141
142 %clean
143 rm -rf $RPM_BUILD_ROOT
144
145 %post   -p /sbin/ldconfig
146 %postun -p /sbin/ldconfig
147
148 %files -f %{name}.lang
149 %defattr(644,root,root,755)
150 %doc AUTHORS ChangeLog README
151 %attr(755,root,root) %{_bindir}/ipod-read-sysinfo-extended
152 %attr(755,root,root) %{_libdir}/libgpod.so.*.*.*
153 %attr(755,root,root) %ghost %{_libdir}/libgpod.so.3
154
155 %files -n hal-libgpod
156 %defattr(644,root,root,755)
157 %attr(755,root,root) %{_libdir}/hal/libgpod-callout
158 %{_datadir}/hal/fdi/policy/20thirdparty/20-libgpod-sysinfo-extended.fdi
159
160 %files devel
161 %defattr(644,root,root,755)
162 %attr(755,root,root) %{_libdir}/libgpod.so
163 %{_libdir}/libgpod.la
164 %{_pkgconfigdir}/libgpod-1.0.pc
165 %{_includedir}/gpod-1.0
166
167 %files static
168 %defattr(644,root,root,755)
169 %{_libdir}/libgpod.a
170
171 %files apidocs
172 %defattr(644,root,root,755)
173 %{_gtkdocdir}/libgpod
174
175 %files -n python-gpod
176 %defattr(644,root,root,755)
177 %dir %{py_sitedir}/gpod
178 %{py_sitedir}/gpod/*.py[co]
179 %attr(755,root,root) %{py_sitedir}/gpod/_gpod.so
This page took 0.052736 seconds and 4 git commands to generate.