]> git.pld-linux.org Git - packages/libgpod.git/blob - libgpod.spec
- separated hal-libgpod package (no daemon, especially udev/hal, should be required
[packages/libgpod.git] / libgpod.spec
1 Summary:        Shared library to access the contents of an iPod
2 Summary(pl.UTF-8):      Biblioteka współdzielona do dostępu do zawartości iPodów
3 Name:           libgpod
4 Version:        0.6.0
5 Release:        3
6 License:        GPL v2
7 Group:          Libraries
8 Source0:        http://dl.sourceforge.net/gtkpod/%{name}-%{version}.tar.gz
9 # Source0-md5:  b44d8aee3f6610370b6faf61770c5f3c
10 URL:            http://www.gtkpod.org/libgpod.html
11 BuildRequires:  autoconf >= 2.52
12 BuildRequires:  automake
13 BuildRequires:  dbus-glib-devel >= 0.30
14 BuildRequires:  gettext-devel
15 BuildRequires:  gtk+2-devel >= 2.0
16 BuildRequires:  gtk-doc >= 1.0
17 BuildRequires:  hal-devel < 0.6
18 BuildRequires:  hal-devel >= 0.5.7.1
19 BuildRequires:  intltool >= 0.35
20 BuildRequires:  libtool
21 BuildRequires:  pkgconfig
22 BuildRequires:  python-devel >= 2.1.1
23 BuildRequires:  python-eyeD3 >= 0.6.6
24 BuildRequires:  python-mutagen >= 1.8
25 BuildRequires:  rpm-pythonprov
26 BuildRequires:  sg3_utils-devel
27 BuildRequires:  swig-python >= 1.3.24
28 # for noinst test only
29 #BuildRequires: taglib-devel
30 Suggests:       hal-libgpod = %{version}-%{release}
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 libgpod is a library meant to abstract access to an iPod content. It
35 provides an easy to use API to retrieve the list of files and playlist
36 stored on an iPod, to modify them and to save them back to the iPod.
37
38 %description -l pl.UTF-8
39 libgpod to biblioteka mająca na celu wyabstrahowanie dostępu do
40 zawartości iPodów. Udostępnia łatwe w użyciu API do pobierania listy
41 plików i playlist zapisanych na iPodzie, modyfikowania ich i
42 zapisywania z powrotem na iPoda.
43
44 %package -n hal-libgpod
45 Summary:        HAL callout program for iPod devices
46 Summary(pl.UTF-8):      Program wywoływany przez HAL dla urządzeń iPod
47 Group:          Applications/System
48 Requires:       %{name} = %{version}-%{release}
49 Requires:       hal >= 0.5
50
51 %description -n hal-libgpod
52 HAL callout program to initialize iPod devices for libgpod library.
53
54 %description -n hal-libgpod -l pl.UTF-8
55 Program wywoływany przez HAL do przygotowywania urządzeń iPod do
56 użytku z biblioteką libgpod.
57
58 %package devel
59 Summary:        Header files for libgpod library
60 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libgpod
61 Group:          Development/Libraries
62 Requires:       %{name} = %{version}-%{release}
63 Requires:       dbus-glib-devel >= 0.30
64 Requires:       gtk+2-devel >= 2.0
65 Requires:       hal-devel >= 0.5.7.1
66
67 %description devel
68 This is the package containing the header files for libgpod library.
69
70 %description devel -l pl.UTF-8
71 Ten pakiet zawiera pliki nagłówkowe biblioteki libgpod.
72
73 %package static
74 Summary:        Static libgpod library
75 Summary(pl.UTF-8):      Statyczna biblioteka libgpod
76 Group:          Development/Libraries
77 Requires:       %{name}-devel = %{version}-%{release}
78
79 %description static
80 Static libgpod library.
81
82 %description static -l pl.UTF-8
83 Statyczna biblioteka libgpod.
84
85 %package apidocs
86 Summary:        libgpod API documentation
87 Summary(pl.UTF-8):      Dokumentacja API biblioteki libgpod
88 Group:          Documentation
89 Requires:       gtk-doc-common
90
91 %description apidocs
92 libgpod API documentation.
93
94 %description apidocs -l pl.UTF-8
95 Dokumentacja API biblioteki libgpod.
96
97 %package -n python-gpod
98 Summary:        Libraries for libgpod access from Python
99 Summary(pl.UTF-8):      Biblioteki Pythona umożliwiające korzystanie z libgpod
100 Group:          Development/Languages/Python
101 Requires:       %{name} = %{version}-%{release}
102 Requires:       python-eyeD3 >= 0.6.6
103 %pyrequires_eq  python-libs
104
105 %description -n python-gpod
106 This is the libgpod Python support package.
107
108 %description -n python-gpod -l pl.UTF-8
109 Biblioteki umożliwiające korzystanie z libgpod z poziomu Pythona.
110
111 %prep
112 %setup -q
113
114 %build
115 %{__gtkdocize}
116 %{__glib_gettextize}
117 %{__intltoolize}
118 %{__libtoolize}
119 %{__aclocal} -I m4
120 %{__autoconf}
121 %{__autoheader}
122 %{__automake}
123 %configure \
124         --with-html-dir=%{_gtkdocdir} \
125         --with-python=yes
126 %{__make}
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130
131 %{__make} install \
132         DESTDIR=$RPM_BUILD_ROOT
133
134 rm -f $RPM_BUILD_ROOT%{py_sitedir}/gpod/*.{la,a}
135
136 %py_postclean
137
138 %find_lang %{name} --all-name
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %post   -p /sbin/ldconfig
144 %postun -p /sbin/ldconfig
145
146 %files -f %{name}.lang
147 %defattr(644,root,root,755)
148 %doc AUTHORS ChangeLog README
149 %attr(755,root,root) %{_bindir}/ipod-read-sysinfo-extended
150 %attr(755,root,root) %{_libdir}/libgpod.so.*.*.*
151 %attr(755,root,root) %ghost %{_libdir}/libgpod.so.3
152
153 %files -n hal-libgpod
154 %defattr(644,root,root,755)
155 %attr(755,root,root) %{_libdir}/hal/libgpod-callout
156 %{_datadir}/hal/fdi/policy/20thirdparty/20-libgpod-sysinfo-extended.fdi
157
158 %files devel
159 %defattr(644,root,root,755)
160 %attr(755,root,root) %{_libdir}/libgpod.so
161 %{_libdir}/libgpod.la
162 %{_pkgconfigdir}/libgpod-1.0.pc
163 %{_includedir}/gpod-1.0
164
165 %files static
166 %defattr(644,root,root,755)
167 %{_libdir}/libgpod.a
168
169 %files apidocs
170 %defattr(644,root,root,755)
171 %{_gtkdocdir}/libgpod
172
173 %files -n python-gpod
174 %defattr(644,root,root,755)
175 %dir %{py_sitedir}/gpod
176 %{py_sitedir}/gpod/*.py[co]
177 %attr(755,root,root) %{py_sitedir}/gpod/_gpod.so
This page took 0.077974 seconds and 4 git commands to generate.