]> git.pld-linux.org Git - packages/libgpod.git/blob - libgpod.spec
- %files
[packages/libgpod.git] / libgpod.spec
1 Summary:        Shared library to access the contents of an iPod
2 Summary(pl.UTF-8):      Biblioteka współdzielona do dostępu do zawartości iPodów
3 Name:           libgpod
4 Version:        0.7.0
5 Release:        1
6 License:        GPL v2
7 Group:          Libraries
8 Source0:        http://dl.sourceforge.net/gtkpod/%{name}-%{version}.tar.gz
9 # Source0-md5:  34eba68a6037e6b2feda20f46d1dbfb8
10 Patch0:         %{name}-gcc43.patch
11 Patch1:         %{name}-sgutils.patch
12 URL:            http://www.gtkpod.org/libgpod.html
13 BuildRequires:  autoconf >= 2.52
14 BuildRequires:  automake
15 BuildRequires:  dbus-glib-devel >= 0.30
16 BuildRequires:  gettext-devel
17 BuildRequires:  gtk+2-devel >= 2.0
18 BuildRequires:  gtk-doc >= 1.0
19 BuildRequires:  hal-devel < 0.6
20 BuildRequires:  hal-devel >= 0.5.7.1
21 BuildRequires:  intltool >= 0.35
22 BuildRequires:  libtool
23 BuildRequires:  pkgconfig
24 BuildRequires:  python-devel >= 2.1.1
25 BuildRequires:  python-eyeD3 >= 0.6.6
26 BuildRequires:  python-mutagen >= 1.8
27 BuildRequires:  rpm-pythonprov
28 BuildRequires:  sg3_utils-devel >= 1.26
29 BuildRequires:  swig-python >= 1.3.24
30 # for noinst test only
31 #BuildRequires: taglib-devel
32 Suggests:       hal-libgpod = %{version}-%{release}
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 libgpod is a library meant to abstract access to an iPod content. It
37 provides an easy to use API to retrieve the list of files and playlist
38 stored on an iPod, to modify them and to save them back to the iPod.
39
40 %description -l pl.UTF-8
41 libgpod to biblioteka mająca na celu wyabstrahowanie dostępu do
42 zawartości iPodów. Udostępnia łatwe w użyciu API do pobierania listy
43 plików i playlist zapisanych na iPodzie, modyfikowania ich i
44 zapisywania z powrotem na iPoda.
45
46 %package -n hal-libgpod
47 Summary:        HAL callout program for iPod devices
48 Summary(pl.UTF-8):      Program wywoływany przez HAL dla urządzeń iPod
49 Group:          Applications/System
50 Requires:       %{name} = %{version}-%{release}
51 Requires:       hal >= 0.5
52
53 %description -n hal-libgpod
54 HAL callout program to initialize iPod devices for libgpod library.
55
56 %description -n hal-libgpod -l pl.UTF-8
57 Program wywoływany przez HAL do przygotowywania urządzeń iPod do
58 użytku z biblioteką libgpod.
59
60 %package devel
61 Summary:        Header files for libgpod library
62 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libgpod
63 Group:          Development/Libraries
64 Requires:       %{name} = %{version}-%{release}
65 Requires:       dbus-glib-devel >= 0.30
66 Requires:       gtk+2-devel >= 2.0
67 Requires:       hal-devel >= 0.5.7.1
68
69 %description devel
70 This is the package containing the header files for libgpod library.
71
72 %description devel -l pl.UTF-8
73 Ten pakiet zawiera pliki nagłówkowe biblioteki libgpod.
74
75 %package static
76 Summary:        Static libgpod library
77 Summary(pl.UTF-8):      Statyczna biblioteka libgpod
78 Group:          Development/Libraries
79 Requires:       %{name}-devel = %{version}-%{release}
80
81 %description static
82 Static libgpod library.
83
84 %description static -l pl.UTF-8
85 Statyczna biblioteka libgpod.
86
87 %package apidocs
88 Summary:        libgpod API documentation
89 Summary(pl.UTF-8):      Dokumentacja API biblioteki libgpod
90 Group:          Documentation
91 Requires:       gtk-doc-common
92
93 %description apidocs
94 libgpod API documentation.
95
96 %description apidocs -l pl.UTF-8
97 Dokumentacja API biblioteki libgpod.
98
99 %package -n python-gpod
100 Summary:        Libraries for libgpod access from Python
101 Summary(pl.UTF-8):      Biblioteki Pythona umożliwiające korzystanie z libgpod
102 Group:          Development/Languages/Python
103 Requires:       %{name} = %{version}-%{release}
104 Requires:       python-eyeD3 >= 0.6.6
105 %pyrequires_eq  python-libs
106
107 %description -n python-gpod
108 This is the libgpod Python support package.
109
110 %description -n python-gpod -l pl.UTF-8
111 Biblioteki umożliwiające korzystanie z libgpod z poziomu Pythona.
112
113 %prep
114 %setup -q
115 %patch0 -p1
116 #%patch1 -p1
117
118 %build
119 %{__gtkdocize}
120 %{__glib_gettextize}
121 %{__intltoolize}
122 %{__libtoolize}
123 %{__aclocal} -I m4
124 %{__autoconf}
125 %{__autoheader}
126 %{__automake}
127 %configure \
128         --with-html-dir=%{_gtkdocdir} \
129         --with-python=yes
130 %{__make}
131
132 %install
133 rm -rf $RPM_BUILD_ROOT
134
135 %{__make} install \
136         DESTDIR=$RPM_BUILD_ROOT
137
138 rm -f $RPM_BUILD_ROOT%{py_sitedir}/gpod/*.{la,a}
139
140 %py_postclean
141
142 %find_lang %{name} --all-name
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %post   -p /sbin/ldconfig
148 %postun -p /sbin/ldconfig
149
150 %files -f %{name}.lang
151 %defattr(644,root,root,755)
152 %doc AUTHORS ChangeLog README
153 %attr(755,root,root) %{_bindir}/ipod-read-sysinfo-extended
154 %attr(755,root,root) %{_libdir}/libgpod.so.*.*.*
155 %attr(755,root,root) %ghost %{_libdir}/libgpod.so.?
156
157 %files -n hal-libgpod
158 %defattr(644,root,root,755)
159 %attr(755,root,root) %{_libdir}/hal/libgpod-callout
160 %{_datadir}/hal/fdi/policy/20thirdparty/20-libgpod-sysinfo-extended.fdi
161
162 %files devel
163 %defattr(644,root,root,755)
164 %attr(755,root,root) %{_libdir}/libgpod.so
165 %{_libdir}/libgpod.la
166 %{_pkgconfigdir}/libgpod-1.0.pc
167 %{_includedir}/gpod-1.0
168
169 %files static
170 %defattr(644,root,root,755)
171 %{_libdir}/libgpod.a
172
173 %files apidocs
174 %defattr(644,root,root,755)
175 %{_gtkdocdir}/libgpod
176
177 %files -n python-gpod
178 %defattr(644,root,root,755)
179 %dir %{py_sitedir}/gpod
180 %{py_sitedir}/gpod/*.py[co]
181 %attr(755,root,root) %{py_sitedir}/gpod/_gpod.so
This page took 0.077063 seconds and 4 git commands to generate.