]> git.pld-linux.org Git - packages/libgpod.git/blob - libgpod.spec
- thou shall not question my decisions :)
[packages/libgpod.git] / libgpod.spec
1 # TODO
2 # check: http://fred.uwcs.co.uk/diff (from http://www.fredemmott.co.uk/blog_121)
3 Summary:        Shared library to access the contents of an iPod
4 Summary(pl.UTF-8):      Biblioteka współdzielona do dostępu do zawartości iPodów
5 Name:           libgpod
6 Version:        0.7.0
7 Release:        1
8 License:        GPL v2
9 Group:          Libraries
10 Source0:        http://dl.sourceforge.net/gtkpod/%{name}-%{version}.tar.gz
11 # Source0-md5:  34eba68a6037e6b2feda20f46d1dbfb8
12 Patch0:         %{name}-gcc43.patch
13 URL:            http://www.gtkpod.org/libgpod.html
14 BuildRequires:  autoconf >= 2.52
15 BuildRequires:  automake
16 BuildRequires:  dbus-glib-devel >= 0.30
17 BuildRequires:  gettext-devel
18 BuildRequires:  gtk+2-devel >= 2.0
19 BuildRequires:  gtk-doc >= 1.0
20 BuildRequires:  hal-devel < 0.6
21 BuildRequires:  hal-devel >= 0.5.7.1
22 BuildRequires:  intltool >= 0.35
23 BuildRequires:  libtool
24 BuildRequires:  pkgconfig
25 BuildRequires:  python-devel >= 2.1.1
26 BuildRequires:  python-eyeD3 >= 0.6.6
27 BuildRequires:  python-mutagen >= 1.8
28 BuildRequires:  rpm-pythonprov
29 BuildRequires:  sg3_utils-devel >= 1.26
30 BuildRequires:  swig-python >= 1.3.24
31 # for noinst test only
32 #BuildRequires: taglib-devel
33 Suggests:       hal-libgpod = %{version}-%{release}
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 libgpod is a library meant to abstract access to an iPod content. It
38 provides an easy to use API to retrieve the list of files and playlist
39 stored on an iPod, to modify them and to save them back to the iPod.
40
41 %description -l pl.UTF-8
42 libgpod to biblioteka mająca na celu wyabstrahowanie dostępu do
43 zawartości iPodów. Udostępnia łatwe w użyciu API do pobierania listy
44 plików i playlist zapisanych na iPodzie, modyfikowania ich i
45 zapisywania z powrotem na iPoda.
46
47 %package -n hal-libgpod
48 Summary:        HAL callout program for iPod devices
49 Summary(pl.UTF-8):      Program wywoływany przez HAL dla urządzeń iPod
50 Group:          Applications/System
51 Requires:       %{name} = %{version}-%{release}
52 Requires:       hal >= 0.5
53
54 %description -n hal-libgpod
55 HAL callout program to initialize iPod devices for libgpod library.
56
57 %description -n hal-libgpod -l pl.UTF-8
58 Program wywoływany przez HAL do przygotowywania urządzeń iPod do
59 użytku z biblioteką libgpod.
60
61 %package devel
62 Summary:        Header files for libgpod library
63 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libgpod
64 Group:          Development/Libraries
65 Requires:       %{name} = %{version}-%{release}
66 Requires:       dbus-glib-devel >= 0.30
67 Requires:       gtk+2-devel >= 2.0
68 Requires:       hal-devel >= 0.5.7.1
69
70 %description devel
71 This is the package containing the header files for libgpod library.
72
73 %description devel -l pl.UTF-8
74 Ten pakiet zawiera pliki nagłówkowe biblioteki libgpod.
75
76 %package static
77 Summary:        Static libgpod library
78 Summary(pl.UTF-8):      Statyczna biblioteka libgpod
79 Group:          Development/Libraries
80 Requires:       %{name}-devel = %{version}-%{release}
81
82 %description static
83 Static libgpod library.
84
85 %description static -l pl.UTF-8
86 Statyczna biblioteka libgpod.
87
88 %package apidocs
89 Summary:        libgpod API documentation
90 Summary(pl.UTF-8):      Dokumentacja API biblioteki libgpod
91 Group:          Documentation
92 Requires:       gtk-doc-common
93
94 %description apidocs
95 libgpod API documentation.
96
97 %description apidocs -l pl.UTF-8
98 Dokumentacja API biblioteki libgpod.
99
100 %package -n python-gpod
101 Summary:        Libraries for libgpod access from Python
102 Summary(pl.UTF-8):      Biblioteki Pythona umożliwiające korzystanie z libgpod
103 Group:          Development/Languages/Python
104 Requires:       %{name} = %{version}-%{release}
105 Requires:       python-eyeD3 >= 0.6.6
106 %pyrequires_eq  python-libs
107
108 %description -n python-gpod
109 This is the libgpod Python support package.
110
111 %description -n python-gpod -l pl.UTF-8
112 Biblioteki umożliwiające korzystanie z libgpod z poziomu Pythona.
113
114 %prep
115 %setup -q
116 %patch0 -p1
117
118 %build
119 %{__gtkdocize}
120 %{__glib_gettextize}
121 %{__intltoolize}
122 %{__libtoolize}
123 %{__aclocal} -I m4
124 %{__autoconf}
125 %{__autoheader}
126 %{__automake}
127 %configure \
128         --with-html-dir=%{_gtkdocdir} \
129         --with-python=yes
130 %{__make}
131
132 %install
133 rm -rf $RPM_BUILD_ROOT
134
135 %{__make} install \
136         DESTDIR=$RPM_BUILD_ROOT
137
138 rm -f $RPM_BUILD_ROOT%{py_sitedir}/gpod/*.{la,a}
139
140 %py_postclean
141
142 %find_lang %{name} --all-name
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %post   -p /sbin/ldconfig
148 %postun -p /sbin/ldconfig
149
150 %files -f %{name}.lang
151 %defattr(644,root,root,755)
152 %doc AUTHORS ChangeLog README
153 %attr(755,root,root) %{_bindir}/ipod-read-sysinfo-extended
154 %attr(755,root,root) %{_libdir}/libgpod.so.*.*.*
155 %attr(755,root,root) %ghost %{_libdir}/libgpod.so.4
156
157 %files -n hal-libgpod
158 %defattr(644,root,root,755)
159 %attr(755,root,root) %{_libdir}/hal/libgpod-callout
160 %{_datadir}/hal/fdi/policy/20thirdparty/20-libgpod-sysinfo-extended.fdi
161
162 %files devel
163 %defattr(644,root,root,755)
164 %attr(755,root,root) %{_libdir}/libgpod.so
165 %{_libdir}/libgpod.la
166 %{_pkgconfigdir}/libgpod-1.0.pc
167 %{_includedir}/gpod-1.0
168
169 %files static
170 %defattr(644,root,root,755)
171 %{_libdir}/libgpod.a
172
173 %files apidocs
174 %defattr(644,root,root,755)
175 %{_gtkdocdir}/libgpod
176
177 %files -n python-gpod
178 %defattr(644,root,root,755)
179 %dir %{py_sitedir}/gpod
180 %{py_sitedir}/gpod/*.py[co]
181 %attr(755,root,root) %{py_sitedir}/gpod/_gpod.so
This page took 0.040766 seconds and 4 git commands to generate.