]> git.pld-linux.org Git - packages/libgpod.git/blob - libgpod.spec
- rebuild with plist 1.10
[packages/libgpod.git] / libgpod.spec
1 # TODO
2 # check: http://fred.uwcs.co.uk/diff (from http://www.fredemmott.co.uk/blog_121)
3 # some warning at doc build:
4 #warning: failed to load external entity "../../docs/reference/xml/*.xml"
5 #unable to parse ../../docs/reference/xml/*.xml
6 #make[3]: [gpod_doc.i] Error 6 (ignored)
7 # - mountdir perms?: %dir %{_localstatedir}/run/%{name}
8 %include        /usr/lib/rpm/macros.mono
9 #
10 Summary:        Shared library to access the contents of an iPod
11 Summary(pl.UTF-8):      Biblioteka współdzielona do dostępu do zawartości iPodów
12 Name:           libgpod
13 Version:        0.8.2
14 Release:        2
15 License:        GPL v2
16 Group:          Libraries
17 Source0:        http://downloads.sourceforge.net/gtkpod/%{name}-%{version}.tar.bz2
18 # Source0-md5:  ff0fd875fa08f2a6a49dec57ce3367ab
19 Source1:        %{name}.tmpfiles
20 Patch0:         %{name}-gcc43.patch
21 Patch1:         %{name}-monodir.patch
22 URL:            http://www.gtkpod.org/libgpod/
23 BuildRequires:  autoconf >= 2.52
24 BuildRequires:  automake
25 BuildRequires:  docbook-dtd412-xml
26 BuildRequires:  dotnet-gtk-sharp2-devel >= 2.12.0
27 BuildRequires:  gdk-pixbuf2-devel >= 2.6.0
28 BuildRequires:  gettext-devel
29 BuildRequires:  glib2-devel >= 1:2.16.0
30 BuildRequires:  gtk-doc >= 1.0
31 BuildRequires:  intltool >= 0.35
32 BuildRequires:  libimobiledevice-devel >= 0.9.7
33 BuildRequires:  libplist-devel >= 1.0.0
34 BuildRequires:  libsmbios-devel
35 BuildRequires:  libtool
36 BuildRequires:  libusb-devel
37 BuildRequires:  libxml2-devel
38 BuildRequires:  mono-devel >= 1.9.1
39 BuildRequires:  pkgconfig
40 BuildRequires:  python-devel >= 2.1.1
41 BuildRequires:  python-eyeD3 >= 0.6.6
42 BuildRequires:  python-mutagen >= 1.8
43 BuildRequires:  python-pygobject-devel >= 2.8.0
44 BuildRequires:  rpm-pythonprov
45 BuildRequires:  rpmbuild(macros) >= 1.647
46 BuildRequires:  rpmbuild(monoautodeps)
47 BuildRequires:  sg3_utils-devel >= 1.26
48 BuildRequires:  sqlite3-devel
49 BuildRequires:  swig-python >= 1.3.24
50 BuildRequires:  zlib-devel
51 # for noinst test only
52 #BuildRequires: taglib-devel
53 Suggests:       udev-libgpod = %{version}-%{release}
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 %description
57 libgpod is a library meant to abstract access to an iPod content. It
58 provides an easy to use API to retrieve the list of files and playlist
59 stored on an iPod, to modify them and to save them back to the iPod.
60
61 %description -l pl.UTF-8
62 libgpod to biblioteka mająca na celu wyabstrahowanie dostępu do
63 zawartości iPodów. Udostępnia łatwe w użyciu API do pobierania listy
64 plików i playlist zapisanych na iPodzie, modyfikowania ich i
65 zapisywania z powrotem na iPoda.
66
67 %package -n udev-libgpod
68 Summary:        UDEV rules and programs for iPod devices
69 Summary(pl.UTF-8):      Reguły i programy używane przez UDEV dla urządzeń iPod
70 Group:          Applications/System
71 Requires:       %{name} = %{version}-%{release}
72 Obsoletes:      hal-libgpod
73
74 %description -n udev-libgpod
75 UDEV rules and programs to initialize iPod devices for libgpod
76 library.
77
78 %description -n udev-libgpod -l pl.UTF-8
79 Reguły i program dla UDEV do przygotowywania urządzeń iPod do użytku z
80 biblioteką libgpod.
81
82 %package devel
83 Summary:        Header files for libgpod library
84 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libgpod
85 Group:          Development/Libraries
86 Requires:       %{name} = %{version}-%{release}
87 Requires:       gdk-pixbuf2-devel >= 2.6.0
88 Requires:       glib2-devel >= 1:2.16.0
89
90 %description devel
91 This is the package containing the header files for libgpod library.
92
93 %description devel -l pl.UTF-8
94 Ten pakiet zawiera pliki nagłówkowe biblioteki libgpod.
95
96 %package static
97 Summary:        Static libgpod library
98 Summary(pl.UTF-8):      Statyczna biblioteka libgpod
99 Group:          Development/Libraries
100 Requires:       %{name}-devel = %{version}-%{release}
101
102 %description static
103 Static libgpod library.
104
105 %description static -l pl.UTF-8
106 Statyczna biblioteka libgpod.
107
108 %package apidocs
109 Summary:        libgpod API documentation
110 Summary(pl.UTF-8):      Dokumentacja API biblioteki libgpod
111 Group:          Documentation
112 Requires:       gtk-doc-common
113
114 %description apidocs
115 libgpod API documentation.
116
117 %description apidocs -l pl.UTF-8
118 Dokumentacja API biblioteki libgpod.
119
120 %package -n python-gpod
121 Summary:        Module for libgpod access from Python
122 Summary(pl.UTF-8):      Moduł Pythona umożliwiający korzystanie z biblioteki libgpod
123 Group:          Development/Languages/Python
124 Requires:       %{name} = %{version}-%{release}
125 Requires:       python-eyeD3 >= 0.6.6
126 %pyrequires_eq  python-libs
127
128 %description -n python-gpod
129 This is the libgpod Python support package.
130
131 %description -n python-gpod -l pl.UTF-8
132 Moduł umożliwiający korzystanie z biblioteki libgpod z poziomu
133 Pythona.
134
135 %package -n dotnet-%{name}-sharp
136 Summary:        C#/.NET library to access iPod content
137 Summary(pl.UTF-8):      Biblioteka C#/.NET pozwalajaca na dostęp do iPoda
138 Group:          Development/Languages
139 Requires:       %{name} = %{version}-%{release}
140
141 %description -n dotnet-%{name}-sharp
142 C#/.NET library to access iPod content. Provides bindings to the
143 libgpod library.
144
145 %description -n dotnet-%{name}-sharp -l pl.UTF-8
146 Biblioteka C#/.NET pozwalająca na dostęp do iPoda. Udostępnia wiązania
147 do biblioteki libgpod.
148
149 %package -n dotnet-%{name}-sharp-devel
150 Summary:        Development files for libgpod-sharp
151 Summary(pl.UTF-8):      Development files for libgpod-sharp
152 Group:          Development/Languages
153 Requires:       dotnet-%{name}-sharp = %{version}-%{release}
154 Requires:       pkgconfig
155
156 %description -n dotnet-%{name}-sharp-devel
157 C#/.NET library to access iPod content. Provides bindings to the
158 libgpod library.
159
160 This package contains the files required to develop programs that will
161 use dotnet-libgpod-sharp.
162
163 %description -n dotnet-%{name}-sharp-devel -l pl.UTF-8
164 Pliki programistyczne biblioteki C#/.NET libgpod-sharp.
165
166 %prep
167 %setup -q
168 %patch0 -p1
169 %patch1 -p1
170
171 %build
172 %{__gtkdocize}
173 %{__glib_gettextize}
174 %{__intltoolize}
175 %{__libtoolize}
176 %{__aclocal} -I m4
177 %{__autoconf}
178 %{__autoheader}
179 %{__automake}
180 %configure \
181         --disable-silent-rules \
182         --enable-gtk-doc \
183         --with-html-dir=%{_gtkdocdir} \
184         --with-temp-mount-dir=%{_localstatedir}/run/%{name} \
185         --with-python=yes \
186         --without-hal \
187         --enable-udev
188
189 %{__make}
190
191 %install
192 rm -rf $RPM_BUILD_ROOT
193 install -d $RPM_BUILD_ROOT%{systemdtmpfilesdir}
194
195 %{__make} install \
196         DESTDIR=$RPM_BUILD_ROOT
197
198 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/gpod/*.la \
199         $RPM_BUILD_ROOT%{_libdir}/libgpod.la
200
201 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
202
203 %py_postclean
204
205 %find_lang %{name} --all-name
206
207 %clean
208 rm -rf $RPM_BUILD_ROOT
209
210 %post   -p /sbin/ldconfig
211 %postun -p /sbin/ldconfig
212
213 %files -f %{name}.lang
214 %defattr(644,root,root,755)
215 %doc AUTHORS ChangeLog README
216 %attr(755,root,root) %{_bindir}/ipod-read-sysinfo-extended
217 %attr(755,root,root) %{_libdir}/libgpod.so.*.*.*
218 %attr(755,root,root) %ghost %{_libdir}/libgpod.so.4
219 %dir %{_localstatedir}/run/%{name}
220 %{systemdtmpfilesdir}/%{name}.conf
221
222 %files -n udev-libgpod
223 %defattr(644,root,root,755)
224 %attr(755,root,root) /lib/udev/iphone-set-info
225 %attr(755,root,root) /lib/udev/ipod-set-info
226 /lib/udev/rules.d/90-libgpod.rules
227
228 %files devel
229 %defattr(644,root,root,755)
230 %attr(755,root,root) %{_libdir}/libgpod.so
231 %{_pkgconfigdir}/libgpod-1.0.pc
232 %{_includedir}/gpod-1.0
233
234 %files static
235 %defattr(644,root,root,755)
236 %{_libdir}/libgpod.a
237
238 %files apidocs
239 %defattr(644,root,root,755)
240 %{_gtkdocdir}/libgpod
241
242 %files -n python-gpod
243 %defattr(644,root,root,755)
244 %dir %{py_sitedir}/gpod
245 %{py_sitedir}/gpod/*.py[co]
246 %attr(755,root,root) %{py_sitedir}/gpod/_gpod.so
247
248 %files -n dotnet-%{name}-sharp
249 %defattr(644,root,root,755)
250 %dir %{_prefix}/lib/libgpod
251 %{_prefix}/lib/libgpod/libgpod-sharp-test.exe
252 %{_prefix}/lib/libgpod/libgpod-sharp-test.exe.mdb
253 %{_prefix}/lib/libgpod/libgpod-sharp.dll
254 %{_prefix}/lib/libgpod/libgpod-sharp.dll.config
255 %{_prefix}/lib/libgpod/libgpod-sharp.dll.mdb
256
257 %files -n dotnet-%{name}-sharp-devel
258 %defattr(644,root,root,755)
259 %{_pkgconfigdir}/libgpod-sharp.pc
This page took 0.083215 seconds and 4 git commands to generate.