]> git.pld-linux.org Git - packages/libgpod.git/blob - libgpod.spec
- pl for dotnet-*
[packages/libgpod.git] / libgpod.spec
1 # TODO
2 # check: http://fred.uwcs.co.uk/diff (from http://www.fredemmott.co.uk/blog_121)
3 # some warning at doc build:
4 #warning: failed to load external entity "../../docs/reference/xml/*.xml"
5 #unable to parse ../../docs/reference/xml/*.xml
6 #make[3]: [gpod_doc.i] Error 6 (ignored)
7 # - mountdir perms?: %dir %{_localstatedir}/run/%{name}
8 %include        /usr/lib/rpm/macros.mono
9 #
10 Summary:        Shared library to access the contents of an iPod
11 Summary(pl.UTF-8):      Biblioteka współdzielona do dostępu do zawartości iPodów
12 Name:           libgpod
13 Version:        0.8.0
14 Release:        1
15 License:        GPL v2
16 Group:          Libraries
17 Source0:        http://downloads.sourceforge.net/gtkpod/%{name}-%{version}.tar.gz
18 # Source0-md5:  6660f74cc53293dcc847407aa5f672ce
19 Patch0:         %{name}-gcc43.patch
20 URL:            http://www.gtkpod.org/libgpod/
21 BuildRequires:  autoconf >= 2.52
22 BuildRequires:  automake
23 BuildRequires:  docbook-dtd412-xml
24 BuildRequires:  dotnet-gtk-sharp2-devel >= 2.12.0
25 BuildRequires:  gdk-pixbuf2-devel >= 2.6.0
26 BuildRequires:  gettext-devel
27 BuildRequires:  glib2-devel >= 1:2.16.0
28 BuildRequires:  gtk-doc >= 1.0
29 BuildRequires:  hal-devel < 0.6
30 BuildRequires:  hal-devel >= 0.5.7.1
31 BuildRequires:  intltool >= 0.35
32 BuildRequires:  libimobiledevice-devel >= 0.9.7
33 BuildRequires:  libplist-devel >= 1.0.0
34 BuildRequires:  libtool
35 BuildRequires:  libusb-devel
36 BuildRequires:  libxml2-devel
37 BuildRequires:  mono-devel >= 1.9.1
38 BuildRequires:  pkgconfig
39 BuildRequires:  python-devel >= 2.1.1
40 BuildRequires:  python-eyeD3 >= 0.6.6
41 BuildRequires:  python-mutagen >= 1.8
42 BuildRequires:  python-pygobject-devel >= 2.8.0
43 BuildRequires:  rpm-pythonprov
44 BuildRequires:  rpmbuild(monoautodeps)
45 BuildRequires:  sg3_utils-devel >= 1.26
46 BuildRequires:  sqlite3-devel
47 BuildRequires:  swig-python >= 1.3.24
48 BuildRequires:  zlib-devel
49 # for noinst test only
50 #BuildRequires: taglib-devel
51 Suggests:       hal-libgpod = %{version}-%{release}
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %description
55 libgpod is a library meant to abstract access to an iPod content. It
56 provides an easy to use API to retrieve the list of files and playlist
57 stored on an iPod, to modify them and to save them back to the iPod.
58
59 %description -l pl.UTF-8
60 libgpod to biblioteka mająca na celu wyabstrahowanie dostępu do
61 zawartości iPodów. Udostępnia łatwe w użyciu API do pobierania listy
62 plików i playlist zapisanych na iPodzie, modyfikowania ich i
63 zapisywania z powrotem na iPoda.
64
65 %package -n hal-libgpod
66 Summary:        HAL callout program for iPod devices
67 Summary(pl.UTF-8):      Program wywoływany przez HAL dla urządzeń iPod
68 Group:          Applications/System
69 Requires:       %{name} = %{version}-%{release}
70 Requires:       hal >= 0.5
71
72 %description -n hal-libgpod
73 HAL callout program to initialize iPod devices for libgpod library.
74
75 %description -n hal-libgpod -l pl.UTF-8
76 Program wywoływany przez HAL do przygotowywania urządzeń iPod do
77 użytku z biblioteką libgpod.
78
79 %package devel
80 Summary:        Header files for libgpod library
81 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libgpod
82 Group:          Development/Libraries
83 Requires:       %{name} = %{version}-%{release}
84 Requires:       gdk-pixbuf2-devel >= 2.6.0
85 Requires:       glib2-devel >= 1:2.16.0
86
87 %description devel
88 This is the package containing the header files for libgpod library.
89
90 %description devel -l pl.UTF-8
91 Ten pakiet zawiera pliki nagłówkowe biblioteki libgpod.
92
93 %package static
94 Summary:        Static libgpod library
95 Summary(pl.UTF-8):      Statyczna biblioteka libgpod
96 Group:          Development/Libraries
97 Requires:       %{name}-devel = %{version}-%{release}
98
99 %description static
100 Static libgpod library.
101
102 %description static -l pl.UTF-8
103 Statyczna biblioteka libgpod.
104
105 %package apidocs
106 Summary:        libgpod API documentation
107 Summary(pl.UTF-8):      Dokumentacja API biblioteki libgpod
108 Group:          Documentation
109 Requires:       gtk-doc-common
110
111 %description apidocs
112 libgpod API documentation.
113
114 %description apidocs -l pl.UTF-8
115 Dokumentacja API biblioteki libgpod.
116
117 %package -n python-gpod
118 Summary:        Module for libgpod access from Python
119 Summary(pl.UTF-8):      Moduł Pythona umożliwiający korzystanie z biblioteki libgpod
120 Group:          Development/Languages/Python
121 Requires:       %{name} = %{version}-%{release}
122 Requires:       python-eyeD3 >= 0.6.6
123 %pyrequires_eq  python-libs
124
125 %description -n python-gpod
126 This is the libgpod Python support package.
127
128 %description -n python-gpod -l pl.UTF-8
129 Moduł umożliwiający korzystanie z biblioteki libgpod z poziomu
130 Pythona.
131
132 %package -n dotnet-%{name}-sharp
133 Summary:        C#/.NET library to access iPod content
134 Summary(pl.UTF-8):      Biblioteka C#/.NET pozwalajaca na dostęp do iPoda
135 Group:          Development/Languages
136 Requires:       %{name} = %{version}-%{release}
137
138 %description -n dotnet-%{name}-sharp
139 C#/.NET library to access iPod content. Provides bindings to the
140 libgpod library.
141
142 %description -n dotnet-%{name}-sharp -l pl.UTF-8
143 Biblioteka C#/.NET pozwalająca na dostęp do iPoda. Udostępnia wiązania
144 do biblioteki libgpod.
145
146 %package -n dotnet-%{name}-sharp-devel
147 Summary:        Development files for libgpod-sharp
148 Summary(pl.UTF-8):      Development files for libgpod-sharp
149 Group:          Development/Languages
150 Requires:       dotnet-%{name}-sharp = %{version}-%{release}
151 Requires:       pkgconfig
152
153 %description -n dotnet-%{name}-sharp-devel
154 C#/.NET library to access iPod content. Provides bindings to the
155 libgpod library.
156
157 This package contains the files required to develop programs that will
158 use dotnet-libgpod-sharp.
159
160 %description -n dotnet-%{name}-sharp-devel -l pl.UTF-8
161 Pliki programistyczne biblioteki C#/.NET libgpod-sharp.
162
163 %prep
164 %setup -q
165 %patch0 -p1
166
167 %build
168 %{__gtkdocize}
169 %{__glib_gettextize}
170 %{__intltoolize}
171 %{__libtoolize}
172 %{__aclocal} -I m4
173 %{__autoconf}
174 %{__autoheader}
175 %{__automake}
176 %configure \
177         --disable-silent-rules \
178         --enable-gtk-doc \
179         --with-html-dir=%{_gtkdocdir} \
180         --with-temp-mount-dir=%{_localstatedir}/run/%{name} \
181         --with-python=yes
182 %{__make}
183
184 %install
185 rm -rf $RPM_BUILD_ROOT
186
187 %{__make} install \
188         DESTDIR=$RPM_BUILD_ROOT
189
190 rm -f $RPM_BUILD_ROOT%{py_sitedir}/gpod/*.{la,a}
191
192 %py_postclean
193
194 %find_lang %{name} --all-name
195
196 %clean
197 rm -rf $RPM_BUILD_ROOT
198
199 %post   -p /sbin/ldconfig
200 %postun -p /sbin/ldconfig
201
202 %files -f %{name}.lang
203 %defattr(644,root,root,755)
204 %doc AUTHORS ChangeLog README
205 %attr(755,root,root) %{_bindir}/ipod-read-sysinfo-extended
206 %attr(755,root,root) %{_libdir}/libgpod.so.*.*.*
207 %attr(755,root,root) %ghost %{_libdir}/libgpod.so.4
208 %dir %{_localstatedir}/run/%{name}
209
210 %files -n hal-libgpod
211 %defattr(644,root,root,755)
212 %attr(755,root,root) %{_libdir}/hal/scripts/libgpod-callout
213 %attr(755,root,root) %{_libdir}/hal/scripts/iphone-callout
214 %{_datadir}/hal/fdi/policy/20thirdparty/20-libgpod-sysinfo-extended.fdi
215
216 %files devel
217 %defattr(644,root,root,755)
218 %attr(755,root,root) %{_libdir}/libgpod.so
219 %{_libdir}/libgpod.la
220 %{_pkgconfigdir}/libgpod-1.0.pc
221 %{_includedir}/gpod-1.0
222
223 %files static
224 %defattr(644,root,root,755)
225 %{_libdir}/libgpod.a
226
227 %files apidocs
228 %defattr(644,root,root,755)
229 %{_gtkdocdir}/libgpod
230
231 %files -n python-gpod
232 %defattr(644,root,root,755)
233 %dir %{py_sitedir}/gpod
234 %{py_sitedir}/gpod/*.py[co]
235 %attr(755,root,root) %{py_sitedir}/gpod/_gpod.so
236
237 %files -n dotnet-%{name}-sharp
238 %defattr(644,root,root,755)
239 %dir %{_libdir}/libgpod
240 %{_libdir}/libgpod/libgpod-sharp-test.exe
241 %{_libdir}/libgpod/libgpod-sharp-test.exe.mdb
242 %{_libdir}/libgpod/libgpod-sharp.dll
243 %{_libdir}/libgpod/libgpod-sharp.dll.config
244 %{_libdir}/libgpod/libgpod-sharp.dll.mdb
245
246 %files -n dotnet-%{name}-sharp-devel
247 %defattr(644,root,root,755)
248 %{_pkgconfigdir}/libgpod-sharp.pc
This page took 0.104645 seconds and 4 git commands to generate.