]> git.pld-linux.org Git - packages/libgpod.git/blob - libgpod.spec
- release 4
[packages/libgpod.git] / libgpod.spec
1 # TODO
2 # check: http://fred.uwcs.co.uk/diff (from http://www.fredemmott.co.uk/blog_121)
3 # some warning at doc build:
4 #warning: failed to load external entity "../../docs/reference/xml/*.xml"
5 #unable to parse ../../docs/reference/xml/*.xml
6 #make[3]: [gpod_doc.i] Error 6 (ignored)
7 # - mountdir perms?: %dir %{_localstatedir}/run/%{name}
8 %include        /usr/lib/rpm/macros.mono
9 #
10 Summary:        Shared library to access the contents of an iPod
11 Summary(pl.UTF-8):      Biblioteka współdzielona do dostępu do zawartości iPodów
12 Name:           libgpod
13 Version:        0.8.0
14 Release:        4
15 License:        GPL v2
16 Group:          Libraries
17 Source0:        http://downloads.sourceforge.net/gtkpod/%{name}-%{version}.tar.gz
18 # Source0-md5:  6660f74cc53293dcc847407aa5f672ce
19 Patch0:         %{name}-gcc43.patch
20 Patch1:         %{name}-monodir.patch
21 URL:            http://www.gtkpod.org/libgpod/
22 BuildRequires:  autoconf >= 2.52
23 BuildRequires:  automake
24 BuildRequires:  docbook-dtd412-xml
25 BuildRequires:  dotnet-gtk-sharp2-devel >= 2.12.0
26 BuildRequires:  gdk-pixbuf2-devel >= 2.6.0
27 BuildRequires:  gettext-devel
28 BuildRequires:  glib2-devel >= 1:2.16.0
29 BuildRequires:  gtk-doc >= 1.0
30 BuildRequires:  hal-devel < 0.6
31 BuildRequires:  hal-devel >= 0.5.7.1
32 BuildRequires:  intltool >= 0.35
33 BuildRequires:  libimobiledevice-devel >= 0.9.7
34 BuildRequires:  libplist-devel >= 1.0.0
35 BuildRequires:  libtool
36 BuildRequires:  libusb-devel
37 BuildRequires:  libxml2-devel
38 BuildRequires:  mono-devel >= 1.9.1
39 BuildRequires:  pkgconfig
40 BuildRequires:  python-devel >= 2.1.1
41 BuildRequires:  python-eyeD3 >= 0.6.6
42 BuildRequires:  python-mutagen >= 1.8
43 BuildRequires:  python-pygobject-devel >= 2.8.0
44 BuildRequires:  rpm-pythonprov
45 BuildRequires:  rpmbuild(monoautodeps)
46 BuildRequires:  sg3_utils-devel >= 1.26
47 BuildRequires:  sqlite3-devel
48 BuildRequires:  swig-python >= 1.3.24
49 BuildRequires:  zlib-devel
50 BuildRequires:  libsmbios-devel
51 # for noinst test only
52 #BuildRequires: taglib-devel
53 Suggests:       hal-libgpod = %{version}-%{release}
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 %description
57 libgpod is a library meant to abstract access to an iPod content. It
58 provides an easy to use API to retrieve the list of files and playlist
59 stored on an iPod, to modify them and to save them back to the iPod.
60
61 %description -l pl.UTF-8
62 libgpod to biblioteka mająca na celu wyabstrahowanie dostępu do
63 zawartości iPodów. Udostępnia łatwe w użyciu API do pobierania listy
64 plików i playlist zapisanych na iPodzie, modyfikowania ich i
65 zapisywania z powrotem na iPoda.
66
67 %package -n hal-libgpod
68 Summary:        HAL callout program for iPod devices
69 Summary(pl.UTF-8):      Program wywoływany przez HAL dla urządzeń iPod
70 Group:          Applications/System
71 Requires:       %{name} = %{version}-%{release}
72 Requires:       hal >= 0.5
73
74 %description -n hal-libgpod
75 HAL callout program to initialize iPod devices for libgpod library.
76
77 %description -n hal-libgpod -l pl.UTF-8
78 Program wywoływany przez HAL do przygotowywania urządzeń iPod do
79 użytku z biblioteką libgpod.
80
81 %package devel
82 Summary:        Header files for libgpod library
83 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libgpod
84 Group:          Development/Libraries
85 Requires:       %{name} = %{version}-%{release}
86 Requires:       gdk-pixbuf2-devel >= 2.6.0
87 Requires:       glib2-devel >= 1:2.16.0
88
89 %description devel
90 This is the package containing the header files for libgpod library.
91
92 %description devel -l pl.UTF-8
93 Ten pakiet zawiera pliki nagłówkowe biblioteki libgpod.
94
95 %package static
96 Summary:        Static libgpod library
97 Summary(pl.UTF-8):      Statyczna biblioteka libgpod
98 Group:          Development/Libraries
99 Requires:       %{name}-devel = %{version}-%{release}
100
101 %description static
102 Static libgpod library.
103
104 %description static -l pl.UTF-8
105 Statyczna biblioteka libgpod.
106
107 %package apidocs
108 Summary:        libgpod API documentation
109 Summary(pl.UTF-8):      Dokumentacja API biblioteki libgpod
110 Group:          Documentation
111 Requires:       gtk-doc-common
112
113 %description apidocs
114 libgpod API documentation.
115
116 %description apidocs -l pl.UTF-8
117 Dokumentacja API biblioteki libgpod.
118
119 %package -n python-gpod
120 Summary:        Module for libgpod access from Python
121 Summary(pl.UTF-8):      Moduł Pythona umożliwiający korzystanie z biblioteki libgpod
122 Group:          Development/Languages/Python
123 Requires:       %{name} = %{version}-%{release}
124 Requires:       python-eyeD3 >= 0.6.6
125 %pyrequires_eq  python-libs
126
127 %description -n python-gpod
128 This is the libgpod Python support package.
129
130 %description -n python-gpod -l pl.UTF-8
131 Moduł umożliwiający korzystanie z biblioteki libgpod z poziomu
132 Pythona.
133
134 %package -n dotnet-%{name}-sharp
135 Summary:        C#/.NET library to access iPod content
136 Summary(pl.UTF-8):      Biblioteka C#/.NET pozwalajaca na dostęp do iPoda
137 Group:          Development/Languages
138 Requires:       %{name} = %{version}-%{release}
139
140 %description -n dotnet-%{name}-sharp
141 C#/.NET library to access iPod content. Provides bindings to the
142 libgpod library.
143
144 %description -n dotnet-%{name}-sharp -l pl.UTF-8
145 Biblioteka C#/.NET pozwalająca na dostęp do iPoda. Udostępnia wiązania
146 do biblioteki libgpod.
147
148 %package -n dotnet-%{name}-sharp-devel
149 Summary:        Development files for libgpod-sharp
150 Summary(pl.UTF-8):      Development files for libgpod-sharp
151 Group:          Development/Languages
152 Requires:       dotnet-%{name}-sharp = %{version}-%{release}
153 Requires:       pkgconfig
154
155 %description -n dotnet-%{name}-sharp-devel
156 C#/.NET library to access iPod content. Provides bindings to the
157 libgpod library.
158
159 This package contains the files required to develop programs that will
160 use dotnet-libgpod-sharp.
161
162 %description -n dotnet-%{name}-sharp-devel -l pl.UTF-8
163 Pliki programistyczne biblioteki C#/.NET libgpod-sharp.
164
165 %prep
166 %setup -q
167 %patch0 -p1
168 %patch1 -p1
169
170 %build
171 %{__gtkdocize}
172 %{__glib_gettextize}
173 %{__intltoolize}
174 %{__libtoolize}
175 %{__aclocal} -I m4
176 %{__autoconf}
177 %{__autoheader}
178 %{__automake}
179 %configure \
180         --disable-silent-rules \
181         --enable-gtk-doc \
182         --with-html-dir=%{_gtkdocdir} \
183         --with-temp-mount-dir=%{_localstatedir}/run/%{name} \
184         --with-python=yes
185 %{__make}
186
187 %install
188 rm -rf $RPM_BUILD_ROOT
189
190 %{__make} install \
191         DESTDIR=$RPM_BUILD_ROOT
192
193 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/gpod/*.la \
194         $RPM_BUILD_ROOT%{_libdir}/libgpod.la
195
196 %py_postclean
197
198 %find_lang %{name} --all-name
199
200 %clean
201 rm -rf $RPM_BUILD_ROOT
202
203 %post   -p /sbin/ldconfig
204 %postun -p /sbin/ldconfig
205
206 %files -f %{name}.lang
207 %defattr(644,root,root,755)
208 %doc AUTHORS ChangeLog README
209 %attr(755,root,root) %{_bindir}/ipod-read-sysinfo-extended
210 %attr(755,root,root) %{_libdir}/libgpod.so.*.*.*
211 %attr(755,root,root) %ghost %{_libdir}/libgpod.so.4
212 %dir %{_localstatedir}/run/%{name}
213
214 %files -n hal-libgpod
215 %defattr(644,root,root,755)
216 %attr(755,root,root) %{_libdir}/hal/scripts/libgpod-callout
217 %attr(755,root,root) %{_libdir}/hal/scripts/iphone-callout
218 %{_datadir}/hal/fdi/policy/20thirdparty/20-libgpod-sysinfo-extended.fdi
219
220 %files devel
221 %defattr(644,root,root,755)
222 %attr(755,root,root) %{_libdir}/libgpod.so
223 %{_pkgconfigdir}/libgpod-1.0.pc
224 %{_includedir}/gpod-1.0
225
226 %files static
227 %defattr(644,root,root,755)
228 %{_libdir}/libgpod.a
229
230 %files apidocs
231 %defattr(644,root,root,755)
232 %{_gtkdocdir}/libgpod
233
234 %files -n python-gpod
235 %defattr(644,root,root,755)
236 %dir %{py_sitedir}/gpod
237 %{py_sitedir}/gpod/*.py[co]
238 %attr(755,root,root) %{py_sitedir}/gpod/_gpod.so
239
240 %files -n dotnet-%{name}-sharp
241 %defattr(644,root,root,755)
242 %dir %{_prefix}/lib/libgpod
243 %{_prefix}/lib/libgpod/libgpod-sharp-test.exe
244 %{_prefix}/lib/libgpod/libgpod-sharp-test.exe.mdb
245 %{_prefix}/lib/libgpod/libgpod-sharp.dll
246 %{_prefix}/lib/libgpod/libgpod-sharp.dll.config
247 %{_prefix}/lib/libgpod/libgpod-sharp.dll.mdb
248
249 %files -n dotnet-%{name}-sharp-devel
250 %defattr(644,root,root,755)
251 %{_pkgconfigdir}/libgpod-sharp.pc
This page took 0.125285 seconds and 4 git commands to generate.