]> git.pld-linux.org Git - packages/libgpod.git/blob - libgpod.spec
- thou shall not be lazy and use metachar, but increase version and note that soname...
[packages/libgpod.git] / libgpod.spec
1 # TODO
2 # check: http://fred.uwcs.co.uk/diff (from http://www.fredemmott.co.uk/blog_121)
3 Summary:        Shared library to access the contents of an iPod
4 Summary(pl.UTF-8):      Biblioteka współdzielona do dostępu do zawartości iPodów
5 Name:           libgpod
6 Version:        0.7.0
7 Release:        1
8 License:        GPL v2
9 Group:          Libraries
10 Source0:        http://dl.sourceforge.net/gtkpod/%{name}-%{version}.tar.gz
11 # Source0-md5:  34eba68a6037e6b2feda20f46d1dbfb8
12 Patch0:         %{name}-gcc43.patch
13 Patch1:         %{name}-sgutils.patch
14 URL:            http://www.gtkpod.org/libgpod.html
15 BuildRequires:  autoconf >= 2.52
16 BuildRequires:  automake
17 BuildRequires:  dbus-glib-devel >= 0.30
18 BuildRequires:  gettext-devel
19 BuildRequires:  gtk+2-devel >= 2.0
20 BuildRequires:  gtk-doc >= 1.0
21 BuildRequires:  hal-devel < 0.6
22 BuildRequires:  hal-devel >= 0.5.7.1
23 BuildRequires:  intltool >= 0.35
24 BuildRequires:  libtool
25 BuildRequires:  pkgconfig
26 BuildRequires:  python-devel >= 2.1.1
27 BuildRequires:  python-eyeD3 >= 0.6.6
28 BuildRequires:  python-mutagen >= 1.8
29 BuildRequires:  rpm-pythonprov
30 BuildRequires:  sg3_utils-devel >= 1.26
31 BuildRequires:  swig-python >= 1.3.24
32 # for noinst test only
33 #BuildRequires: taglib-devel
34 Suggests:       hal-libgpod = %{version}-%{release}
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 libgpod is a library meant to abstract access to an iPod content. It
39 provides an easy to use API to retrieve the list of files and playlist
40 stored on an iPod, to modify them and to save them back to the iPod.
41
42 %description -l pl.UTF-8
43 libgpod to biblioteka mająca na celu wyabstrahowanie dostępu do
44 zawartości iPodów. Udostępnia łatwe w użyciu API do pobierania listy
45 plików i playlist zapisanych na iPodzie, modyfikowania ich i
46 zapisywania z powrotem na iPoda.
47
48 %package -n hal-libgpod
49 Summary:        HAL callout program for iPod devices
50 Summary(pl.UTF-8):      Program wywoływany przez HAL dla urządzeń iPod
51 Group:          Applications/System
52 Requires:       %{name} = %{version}-%{release}
53 Requires:       hal >= 0.5
54
55 %description -n hal-libgpod
56 HAL callout program to initialize iPod devices for libgpod library.
57
58 %description -n hal-libgpod -l pl.UTF-8
59 Program wywoływany przez HAL do przygotowywania urządzeń iPod do
60 użytku z biblioteką libgpod.
61
62 %package devel
63 Summary:        Header files for libgpod library
64 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libgpod
65 Group:          Development/Libraries
66 Requires:       %{name} = %{version}-%{release}
67 Requires:       dbus-glib-devel >= 0.30
68 Requires:       gtk+2-devel >= 2.0
69 Requires:       hal-devel >= 0.5.7.1
70
71 %description devel
72 This is the package containing the header files for libgpod library.
73
74 %description devel -l pl.UTF-8
75 Ten pakiet zawiera pliki nagłówkowe biblioteki libgpod.
76
77 %package static
78 Summary:        Static libgpod library
79 Summary(pl.UTF-8):      Statyczna biblioteka libgpod
80 Group:          Development/Libraries
81 Requires:       %{name}-devel = %{version}-%{release}
82
83 %description static
84 Static libgpod library.
85
86 %description static -l pl.UTF-8
87 Statyczna biblioteka libgpod.
88
89 %package apidocs
90 Summary:        libgpod API documentation
91 Summary(pl.UTF-8):      Dokumentacja API biblioteki libgpod
92 Group:          Documentation
93 Requires:       gtk-doc-common
94
95 %description apidocs
96 libgpod API documentation.
97
98 %description apidocs -l pl.UTF-8
99 Dokumentacja API biblioteki libgpod.
100
101 %package -n python-gpod
102 Summary:        Libraries for libgpod access from Python
103 Summary(pl.UTF-8):      Biblioteki Pythona umożliwiające korzystanie z libgpod
104 Group:          Development/Languages/Python
105 Requires:       %{name} = %{version}-%{release}
106 Requires:       python-eyeD3 >= 0.6.6
107 %pyrequires_eq  python-libs
108
109 %description -n python-gpod
110 This is the libgpod Python support package.
111
112 %description -n python-gpod -l pl.UTF-8
113 Biblioteki umożliwiające korzystanie z libgpod z poziomu Pythona.
114
115 %prep
116 %setup -q
117 %patch0 -p1
118 %patch1 -p1
119
120 %build
121 %{__gtkdocize}
122 %{__glib_gettextize}
123 %{__intltoolize}
124 %{__libtoolize}
125 %{__aclocal} -I m4
126 %{__autoconf}
127 %{__autoheader}
128 %{__automake}
129 %configure \
130         --with-html-dir=%{_gtkdocdir} \
131         --with-python=yes
132 %{__make}
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136
137 %{__make} install \
138         DESTDIR=$RPM_BUILD_ROOT
139
140 rm -f $RPM_BUILD_ROOT%{py_sitedir}/gpod/*.{la,a}
141
142 %py_postclean
143
144 %find_lang %{name} --all-name
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %post   -p /sbin/ldconfig
150 %postun -p /sbin/ldconfig
151
152 %files -f %{name}.lang
153 %defattr(644,root,root,755)
154 %doc AUTHORS ChangeLog README
155 %attr(755,root,root) %{_bindir}/ipod-read-sysinfo-extended
156 %attr(755,root,root) %{_libdir}/libgpod.so.*.*.*
157 %attr(755,root,root) %ghost %{_libdir}/libgpod.so.4
158
159 %files -n hal-libgpod
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{_libdir}/hal/libgpod-callout
162 %{_datadir}/hal/fdi/policy/20thirdparty/20-libgpod-sysinfo-extended.fdi
163
164 %files devel
165 %defattr(644,root,root,755)
166 %attr(755,root,root) %{_libdir}/libgpod.so
167 %{_libdir}/libgpod.la
168 %{_pkgconfigdir}/libgpod-1.0.pc
169 %{_includedir}/gpod-1.0
170
171 %files static
172 %defattr(644,root,root,755)
173 %{_libdir}/libgpod.a
174
175 %files apidocs
176 %defattr(644,root,root,755)
177 %{_gtkdocdir}/libgpod
178
179 %files -n python-gpod
180 %defattr(644,root,root,755)
181 %dir %{py_sitedir}/gpod
182 %{py_sitedir}/gpod/*.py[co]
183 %attr(755,root,root) %{py_sitedir}/gpod/_gpod.so
This page took 0.114031 seconds and 4 git commands to generate.