]> git.pld-linux.org Git - packages/libgpod.git/blob - libgpod.spec
- BR: sg3_utils-devel
[packages/libgpod.git] / libgpod.spec
1 Summary:        Shared library to access the contents of an iPod
2 Summary(pl.UTF-8):      Biblioteka współdzielona do dostępu do zawartości iPodów
3 Name:           libgpod
4 Version:        0.6.0
5 Release:        2
6 License:        GPL v2
7 Group:          Libraries
8 Source0:        http://dl.sourceforge.net/gtkpod/%{name}-%{version}.tar.gz
9 # Source0-md5:  b44d8aee3f6610370b6faf61770c5f3c
10 URL:            http://www.gtkpod.org/libgpod.html
11 BuildRequires:  autoconf >= 2.52
12 BuildRequires:  automake
13 BuildRequires:  dbus-glib-devel >= 0.71
14 BuildRequires:  gettext-devel
15 BuildRequires:  gtk+2-devel >= 2:2.10.1
16 BuildRequires:  gtk-doc >= 1.0
17 BuildRequires:  hal-devel < 0.6
18 BuildRequires:  hal-devel >= 0.5.7.1
19 BuildRequires:  intltool >= 0.35
20 BuildRequires:  libtool
21 BuildRequires:  pkgconfig
22 BuildRequires:  python-devel >= 2.1.1
23 BuildRequires:  python-eyeD3 >= 0.6.6
24 BuildRequires:  python-mutagen >= 1.11
25 BuildRequires:  rpm-pythonprov
26 BuildRequires:  sg3_utils-devel
27 BuildRequires:  swig-python >= 1.3.24
28 # for noinst test only
29 #BuildRequires: taglib-devel
30 Requires:       hal
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 libgpod is a library meant to abstract access to an iPod content. It
35 provides an easy to use API to retrieve the list of files and playlist
36 stored on an iPod, to modify them and to save them back to the iPod.
37
38 %description -l pl.UTF-8
39 libgpod to biblioteka mająca na celu wyabstrahowanie dostępu do
40 zawartości iPodów. Udostępnia łatwe w użyciu API do pobierania listy
41 plików i playlist zapisanych na iPodzie, modyfikowania ich i
42 zapisywania z powrotem na iPoda.
43
44 %package devel
45 Summary:        Header files for libgpod library
46 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libgpod
47 Group:          Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49 Requires:       dbus-glib-devel >= 0.71
50 Requires:       gtk+2-devel >= 2:2.10.1
51 Requires:       hal-devel >= 0.5.7.1
52
53 %description devel
54 This is the package containing the header files for libgpod library.
55
56 %description devel -l pl.UTF-8
57 Ten pakiet zawiera pliki nagłówkowe biblioteki libgpod.
58
59 %package static
60 Summary:        Static libgpod library
61 Summary(pl.UTF-8):      Statyczna biblioteka libgpod
62 Group:          Development/Libraries
63 Requires:       %{name}-devel = %{version}-%{release}
64
65 %description static
66 Static libgpod library.
67
68 %description static -l pl.UTF-8
69 Statyczna biblioteka libgpod.
70
71 %package apidocs
72 Summary:        libgpod API documentation
73 Summary(pl.UTF-8):      Dokumentacja API biblioteki libgpod
74 Group:          Documentation
75 Requires:       gtk-doc-common
76
77 %description apidocs
78 libgpod API documentation.
79
80 %description apidocs -l pl.UTF-8
81 Dokumentacja API biblioteki libgpod.
82
83 %package -n python-gpod
84 Summary:        Libraries for libgpod access from Python
85 Summary(pl.UTF-8):      Biblioteki Pythona umożliwiające korzystanie z libgpod
86 Group:          Development/Languages/Python
87 Requires:       %{name} = %{version}-%{release}
88 Requires:       python-eyeD3 >= 0.6.6
89 %pyrequires_eq  python-libs
90
91 %description -n python-gpod
92 This is the libgpod Python support package.
93
94 %description -n python-gpod -l pl.UTF-8
95 Biblioteki umożliwiające korzystanie z libgpod z poziomu Pythona.
96
97 %prep
98 %setup -q
99
100 %build
101 %{__gtkdocize}
102 %{__glib_gettextize}
103 %{__intltoolize}
104 %{__libtoolize}
105 %{__aclocal} -I m4
106 %{__autoconf}
107 %{__autoheader}
108 %{__automake}
109 %configure \
110         --with-html-dir=%{_gtkdocdir} \
111         --with-python=yes
112 %{__make}
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116
117 %{__make} install \
118         DESTDIR=$RPM_BUILD_ROOT
119
120 rm -f $RPM_BUILD_ROOT%{py_sitedir}/gpod/*.{la,a}
121
122 %py_postclean
123
124 %find_lang %{name} --all-name
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %post   -p /sbin/ldconfig
130 %postun -p /sbin/ldconfig
131
132 %files -f %{name}.lang
133 %defattr(644,root,root,755)
134 %doc AUTHORS ChangeLog README
135 %attr(755,root,root) %{_bindir}/ipod-read-sysinfo-extended
136 %attr(755,root,root) %{_libdir}/libgpod.so.*.*.*
137 %attr(755,root,root) %{_libdir}/hal/libgpod-callout
138 %{_datadir}/hal/fdi/policy/20thirdparty/20-libgpod-sysinfo-extended.fdi
139
140 %files devel
141 %defattr(644,root,root,755)
142 %attr(755,root,root) %{_libdir}/libgpod.so
143 %{_libdir}/libgpod.la
144 %{_pkgconfigdir}/libgpod-1.0.pc
145 %{_includedir}/gpod-1.0
146
147 %files static
148 %defattr(644,root,root,755)
149 %{_libdir}/libgpod.a
150
151 %files apidocs
152 %defattr(644,root,root,755)
153 %{_gtkdocdir}/libgpod
154
155 %files -n python-gpod
156 %defattr(644,root,root,755)
157 %dir %{py_sitedir}/gpod
158 %{py_sitedir}/gpod/*.py[co]
159 %attr(755,root,root) %{py_sitedir}/gpod/_gpod.so
This page took 0.073799 seconds and 4 git commands to generate.