]> git.pld-linux.org Git - packages/libgpod.git/blob - libgpod.spec
- dotnet packaging, rfc for corrections
[packages/libgpod.git] / libgpod.spec
1 # TODO
2 # check: http://fred.uwcs.co.uk/diff (from http://www.fredemmott.co.uk/blog_121)
3 # some warning at doc build:
4 #warning: failed to load external entity "../../docs/reference/xml/*.xml"
5 #unable to parse ../../docs/reference/xml/*.xml
6 #make[3]: [gpod_doc.i] Error 6 (ignored)
7 # - mountdir perms?: %dir %{_localstatedir}/run/%{name}
8 # - dotnet pkg executable bits for .exe?
9 Summary:        Shared library to access the contents of an iPod
10 Summary(pl.UTF-8):      Biblioteka współdzielona do dostępu do zawartości iPodów
11 Name:           libgpod
12 Version:        0.8.0
13 Release:        0.1
14 License:        GPL v2
15 Group:          Libraries
16 Source0:        http://downloads.sourceforge.net/gtkpod/%{name}-%{version}.tar.gz
17 # Source0-md5:  6660f74cc53293dcc847407aa5f672ce
18 Patch0:         %{name}-gcc43.patch
19 URL:            http://www.gtkpod.org/libgpod/
20 BuildRequires:  autoconf >= 2.52
21 BuildRequires:  automake
22 BuildRequires:  dbus-glib-devel >= 0.30
23 BuildRequires:  docbook-dtd412-xml
24 BuildRequires:  dotnet-gtk-sharp2-devel >= 2.12
25 BuildRequires:  gettext-devel
26 BuildRequires:  gtk+2-devel >= 2.0
27 BuildRequires:  gtk-doc >= 1.0
28 BuildRequires:  hal-devel < 0.6
29 BuildRequires:  hal-devel >= 0.5.7.1
30 BuildRequires:  intltool >= 0.35
31 BuildRequires:  libtool
32 BuildRequires:  mono-devel >= 1.9.1
33 BuildRequires:  pkgconfig
34 BuildRequires:  python-devel >= 2.1.1
35 BuildRequires:  python-eyeD3 >= 0.6.6
36 BuildRequires:  python-mutagen >= 1.8
37 BuildRequires:  rpm-pythonprov
38 BuildRequires:  sg3_utils-devel >= 1.26
39 BuildRequires:  swig-python >= 1.3.24
40 # for noinst test only
41 #BuildRequires: taglib-devel
42 Suggests:       hal-libgpod = %{version}-%{release}
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 libgpod is a library meant to abstract access to an iPod content. It
47 provides an easy to use API to retrieve the list of files and playlist
48 stored on an iPod, to modify them and to save them back to the iPod.
49
50 %description -l pl.UTF-8
51 libgpod to biblioteka mająca na celu wyabstrahowanie dostępu do
52 zawartości iPodów. Udostępnia łatwe w użyciu API do pobierania listy
53 plików i playlist zapisanych na iPodzie, modyfikowania ich i
54 zapisywania z powrotem na iPoda.
55
56 %package -n hal-libgpod
57 Summary:        HAL callout program for iPod devices
58 Summary(pl.UTF-8):      Program wywoływany przez HAL dla urządzeń iPod
59 Group:          Applications/System
60 Requires:       %{name} = %{version}-%{release}
61 Requires:       hal >= 0.5
62
63 %description -n hal-libgpod
64 HAL callout program to initialize iPod devices for libgpod library.
65
66 %description -n hal-libgpod -l pl.UTF-8
67 Program wywoływany przez HAL do przygotowywania urządzeń iPod do
68 użytku z biblioteką libgpod.
69
70 %package devel
71 Summary:        Header files for libgpod library
72 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libgpod
73 Group:          Development/Libraries
74 Requires:       %{name} = %{version}-%{release}
75 Requires:       dbus-glib-devel >= 0.30
76 Requires:       gtk+2-devel >= 2.0
77 Requires:       hal-devel >= 0.5.7.1
78
79 %description devel
80 This is the package containing the header files for libgpod library.
81
82 %description devel -l pl.UTF-8
83 Ten pakiet zawiera pliki nagłówkowe biblioteki libgpod.
84
85 %package static
86 Summary:        Static libgpod library
87 Summary(pl.UTF-8):      Statyczna biblioteka libgpod
88 Group:          Development/Libraries
89 Requires:       %{name}-devel = %{version}-%{release}
90
91 %description static
92 Static libgpod library.
93
94 %description static -l pl.UTF-8
95 Statyczna biblioteka libgpod.
96
97 %package apidocs
98 Summary:        libgpod API documentation
99 Summary(pl.UTF-8):      Dokumentacja API biblioteki libgpod
100 Group:          Documentation
101 Requires:       gtk-doc-common
102
103 %description apidocs
104 libgpod API documentation.
105
106 %description apidocs -l pl.UTF-8
107 Dokumentacja API biblioteki libgpod.
108
109 %package -n python-gpod
110 Summary:        Libraries for libgpod access from Python
111 Summary(pl.UTF-8):      Biblioteki Pythona umożliwiające korzystanie z libgpod
112 Group:          Development/Languages/Python
113 Requires:       %{name} = %{version}-%{release}
114 Requires:       python-eyeD3 >= 0.6.6
115 %pyrequires_eq  python-libs
116
117 %description -n python-gpod
118 This is the libgpod Python support package.
119
120 %description -n python-gpod -l pl.UTF-8
121 Biblioteki umożliwiające korzystanie z libgpod z poziomu Pythona.
122
123 %package -n dotnet-%{name}-sharp
124 Summary:        C#/.NET library to access iPod content
125 Group:          Development/Languages
126 Requires:       %{name} = %{version}-%{release}
127
128 %description -n dotnet-%{name}-sharp
129 C#/.NET library to access iPod content. Provides bindings to the
130 libgpod library.
131
132 %package -n dotnet-%{name}-sharp-devel
133 Summary:        C#/.NET library to access iPod content
134 Summary:        Development files for libgpod-sharp
135 Group:          Development/Languages
136 Requires:       dotnet-%{name}-sharp = %{version}-%{release}
137 Requires:       pkgconfig
138
139 %description -n dotnet-%{name}-sharp-devel
140 C#/.NET library to access iPod content. Provides bindings to the
141 libgpod library.
142
143 This package contains the files required to develop programs that will
144 use dotnet-libgpod-sharp.
145
146 %prep
147 %setup -q
148 %patch0 -p1
149
150 %build
151 %{__gtkdocize}
152 %{__glib_gettextize}
153 %{__intltoolize}
154 %{__libtoolize}
155 %{__aclocal} -I m4
156 %{__autoconf}
157 %{__autoheader}
158 %{__automake}
159 %configure \
160         --with-html-dir=%{_gtkdocdir} \
161         --with-temp-mount-dir=%{_localstatedir}/run/%{name} \
162         --with-python=yes
163 %{__make}
164
165 %install
166 rm -rf $RPM_BUILD_ROOT
167
168 %{__make} install \
169         DESTDIR=$RPM_BUILD_ROOT
170
171 rm -f $RPM_BUILD_ROOT%{py_sitedir}/gpod/*.{la,a}
172
173 %py_postclean
174
175 %find_lang %{name} --all-name
176
177 %clean
178 rm -rf $RPM_BUILD_ROOT
179
180 %post   -p /sbin/ldconfig
181 %postun -p /sbin/ldconfig
182
183 %files -f %{name}.lang
184 %defattr(644,root,root,755)
185 %doc AUTHORS ChangeLog README
186 %attr(755,root,root) %{_bindir}/ipod-read-sysinfo-extended
187 %attr(755,root,root) %{_libdir}/libgpod.so.*.*.*
188 %attr(755,root,root) %ghost %{_libdir}/libgpod.so.4
189 %dir %{_localstatedir}/run/%{name}
190
191 %files -n hal-libgpod
192 %defattr(644,root,root,755)
193 %attr(755,root,root) %{_libdir}/hal/scripts/libgpod-callout
194 %attr(755,root,root) %{_libdir}/hal/scripts/iphone-callout
195 %{_datadir}/hal/fdi/policy/20thirdparty/20-libgpod-sysinfo-extended.fdi
196
197 %files devel
198 %defattr(644,root,root,755)
199 %attr(755,root,root) %{_libdir}/libgpod.so
200 %{_libdir}/libgpod.la
201 %{_pkgconfigdir}/libgpod-1.0.pc
202 %{_includedir}/gpod-1.0
203
204 %files static
205 %defattr(644,root,root,755)
206 %{_libdir}/libgpod.a
207
208 %files apidocs
209 %defattr(644,root,root,755)
210 %{_gtkdocdir}/libgpod
211
212 %files -n python-gpod
213 %defattr(644,root,root,755)
214 %dir %{py_sitedir}/gpod
215 %{py_sitedir}/gpod/*.py[co]
216 %attr(755,root,root) %{py_sitedir}/gpod/_gpod.so
217
218 %files -n dotnet-%{name}-sharp
219 %defattr(644,root,root,755)
220 %dir %{_libdir}/%{name}
221 %{_libdir}/%{name}/%{name}-sharp-test.exe
222 %{_libdir}/%{name}/%{name}-sharp-test.exe.mdb
223 %{_libdir}/%{name}/%{name}-sharp.dll
224 %{_libdir}/%{name}/%{name}-sharp.dll.config
225 %{_libdir}/%{name}/%{name}-sharp.dll.mdb
226
227 %files -n dotnet-%{name}-sharp-devel
228 %defattr(644,root,root,755)
229 %{_pkgconfigdir}/%{name}-sharp.pc
This page took 0.044982 seconds and 4 git commands to generate.