]> git.pld-linux.org Git - packages/libgpod.git/blob - libgpod.spec
- 0.6.0
[packages/libgpod.git] / libgpod.spec
1 Summary:        Shared library to access the contents of an iPod
2 Summary(pl.UTF-8):      Biblioteka współdzielona do dostępu do zawartości iPodów
3 Name:           libgpod
4 Version:        0.6.0
5 Release:        1
6 License:        GPL v2
7 Group:          Libraries
8 Source0:        http://dl.sourceforge.net/gtkpod/%{name}-%{version}.tar.gz
9 # Source0-md5:  b44d8aee3f6610370b6faf61770c5f3c
10 URL:            http://www.gtkpod.org/libgpod.html
11 BuildRequires:  autoconf >= 2.52
12 BuildRequires:  automake
13 BuildRequires:  dbus-glib-devel >= 0.71
14 BuildRequires:  gettext-devel
15 BuildRequires:  gtk+2-devel >= 2:2.10.1
16 BuildRequires:  gtk-doc >= 1.0
17 BuildRequires:  hal-devel < 0.6
18 BuildRequires:  hal-devel >= 0.5.7.1
19 BuildRequires:  intltool >= 0.35
20 BuildRequires:  libtool
21 BuildRequires:  pkgconfig
22 BuildRequires:  python-devel >= 2.1.1
23 BuildRequires:  python-eyeD3 >= 0.6.6
24 BuildRequires:  python-mutagen >= 1.11
25 BuildRequires:  rpm-pythonprov
26 BuildRequires:  swig-python >= 1.3.24
27 # for noinst test only
28 #BuildRequires: taglib-devel
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 libgpod is a library meant to abstract access to an iPod content. It
33 provides an easy to use API to retrieve the list of files and playlist
34 stored on an iPod, to modify them and to save them back to the iPod.
35
36 %description -l pl.UTF-8
37 libgpod to biblioteka mająca na celu wyabstrahowanie dostępu do
38 zawartości iPodów. Udostępnia łatwe w użyciu API do pobierania listy
39 plików i playlist zapisanych na iPodzie, modyfikowania ich i
40 zapisywania z powrotem na iPoda.
41
42 %package devel
43 Summary:        Header files for libgpod library
44 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libgpod
45 Group:          Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47 Requires:       dbus-glib-devel >= 0.71
48 Requires:       gtk+2-devel >= 2:2.10.1
49 Requires:       hal-devel >= 0.5.7.1
50
51 %description devel
52 This is the package containing the header files for libgpod library.
53
54 %description devel -l pl.UTF-8
55 Ten pakiet zawiera pliki nagłówkowe biblioteki libgpod.
56
57 %package static
58 Summary:        Static libgpod library
59 Summary(pl.UTF-8):      Statyczna biblioteka libgpod
60 Group:          Development/Libraries
61 Requires:       %{name}-devel = %{version}-%{release}
62
63 %description static
64 Static libgpod library.
65
66 %description static -l pl.UTF-8
67 Statyczna biblioteka libgpod.
68
69 %package apidocs
70 Summary:        libgpod API documentation
71 Summary(pl.UTF-8):      Dokumentacja API biblioteki libgpod
72 Group:          Documentation
73 Requires:       gtk-doc-common
74
75 %description apidocs
76 libgpod API documentation.
77
78 %description apidocs -l pl.UTF-8
79 Dokumentacja API biblioteki libgpod.
80
81 %package -n python-gpod
82 Summary:        Libraries for libgpod access from Python
83 Summary(pl.UTF-8):      Biblioteki Pythona umożliwiające korzystanie z libgpod
84 Group:          Development/Languages/Python
85 Requires:       %{name} = %{version}-%{release}
86 Requires:       python-eyeD3 >= 0.6.6
87 %pyrequires_eq  python-libs
88
89 %description -n python-gpod
90 This is the libgpod Python support package.
91
92 %description -n python-gpod -l pl.UTF-8
93 Biblioteki umożliwiające korzystanie z libgpod z poziomu Pythona.
94
95 %prep
96 %setup -q
97
98 %build
99 %{__gtkdocize}
100 %{__glib_gettextize}
101 %{__intltoolize}
102 %{__libtoolize}
103 %{__aclocal} -I m4
104 %{__autoconf}
105 %{__autoheader}
106 %{__automake}
107 %configure \
108         --with-html-dir=%{_gtkdocdir} \
109         --with-python=yes
110 %{__make}
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114
115 %{__make} install \
116         DESTDIR=$RPM_BUILD_ROOT
117
118 rm -f $RPM_BUILD_ROOT%{py_sitedir}/gpod/*.{la,a}
119
120 %py_postclean
121
122 %find_lang %{name} --all-name
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %post   -p /sbin/ldconfig
128 %postun -p /sbin/ldconfig
129
130 %files -f %{name}.lang
131 %defattr(644,root,root,755)
132 %doc AUTHORS ChangeLog README
133 %attr(755,root,root) %{_bindir}/ipod-read-sysinfo-extended
134 %attr(755,root,root) %{_libdir}/libgpod.so.*.*.*
135 %attr(755,root,root) %{_libdir}/hal/libgpod-callout
136 %{_datadir}/hal/fdi/policy/20thirdparty/20-libgpod-sysinfo-extended.fdi
137
138 %files devel
139 %defattr(644,root,root,755)
140 %attr(755,root,root) %{_libdir}/libgpod.so
141 %{_libdir}/libgpod.la
142 %{_pkgconfigdir}/libgpod-1.0.pc
143 %{_includedir}/gpod-1.0
144
145 %files static
146 %defattr(644,root,root,755)
147 %{_libdir}/libgpod.a
148
149 %files apidocs
150 %defattr(644,root,root,755)
151 %{_gtkdocdir}/libgpod
152
153 %files -n python-gpod
154 %defattr(644,root,root,755)
155 %dir %{py_sitedir}/gpod
156 %{py_sitedir}/gpod/*.py[co]
157 %attr(755,root,root) %{py_sitedir}/gpod/_gpod.so
This page took 0.11275 seconds and 4 git commands to generate.