]> git.pld-linux.org Git - packages/libgpod.git/blob - libgpod.spec
- require rpm 4.6+ (covers both noarch subpackages and mono autodeps)
[packages/libgpod.git] / libgpod.spec
1 # TODO
2 # check: http://fred.uwcs.co.uk/diff (from http://www.fredemmott.co.uk/blog_121)
3 # some warning at doc build:
4 #warning: failed to load external entity "../../docs/reference/xml/*.xml"
5 #unable to parse ../../docs/reference/xml/*.xml
6 #make[3]: [gpod_doc.i] Error 6 (ignored)
7 # - mountdir perms?: %dir %{_localstatedir}/run/%{name}
8 #
9 # Conditional build:
10 %bcond_without  dotnet  # .NET bindings
11 %bcond_without  python  # Python bindings
12
13 %ifarch x32
14 %undefine       with_dotnet
15 %endif
16
17 Summary:        Shared library to access the contents of an iPod
18 Summary(pl.UTF-8):      Biblioteka współdzielona do dostępu do zawartości iPodów
19 Name:           libgpod
20 Version:        0.8.3
21 Release:        8
22 License:        GPL v2
23 Group:          Libraries
24 Source0:        http://downloads.sourceforge.net/gtkpod/%{name}-%{version}.tar.bz2
25 # Source0-md5:  f8a0b7a34e768e33a708e8dd172bd6f8
26 Source1:        %{name}.tmpfiles
27 Patch0:         %{name}-gcc43.patch
28 Patch1:         %{name}-monodir.patch
29 Patch2:         mono4.patch
30 Patch3:         %{name}-swig.patch
31 Patch4:         %{name}-libplist.patch
32 URL:            http://www.gtkpod.org/libgpod/
33 BuildRequires:  autoconf >= 2.65
34 BuildRequires:  automake
35 BuildRequires:  docbook-dtd412-xml
36 BuildRequires:  gdk-pixbuf2-devel >= 2.6.0
37 BuildRequires:  gettext-tools
38 BuildRequires:  glib2-devel >= 1:2.16.0
39 BuildRequires:  gtk-doc >= 1.0
40 BuildRequires:  intltool >= 0.35
41 BuildRequires:  libimobiledevice-devel >= 1.1.5
42 BuildRequires:  libplist-devel >= 2.2.0
43 BuildRequires:  libsmbios-devel
44 BuildRequires:  libtool >= 2:2
45 BuildRequires:  libusb-devel >= 1.0
46 BuildRequires:  libxml2-devel >= 2.0
47 BuildRequires:  pkgconfig
48 BuildRequires:  rpm-build >= 4.6
49 BuildRequires:  rpmbuild(macros) >= 1.647
50 BuildRequires:  sg3_utils-devel >= 1.26
51 BuildRequires:  sqlite3-devel >= 3
52 BuildRequires:  zlib-devel
53 # for noinst test only
54 #BuildRequires: taglib-devel
55 %if %{with dotnet}
56 BuildRequires:  dotnet-gtk-sharp2-devel >= 2.12.0
57 BuildRequires:  mono-csharp >= 1.9.1
58 BuildRequires:  mono-devel >= 1.9.1
59 %endif
60 %if %{with python}
61 BuildRequires:  python-devel >= 2.1.1
62 BuildRequires:  python-mutagen >= 1.8
63 BuildRequires:  python-pygobject-devel >= 2.8.0
64 BuildRequires:  rpm-pythonprov
65 BuildRequires:  swig-python >= 1.3.24
66 %endif
67 Requires:       glib2 >= 1:2.16.0
68 Requires:       libimobiledevice >= 1.1.5
69 Requires:       libplist >= 2.2.0
70 Suggests:       udev-libgpod = %{version}-%{release}
71 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
72
73 %description
74 libgpod is a library meant to abstract access to an iPod content. It
75 provides an easy to use API to retrieve the list of files and playlist
76 stored on an iPod, to modify them and to save them back to the iPod.
77
78 %description -l pl.UTF-8
79 libgpod to biblioteka mająca na celu wyabstrahowanie dostępu do
80 zawartości iPodów. Udostępnia łatwe w użyciu API do pobierania listy
81 plików i playlist zapisanych na iPodzie, modyfikowania ich i
82 zapisywania z powrotem na iPoda.
83
84 %package -n udev-libgpod
85 Summary:        UDEV rules and programs for iPod devices
86 Summary(pl.UTF-8):      Reguły i programy używane przez UDEV dla urządzeń iPod
87 Group:          Applications/System
88 Requires:       %{name} = %{version}-%{release}
89 Obsoletes:      hal-libgpod
90
91 %description -n udev-libgpod
92 UDEV rules and programs to initialize iPod devices for libgpod
93 library.
94
95 %description -n udev-libgpod -l pl.UTF-8
96 Reguły i program dla UDEV do przygotowywania urządzeń iPod do użytku z
97 biblioteką libgpod.
98
99 %package devel
100 Summary:        Header files for libgpod library
101 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libgpod
102 Group:          Development/Libraries
103 Requires:       %{name} = %{version}-%{release}
104 Requires:       gdk-pixbuf2-devel >= 2.6.0
105 Requires:       glib2-devel >= 1:2.16.0
106
107 %description devel
108 This is the package containing the header files for libgpod library.
109
110 %description devel -l pl.UTF-8
111 Ten pakiet zawiera pliki nagłówkowe biblioteki libgpod.
112
113 %package static
114 Summary:        Static libgpod library
115 Summary(pl.UTF-8):      Statyczna biblioteka libgpod
116 Group:          Development/Libraries
117 Requires:       %{name}-devel = %{version}-%{release}
118
119 %description static
120 Static libgpod library.
121
122 %description static -l pl.UTF-8
123 Statyczna biblioteka libgpod.
124
125 %package apidocs
126 Summary:        libgpod API documentation
127 Summary(pl.UTF-8):      Dokumentacja API biblioteki libgpod
128 Group:          Documentation
129 Requires:       gtk-doc-common
130 BuildArch:      noarch
131
132 %description apidocs
133 libgpod API documentation.
134
135 %description apidocs -l pl.UTF-8
136 Dokumentacja API biblioteki libgpod.
137
138 %package -n python-gpod
139 Summary:        Module for libgpod access from Python
140 Summary(pl.UTF-8):      Moduł Pythona umożliwiający korzystanie z biblioteki libgpod
141 Group:          Development/Languages/Python
142 Requires:       %{name} = %{version}-%{release}
143 Requires:       python-libs
144 Requires:       python-mutagen >= 1.8
145 Requires:       python-pygobject >= 2.8.0
146
147 %description -n python-gpod
148 This is the libgpod Python support package.
149
150 %description -n python-gpod -l pl.UTF-8
151 Moduł umożliwiający korzystanie z biblioteki libgpod z poziomu
152 Pythona.
153
154 %package -n dotnet-%{name}-sharp
155 Summary:        C#/.NET library to access iPod content
156 Summary(pl.UTF-8):      Biblioteka C#/.NET pozwalajaca na dostęp do iPoda
157 Group:          Development/Languages
158 Requires:       %{name} = %{version}-%{release}
159
160 %description -n dotnet-%{name}-sharp
161 C#/.NET library to access iPod content. Provides bindings to the
162 libgpod library.
163
164 %description -n dotnet-%{name}-sharp -l pl.UTF-8
165 Biblioteka C#/.NET pozwalająca na dostęp do iPoda. Udostępnia wiązania
166 do biblioteki libgpod.
167
168 %package -n dotnet-%{name}-sharp-devel
169 Summary:        Development files for libgpod-sharp
170 Summary(pl.UTF-8):      Development files for libgpod-sharp
171 Group:          Development/Languages
172 Requires:       dotnet-%{name}-sharp = %{version}-%{release}
173 Requires:       pkgconfig
174
175 %description -n dotnet-%{name}-sharp-devel
176 C#/.NET library to access iPod content. Provides bindings to the
177 libgpod library.
178
179 This package contains the files required to develop programs that will
180 use dotnet-libgpod-sharp.
181
182 %description -n dotnet-%{name}-sharp-devel -l pl.UTF-8
183 Pliki programistyczne biblioteki C#/.NET libgpod-sharp.
184
185 %prep
186 %setup -q
187 %patch0 -p1
188 %patch1 -p1
189 %patch2 -p1
190 %patch3 -p1
191 %patch4 -p1
192
193 %build
194 %{__gtkdocize}
195 %{__glib_gettextize}
196 %{__intltoolize}
197 %{__libtoolize}
198 %{__aclocal} -I m4
199 %{__autoconf}
200 %{__autoheader}
201 %{__automake}
202 %configure \
203         --disable-silent-rules \
204         --enable-gtk-doc \
205         --enable-mono%{!?with_dotnet:=no} \
206         --enable-udev \
207         --with-html-dir=%{_gtkdocdir} \
208         --with-python%{!?with_python:=no} \
209         --with-temp-mount-dir=%{_localstatedir}/run/%{name} \
210         --without-hal
211
212 %{__make}
213
214 %install
215 rm -rf $RPM_BUILD_ROOT
216 install -d $RPM_BUILD_ROOT%{systemdtmpfilesdir}
217
218 %{__make} install \
219         DESTDIR=$RPM_BUILD_ROOT
220
221 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpod.la
222
223 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
224
225 %if %{with python}
226 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/gpod/*.la
227 %py_postclean
228 %endif
229
230 %find_lang %{name} --all-name
231
232 %clean
233 rm -rf $RPM_BUILD_ROOT
234
235 %post   -p /sbin/ldconfig
236 %postun -p /sbin/ldconfig
237
238 %files -f %{name}.lang
239 %defattr(644,root,root,755)
240 %doc AUTHORS ChangeLog README
241 %attr(755,root,root) %{_bindir}/ipod-read-sysinfo-extended
242 %attr(755,root,root) %{_libdir}/libgpod.so.*.*.*
243 %attr(755,root,root) %ghost %{_libdir}/libgpod.so.4
244 %dir %{_localstatedir}/run/%{name}
245 %{systemdtmpfilesdir}/%{name}.conf
246
247 %files -n udev-libgpod
248 %defattr(644,root,root,755)
249 %attr(755,root,root) /lib/udev/iphone-set-info
250 %attr(755,root,root) /lib/udev/ipod-set-info
251 /lib/udev/rules.d/90-libgpod.rules
252
253 %files devel
254 %defattr(644,root,root,755)
255 %attr(755,root,root) %{_libdir}/libgpod.so
256 %{_pkgconfigdir}/libgpod-1.0.pc
257 %{_includedir}/gpod-1.0
258
259 %files static
260 %defattr(644,root,root,755)
261 %{_libdir}/libgpod.a
262
263 %files apidocs
264 %defattr(644,root,root,755)
265 %{_gtkdocdir}/libgpod
266
267 %if %{with python}
268 %files -n python-gpod
269 %defattr(644,root,root,755)
270 %dir %{py_sitedir}/gpod
271 %{py_sitedir}/gpod/*.py[co]
272 %attr(755,root,root) %{py_sitedir}/gpod/_gpod.so
273 %endif
274
275 %if %{with dotnet}
276 %files -n dotnet-%{name}-sharp
277 %defattr(644,root,root,755)
278 %dir %{_prefix}/lib/libgpod
279 %{_prefix}/lib/libgpod/libgpod-sharp-test.exe
280 %{_prefix}/lib/libgpod/libgpod-sharp-test.exe.mdb
281 %{_prefix}/lib/libgpod/libgpod-sharp.dll
282 %{_prefix}/lib/libgpod/libgpod-sharp.dll.config
283 %{_prefix}/lib/libgpod/libgpod-sharp.dll.mdb
284
285 %files -n dotnet-%{name}-sharp-devel
286 %defattr(644,root,root,755)
287 %{_pkgconfigdir}/libgpod-sharp.pc
288 %endif
This page took 0.083357 seconds and 3 git commands to generate.