]> git.pld-linux.org Git - packages/libgpod.git/blob - libgpod.spec
- added libplist patch (adjust pkgconfig name for libplist 2.2.0+); release 7
[packages/libgpod.git] / libgpod.spec
1 # TODO
2 # check: http://fred.uwcs.co.uk/diff (from http://www.fredemmott.co.uk/blog_121)
3 # some warning at doc build:
4 #warning: failed to load external entity "../../docs/reference/xml/*.xml"
5 #unable to parse ../../docs/reference/xml/*.xml
6 #make[3]: [gpod_doc.i] Error 6 (ignored)
7 # - mountdir perms?: %dir %{_localstatedir}/run/%{name}
8 #
9 # Conditional build:
10 %bcond_without  dotnet  # .NET bindings
11 %bcond_without  python  # Python bindings
12
13 %ifarch x32
14 %undefine       with_dotnet
15 %endif
16
17 Summary:        Shared library to access the contents of an iPod
18 Summary(pl.UTF-8):      Biblioteka współdzielona do dostępu do zawartości iPodów
19 Name:           libgpod
20 Version:        0.8.3
21 Release:        7
22 License:        GPL v2
23 Group:          Libraries
24 Source0:        http://downloads.sourceforge.net/gtkpod/%{name}-%{version}.tar.bz2
25 # Source0-md5:  f8a0b7a34e768e33a708e8dd172bd6f8
26 Source1:        %{name}.tmpfiles
27 Patch0:         %{name}-gcc43.patch
28 Patch1:         %{name}-monodir.patch
29 Patch2:         mono4.patch
30 Patch3:         %{name}-swig.patch
31 Patch4:         %{name}-libplist.patch
32 URL:            http://www.gtkpod.org/libgpod/
33 BuildRequires:  autoconf >= 2.65
34 BuildRequires:  automake
35 BuildRequires:  docbook-dtd412-xml
36 BuildRequires:  gdk-pixbuf2-devel >= 2.6.0
37 BuildRequires:  gettext-tools
38 BuildRequires:  glib2-devel >= 1:2.16.0
39 BuildRequires:  gtk-doc >= 1.0
40 BuildRequires:  intltool >= 0.35
41 BuildRequires:  libimobiledevice-devel >= 1.1.5
42 BuildRequires:  libplist-devel >= 2.2.0
43 BuildRequires:  libsmbios-devel
44 BuildRequires:  libtool >= 2:2
45 BuildRequires:  libusb-devel >= 1.0
46 BuildRequires:  libxml2-devel >= 2.0
47 BuildRequires:  pkgconfig
48 BuildRequires:  rpmbuild(macros) >= 1.647
49 BuildRequires:  sg3_utils-devel >= 1.26
50 BuildRequires:  sqlite3-devel >= 3
51 BuildRequires:  zlib-devel
52 # for noinst test only
53 #BuildRequires: taglib-devel
54 %if %{with dotnet}
55 BuildRequires:  dotnet-gtk-sharp2-devel >= 2.12.0
56 BuildRequires:  mono-csharp >= 1.9.1
57 BuildRequires:  mono-devel >= 1.9.1
58 BuildRequires:  rpmbuild(monoautodeps)
59 %endif
60 %if %{with python}
61 BuildRequires:  python-devel >= 2.1.1
62 BuildRequires:  python-mutagen >= 1.8
63 BuildRequires:  python-pygobject-devel >= 2.8.0
64 BuildRequires:  rpm-pythonprov
65 BuildRequires:  swig-python >= 1.3.24
66 %endif
67 Requires:       glib2 >= 1:2.16.0
68 Requires:       libimobiledevice >= 1.1.5
69 Requires:       libplist >= 2.2.0
70 Suggests:       udev-libgpod = %{version}-%{release}
71 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
72
73 %description
74 libgpod is a library meant to abstract access to an iPod content. It
75 provides an easy to use API to retrieve the list of files and playlist
76 stored on an iPod, to modify them and to save them back to the iPod.
77
78 %description -l pl.UTF-8
79 libgpod to biblioteka mająca na celu wyabstrahowanie dostępu do
80 zawartości iPodów. Udostępnia łatwe w użyciu API do pobierania listy
81 plików i playlist zapisanych na iPodzie, modyfikowania ich i
82 zapisywania z powrotem na iPoda.
83
84 %package -n udev-libgpod
85 Summary:        UDEV rules and programs for iPod devices
86 Summary(pl.UTF-8):      Reguły i programy używane przez UDEV dla urządzeń iPod
87 Group:          Applications/System
88 Requires:       %{name} = %{version}-%{release}
89 Obsoletes:      hal-libgpod
90
91 %description -n udev-libgpod
92 UDEV rules and programs to initialize iPod devices for libgpod
93 library.
94
95 %description -n udev-libgpod -l pl.UTF-8
96 Reguły i program dla UDEV do przygotowywania urządzeń iPod do użytku z
97 biblioteką libgpod.
98
99 %package devel
100 Summary:        Header files for libgpod library
101 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libgpod
102 Group:          Development/Libraries
103 Requires:       %{name} = %{version}-%{release}
104 Requires:       gdk-pixbuf2-devel >= 2.6.0
105 Requires:       glib2-devel >= 1:2.16.0
106
107 %description devel
108 This is the package containing the header files for libgpod library.
109
110 %description devel -l pl.UTF-8
111 Ten pakiet zawiera pliki nagłówkowe biblioteki libgpod.
112
113 %package static
114 Summary:        Static libgpod library
115 Summary(pl.UTF-8):      Statyczna biblioteka libgpod
116 Group:          Development/Libraries
117 Requires:       %{name}-devel = %{version}-%{release}
118
119 %description static
120 Static libgpod library.
121
122 %description static -l pl.UTF-8
123 Statyczna biblioteka libgpod.
124
125 %package apidocs
126 Summary:        libgpod API documentation
127 Summary(pl.UTF-8):      Dokumentacja API biblioteki libgpod
128 Group:          Documentation
129 Requires:       gtk-doc-common
130 %if "%{_rpmversion}" >= "4.6"
131 BuildArch:      noarch
132 %endif
133
134 %description apidocs
135 libgpod API documentation.
136
137 %description apidocs -l pl.UTF-8
138 Dokumentacja API biblioteki libgpod.
139
140 %package -n python-gpod
141 Summary:        Module for libgpod access from Python
142 Summary(pl.UTF-8):      Moduł Pythona umożliwiający korzystanie z biblioteki libgpod
143 Group:          Development/Languages/Python
144 Requires:       %{name} = %{version}-%{release}
145 Requires:       python-libs
146 Requires:       python-mutagen >= 1.8
147 Requires:       python-pygobject >= 2.8.0
148
149 %description -n python-gpod
150 This is the libgpod Python support package.
151
152 %description -n python-gpod -l pl.UTF-8
153 Moduł umożliwiający korzystanie z biblioteki libgpod z poziomu
154 Pythona.
155
156 %package -n dotnet-%{name}-sharp
157 Summary:        C#/.NET library to access iPod content
158 Summary(pl.UTF-8):      Biblioteka C#/.NET pozwalajaca na dostęp do iPoda
159 Group:          Development/Languages
160 Requires:       %{name} = %{version}-%{release}
161
162 %description -n dotnet-%{name}-sharp
163 C#/.NET library to access iPod content. Provides bindings to the
164 libgpod library.
165
166 %description -n dotnet-%{name}-sharp -l pl.UTF-8
167 Biblioteka C#/.NET pozwalająca na dostęp do iPoda. Udostępnia wiązania
168 do biblioteki libgpod.
169
170 %package -n dotnet-%{name}-sharp-devel
171 Summary:        Development files for libgpod-sharp
172 Summary(pl.UTF-8):      Development files for libgpod-sharp
173 Group:          Development/Languages
174 Requires:       dotnet-%{name}-sharp = %{version}-%{release}
175 Requires:       pkgconfig
176
177 %description -n dotnet-%{name}-sharp-devel
178 C#/.NET library to access iPod content. Provides bindings to the
179 libgpod library.
180
181 This package contains the files required to develop programs that will
182 use dotnet-libgpod-sharp.
183
184 %description -n dotnet-%{name}-sharp-devel -l pl.UTF-8
185 Pliki programistyczne biblioteki C#/.NET libgpod-sharp.
186
187 %prep
188 %setup -q
189 %patch0 -p1
190 %patch1 -p1
191 %patch2 -p1
192 %patch3 -p1
193 %patch4 -p1
194
195 %build
196 %{__gtkdocize}
197 %{__glib_gettextize}
198 %{__intltoolize}
199 %{__libtoolize}
200 %{__aclocal} -I m4
201 %{__autoconf}
202 %{__autoheader}
203 %{__automake}
204 %configure \
205         --disable-silent-rules \
206         --enable-gtk-doc \
207         --enable-mono%{!?with_dotnet:=no} \
208         --enable-udev \
209         --with-html-dir=%{_gtkdocdir} \
210         --with-python%{!?with_python:=no} \
211         --with-temp-mount-dir=%{_localstatedir}/run/%{name} \
212         --without-hal
213
214 %{__make}
215
216 %install
217 rm -rf $RPM_BUILD_ROOT
218 install -d $RPM_BUILD_ROOT%{systemdtmpfilesdir}
219
220 %{__make} install \
221         DESTDIR=$RPM_BUILD_ROOT
222
223 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpod.la
224
225 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
226
227 %if %{with python}
228 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/gpod/*.la
229 %py_postclean
230 %endif
231
232 %find_lang %{name} --all-name
233
234 %clean
235 rm -rf $RPM_BUILD_ROOT
236
237 %post   -p /sbin/ldconfig
238 %postun -p /sbin/ldconfig
239
240 %files -f %{name}.lang
241 %defattr(644,root,root,755)
242 %doc AUTHORS ChangeLog README
243 %attr(755,root,root) %{_bindir}/ipod-read-sysinfo-extended
244 %attr(755,root,root) %{_libdir}/libgpod.so.*.*.*
245 %attr(755,root,root) %ghost %{_libdir}/libgpod.so.4
246 %dir %{_localstatedir}/run/%{name}
247 %{systemdtmpfilesdir}/%{name}.conf
248
249 %files -n udev-libgpod
250 %defattr(644,root,root,755)
251 %attr(755,root,root) /lib/udev/iphone-set-info
252 %attr(755,root,root) /lib/udev/ipod-set-info
253 /lib/udev/rules.d/90-libgpod.rules
254
255 %files devel
256 %defattr(644,root,root,755)
257 %attr(755,root,root) %{_libdir}/libgpod.so
258 %{_pkgconfigdir}/libgpod-1.0.pc
259 %{_includedir}/gpod-1.0
260
261 %files static
262 %defattr(644,root,root,755)
263 %{_libdir}/libgpod.a
264
265 %files apidocs
266 %defattr(644,root,root,755)
267 %{_gtkdocdir}/libgpod
268
269 %if %{with python}
270 %files -n python-gpod
271 %defattr(644,root,root,755)
272 %dir %{py_sitedir}/gpod
273 %{py_sitedir}/gpod/*.py[co]
274 %attr(755,root,root) %{py_sitedir}/gpod/_gpod.so
275 %endif
276
277 %if %{with dotnet}
278 %files -n dotnet-%{name}-sharp
279 %defattr(644,root,root,755)
280 %dir %{_prefix}/lib/libgpod
281 %{_prefix}/lib/libgpod/libgpod-sharp-test.exe
282 %{_prefix}/lib/libgpod/libgpod-sharp-test.exe.mdb
283 %{_prefix}/lib/libgpod/libgpod-sharp.dll
284 %{_prefix}/lib/libgpod/libgpod-sharp.dll.config
285 %{_prefix}/lib/libgpod/libgpod-sharp.dll.mdb
286
287 %files -n dotnet-%{name}-sharp-devel
288 %defattr(644,root,root,755)
289 %{_pkgconfigdir}/libgpod-sharp.pc
290 %endif
This page took 0.071593 seconds and 3 git commands to generate.