]> git.pld-linux.org Git - packages/libgpod.git/blob - libgpod.spec
1b8c50a6dd2490f9ae112876a2fa6461a00cb588
[packages/libgpod.git] / libgpod.spec
1 # TODO
2 # check: http://fred.uwcs.co.uk/diff (from http://www.fredemmott.co.uk/blog_121)
3 # some warning at doc build:
4 #warning: failed to load external entity "../../docs/reference/xml/*.xml"
5 #unable to parse ../../docs/reference/xml/*.xml
6 #make[3]: [gpod_doc.i] Error 6 (ignored)
7 # - mountdir perms?: %dir %{_localstatedir}/run/%{name}
8 #
9 # Conditional build:
10 %bcond_without  dotnet  # .NET bindings
11 %bcond_without  python  # Python bindings
12
13 %ifarch x32
14 %undefine       with_dotnet
15 %endif
16
17 Summary:        Shared library to access the contents of an iPod
18 Summary(pl.UTF-8):      Biblioteka współdzielona do dostępu do zawartości iPodów
19 Name:           libgpod
20 Version:        0.8.3
21 Release:        8
22 License:        GPL v2
23 Group:          Libraries
24 Source0:        http://downloads.sourceforge.net/gtkpod/%{name}-%{version}.tar.bz2
25 # Source0-md5:  f8a0b7a34e768e33a708e8dd172bd6f8
26 Source1:        %{name}.tmpfiles
27 Patch0:         %{name}-gcc43.patch
28 Patch1:         %{name}-monodir.patch
29 Patch2:         mono4.patch
30 Patch3:         %{name}-swig.patch
31 Patch4:         %{name}-libplist.patch
32 URL:            http://www.gtkpod.org/libgpod/
33 BuildRequires:  autoconf >= 2.65
34 BuildRequires:  automake
35 BuildRequires:  docbook-dtd412-xml
36 BuildRequires:  gdk-pixbuf2-devel >= 2.6.0
37 BuildRequires:  gettext-tools
38 BuildRequires:  glib2-devel >= 1:2.16.0
39 BuildRequires:  gtk-doc >= 1.0
40 BuildRequires:  intltool >= 0.35
41 BuildRequires:  libimobiledevice-devel >= 1.1.5
42 BuildRequires:  libplist-devel >= 2.2.0
43 BuildRequires:  libsmbios-devel
44 BuildRequires:  libtool >= 2:2
45 BuildRequires:  libusb-devel >= 1.0
46 BuildRequires:  libxml2-devel >= 2.0
47 BuildRequires:  pkgconfig
48 BuildRequires:  rpmbuild(macros) >= 1.647
49 BuildRequires:  sg3_utils-devel >= 1.26
50 BuildRequires:  sqlite3-devel >= 3
51 BuildRequires:  zlib-devel
52 # for noinst test only
53 #BuildRequires: taglib-devel
54 %if %{with dotnet}
55 BuildRequires:  dotnet-gtk-sharp2-devel >= 2.12.0
56 BuildRequires:  mono-csharp >= 1.9.1
57 BuildRequires:  mono-devel >= 1.9.1
58 %endif
59 %if %{with python}
60 BuildRequires:  python-devel >= 2.1.1
61 BuildRequires:  python-mutagen >= 1.8
62 BuildRequires:  python-pygobject-devel >= 2.8.0
63 BuildRequires:  rpm-pythonprov
64 BuildRequires:  swig-python >= 1.3.24
65 %endif
66 Requires:       glib2 >= 1:2.16.0
67 Requires:       libimobiledevice >= 1.1.5
68 Requires:       libplist >= 2.2.0
69 Suggests:       udev-libgpod = %{version}-%{release}
70 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
71
72 %description
73 libgpod is a library meant to abstract access to an iPod content. It
74 provides an easy to use API to retrieve the list of files and playlist
75 stored on an iPod, to modify them and to save them back to the iPod.
76
77 %description -l pl.UTF-8
78 libgpod to biblioteka mająca na celu wyabstrahowanie dostępu do
79 zawartości iPodów. Udostępnia łatwe w użyciu API do pobierania listy
80 plików i playlist zapisanych na iPodzie, modyfikowania ich i
81 zapisywania z powrotem na iPoda.
82
83 %package -n udev-libgpod
84 Summary:        UDEV rules and programs for iPod devices
85 Summary(pl.UTF-8):      Reguły i programy używane przez UDEV dla urządzeń iPod
86 Group:          Applications/System
87 Requires:       %{name} = %{version}-%{release}
88 Obsoletes:      hal-libgpod
89
90 %description -n udev-libgpod
91 UDEV rules and programs to initialize iPod devices for libgpod
92 library.
93
94 %description -n udev-libgpod -l pl.UTF-8
95 Reguły i program dla UDEV do przygotowywania urządzeń iPod do użytku z
96 biblioteką libgpod.
97
98 %package devel
99 Summary:        Header files for libgpod library
100 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libgpod
101 Group:          Development/Libraries
102 Requires:       %{name} = %{version}-%{release}
103 Requires:       gdk-pixbuf2-devel >= 2.6.0
104 Requires:       glib2-devel >= 1:2.16.0
105
106 %description devel
107 This is the package containing the header files for libgpod library.
108
109 %description devel -l pl.UTF-8
110 Ten pakiet zawiera pliki nagłówkowe biblioteki libgpod.
111
112 %package static
113 Summary:        Static libgpod library
114 Summary(pl.UTF-8):      Statyczna biblioteka libgpod
115 Group:          Development/Libraries
116 Requires:       %{name}-devel = %{version}-%{release}
117
118 %description static
119 Static libgpod library.
120
121 %description static -l pl.UTF-8
122 Statyczna biblioteka libgpod.
123
124 %package apidocs
125 Summary:        libgpod API documentation
126 Summary(pl.UTF-8):      Dokumentacja API biblioteki libgpod
127 Group:          Documentation
128 Requires:       gtk-doc-common
129 BuildArch:      noarch
130
131 %description apidocs
132 libgpod API documentation.
133
134 %description apidocs -l pl.UTF-8
135 Dokumentacja API biblioteki libgpod.
136
137 %package -n python-gpod
138 Summary:        Module for libgpod access from Python
139 Summary(pl.UTF-8):      Moduł Pythona umożliwiający korzystanie z biblioteki libgpod
140 Group:          Development/Languages/Python
141 Requires:       %{name} = %{version}-%{release}
142 Requires:       python-libs
143 Requires:       python-mutagen >= 1.8
144 Requires:       python-pygobject >= 2.8.0
145
146 %description -n python-gpod
147 This is the libgpod Python support package.
148
149 %description -n python-gpod -l pl.UTF-8
150 Moduł umożliwiający korzystanie z biblioteki libgpod z poziomu
151 Pythona.
152
153 %package -n dotnet-%{name}-sharp
154 Summary:        C#/.NET library to access iPod content
155 Summary(pl.UTF-8):      Biblioteka C#/.NET pozwalajaca na dostęp do iPoda
156 Group:          Development/Languages
157 Requires:       %{name} = %{version}-%{release}
158
159 %description -n dotnet-%{name}-sharp
160 C#/.NET library to access iPod content. Provides bindings to the
161 libgpod library.
162
163 %description -n dotnet-%{name}-sharp -l pl.UTF-8
164 Biblioteka C#/.NET pozwalająca na dostęp do iPoda. Udostępnia wiązania
165 do biblioteki libgpod.
166
167 %package -n dotnet-%{name}-sharp-devel
168 Summary:        Development files for libgpod-sharp
169 Summary(pl.UTF-8):      Development files for libgpod-sharp
170 Group:          Development/Languages
171 Requires:       dotnet-%{name}-sharp = %{version}-%{release}
172 Requires:       pkgconfig
173
174 %description -n dotnet-%{name}-sharp-devel
175 C#/.NET library to access iPod content. Provides bindings to the
176 libgpod library.
177
178 This package contains the files required to develop programs that will
179 use dotnet-libgpod-sharp.
180
181 %description -n dotnet-%{name}-sharp-devel -l pl.UTF-8
182 Pliki programistyczne biblioteki C#/.NET libgpod-sharp.
183
184 %prep
185 %setup -q
186 %patch0 -p1
187 %patch1 -p1
188 %patch2 -p1
189 %patch3 -p1
190 %patch4 -p1
191
192 %build
193 %{__gtkdocize}
194 %{__glib_gettextize}
195 %{__intltoolize}
196 %{__libtoolize}
197 %{__aclocal} -I m4
198 %{__autoconf}
199 %{__autoheader}
200 %{__automake}
201 %configure \
202         --disable-silent-rules \
203         --enable-gtk-doc \
204         --enable-mono%{!?with_dotnet:=no} \
205         --enable-udev \
206         --with-html-dir=%{_gtkdocdir} \
207         --with-python%{!?with_python:=no} \
208         --with-temp-mount-dir=%{_localstatedir}/run/%{name} \
209         --without-hal
210
211 %{__make}
212
213 %install
214 rm -rf $RPM_BUILD_ROOT
215 install -d $RPM_BUILD_ROOT%{systemdtmpfilesdir}
216
217 %{__make} install \
218         DESTDIR=$RPM_BUILD_ROOT
219
220 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpod.la
221
222 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
223
224 %if %{with python}
225 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/gpod/*.la
226 %py_postclean
227 %endif
228
229 %find_lang %{name} --all-name
230
231 %clean
232 rm -rf $RPM_BUILD_ROOT
233
234 %post   -p /sbin/ldconfig
235 %postun -p /sbin/ldconfig
236
237 %files -f %{name}.lang
238 %defattr(644,root,root,755)
239 %doc AUTHORS ChangeLog README
240 %attr(755,root,root) %{_bindir}/ipod-read-sysinfo-extended
241 %attr(755,root,root) %{_libdir}/libgpod.so.*.*.*
242 %attr(755,root,root) %ghost %{_libdir}/libgpod.so.4
243 %dir %{_localstatedir}/run/%{name}
244 %{systemdtmpfilesdir}/%{name}.conf
245
246 %files -n udev-libgpod
247 %defattr(644,root,root,755)
248 %attr(755,root,root) /lib/udev/iphone-set-info
249 %attr(755,root,root) /lib/udev/ipod-set-info
250 /lib/udev/rules.d/90-libgpod.rules
251
252 %files devel
253 %defattr(644,root,root,755)
254 %attr(755,root,root) %{_libdir}/libgpod.so
255 %{_pkgconfigdir}/libgpod-1.0.pc
256 %{_includedir}/gpod-1.0
257
258 %files static
259 %defattr(644,root,root,755)
260 %{_libdir}/libgpod.a
261
262 %files apidocs
263 %defattr(644,root,root,755)
264 %{_gtkdocdir}/libgpod
265
266 %if %{with python}
267 %files -n python-gpod
268 %defattr(644,root,root,755)
269 %dir %{py_sitedir}/gpod
270 %{py_sitedir}/gpod/*.py[co]
271 %attr(755,root,root) %{py_sitedir}/gpod/_gpod.so
272 %endif
273
274 %if %{with dotnet}
275 %files -n dotnet-%{name}-sharp
276 %defattr(644,root,root,755)
277 %dir %{_prefix}/lib/libgpod
278 %{_prefix}/lib/libgpod/libgpod-sharp-test.exe
279 %{_prefix}/lib/libgpod/libgpod-sharp-test.exe.mdb
280 %{_prefix}/lib/libgpod/libgpod-sharp.dll
281 %{_prefix}/lib/libgpod/libgpod-sharp.dll.config
282 %{_prefix}/lib/libgpod/libgpod-sharp.dll.mdb
283
284 %files -n dotnet-%{name}-sharp-devel
285 %defattr(644,root,root,755)
286 %{_pkgconfigdir}/libgpod-sharp.pc
287 %endif
This page took 0.079469 seconds and 2 git commands to generate.