]> git.pld-linux.org Git - packages/libgpg-error.git/blob - libgpg-error.spec
98d06f0041481e42e27460a1571cd335d9d7da10
[packages/libgpg-error.git] / libgpg-error.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 Summary:        Library libgpg-error
6 Summary(pl.UTF-8):      Biblioteka libgpg-error
7 Name:           libgpg-error
8 Version:        1.25
9 Release:        1
10 License:        LGPL v2.1+
11 Group:          Libraries
12 Source0:        ftp://ftp.gnupg.org/gcrypt/libgpg-error/%{name}-%{version}.tar.bz2
13 # Source0-md5:  d9fa545922a5060cbfbd87464bc31686
14 Patch0:         %{name}-pl.po-update.patch
15 Patch1:         %{name}-info.patch
16 URL:            http://www.gnupg.org/related_software/libgpg-error/
17 BuildRequires:  autoconf >= 2.59
18 BuildRequires:  automake >= 1:1.14
19 BuildRequires:  gettext-tools >= 0.19.3
20 BuildRequires:  libtool >= 2:2.2.6
21 BuildRequires:  texinfo
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 libgpg-error is a library that defines common error values for all
26 GnuPG components. Among these are GPG, GPGSM, GPGME, GPG-Agent,
27 libgcrypt, pinentry, SmartCard Daemon and possibly more in the future.
28
29 %description -l pl.UTF-8
30 libgpg-error jest biblioteką definiującą wartości błędów wspólne dla
31 komponentów GnuPG. Są wśród nich GPG, GPGSM, GPGME, GPG-Agent,
32 libgcrypt, pinentry, SmartCard Daemon i inne - w przyszłości.
33
34 %package devel
35 Summary:        Header files for libgpg-error
36 Summary(pl.UTF-8):      Pliki nagłówkowe dla libgpg-error
37 Group:          Development/Libraries
38 Requires:       %{name} = %{version}-%{release}
39
40 %description devel
41 libgpg-error is a library that defines common error values for all
42 GnuPG components. Among these are GPG, GPGSM, GPGME, GPG-Agent,
43 libgcrypt, pinentry, SmartCard Daemon and possibly more in the future.
44
45 This package contains the header files needed to develop programs that
46 use these libgpg-error.
47
48 %description devel -l pl.UTF-8
49 libgpg-error jest biblioteką definiującą wartości błędów wspólne dla
50 komponentów GnuPG. Są wśród nich GPG, GPGSM, GPGME, GPG-Agent,
51 libgcrypt, pinentry, SmartCard Daemon i inne - w przyszłości.
52
53 Pakiet zawiera pliki nagłówkowe niezbędne do kompilowania programów
54 używających biblioteki libgpg-error.
55
56 %package static
57 Summary:        Static version of libgpg-error library
58 Summary(pl.UTF-8):      Statyczna wersja biblioteki libgpg-error
59 Group:          Development/Libraries
60 Requires:       %{name}-devel = %{version}-%{release}
61
62 %description static
63 libgpg-error is a library that defines common error values for all
64 GnuPG components. Among these are GPG, GPGSM, GPGME, GPG-Agent,
65 libgcrypt, pinentry, SmartCard Daemon and possibly more in the future.
66
67 This package contains the static libgpg-error libraries.
68
69 %description static -l pl.UTF-8
70 libgpg-error jest biblioteką definiującą wartości błędów wspólne dla
71 komponentów GnuPG. Są wśród nich GPG, GPGSM, GPGME, GPG-Agent,
72 libgcrypt, pinentry, SmartCard Daemon i inne - w przyszłości.
73
74 Pakiet zawiera statyczne biblioteki libgpg-error.
75
76 %package -n common-lisp-gpg-error
77 Summary:        Common Lisp binding for libgpg-error library
78 Summary(pl.UTF-8):      Wiązania Common Lispa do biblioteki libgpg-error
79 Group:          Libraries
80 Requires:       %{name} = %{version}-%{release}
81 Requires:       common-lisp-controller
82
83 %description -n common-lisp-gpg-error
84 Common Lisp binding for libgpg-error library.
85
86 %description -n common-lisp-gpg-error -l pl.UTF-8
87 Wiązania Common Lispa do biblioteki libgpg-error.
88
89 %prep
90 %setup -q
91 %patch0 -p1
92 %patch1 -p1
93
94 %{__rm} po/stamp-po
95
96 %build
97 %{__gettextize}
98 %{__libtoolize}
99 %{__aclocal} -I m4
100 %{__autoconf}
101 %{__automake}
102 %configure \
103         %{?with_static_libs:--enable-static}
104 %{__make}
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108
109 %{__make} install \
110         DESTDIR=$RPM_BUILD_ROOT
111
112 install -d $RPM_BUILD_ROOT/%{_lib}
113 mv -f $RPM_BUILD_ROOT%{_libdir}/libgpg-error.so.* $RPM_BUILD_ROOT/%{_lib}
114 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libgpg-error.so.*.*.*) \
115         $RPM_BUILD_ROOT%{_libdir}/libgpg-error.so
116
117 %find_lang %{name}
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %post   -p /sbin/ldconfig
123 %postun -p /sbin/ldconfig
124
125 %files -f %{name}.lang
126 %defattr(644,root,root,755)
127 %doc AUTHORS ChangeLog NEWS README THANKS
128 %attr(755,root,root) %{_bindir}/gpg-error
129 %attr(755,root,root) /%{_lib}/libgpg-error.so.*.*.*
130 %attr(755,root,root) %ghost /%{_lib}/libgpg-error.so.0
131
132 %files devel
133 %defattr(644,root,root,755)
134 %attr(755,root,root) %{_bindir}/gpg-error-config
135 %attr(755,root,root) %{_libdir}/libgpg-error.so
136 %{_libdir}/libgpg-error.la
137 %{_includedir}/gpg-error.h
138 %{_aclocaldir}/gpg-error.m4
139 %{_mandir}/man1/gpg-error-config.1*
140 %{_infodir}/gpgrt.info*
141
142 %if %{with static_libs}
143 %files static
144 %defattr(644,root,root,755)
145 %{_libdir}/libgpg-error.a
146 %endif
147
148 %files -n common-lisp-gpg-error
149 %defattr(644,root,root,755)
150 %{_datadir}/common-lisp/source/gpg-error
This page took 0.061195 seconds and 2 git commands to generate.