]> git.pld-linux.org Git - packages/libgovirt.git/blob - libgovirt.spec
- updated to 0.2.0 (note: new soname)
[packages/libgovirt.git] / libgovirt.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 #
5 Summary:        goVirt library - GLib binding for oVirt REST API
6 Summary(pl.UTF-8):      Biblioteka goVirt - wiązanie GLib do API REST-owego oVirt
7 Name:           libgovirt
8 Version:        0.2.0
9 Release:        1
10 License:        LGPL v2.1+
11 Group:          Libraries
12 Source0:        http://people.freedesktop.org/~teuf/govirt/%{name}-%{version}.tar.xz
13 # Source0-md5:  107e814e0196147f6f8573acc6a0a559
14 URL:            http://cgit.freedesktop.org/~teuf/govirt/
15 BuildRequires:  glib2-devel >= 1:2.26.0
16 BuildRequires:  gobject-introspection-devel >= 1.30.0
17 BuildRequires:  rest-devel >= 0.7.13
18 Requires:       glib2 >= 1:2.26.0
19 Requires:       rest >= 0.7.13
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 GoVirt is a GObject wrapper for the oVirt REST API. It will only
24 provide very basic functionality as the goal is to autogenerate a full
25 wrapper as it is already done for the Python bindings.
26
27 %description -l pl.UTF-8
28 GoVirt to interfejs GObject dla API REST-owego oVirt. Zapewnia
29 jedynie podstawową funkcjonalność, jako że celem jest automatyczne
30 generowanie pełnego interfejsu - tak, jak jest to robione w wiązaniach
31 Pythona.
32
33 %package devel
34 Summary:        Header files for goVirt library
35 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki goVirt
36 Group:          Development/Libraries
37 Requires:       %{name} = %{version}-%{release}
38 Requires:       glib2-devel >= 1:2.26.0
39 Requires:       rest-devel >= 0.7.13
40
41 %description devel
42 Header files for goVirt library.
43
44 %description devel -l pl.UTF-8
45 Pliki nagłówkowe biblioteki goVirt.
46
47 %package static
48 Summary:        Static goVirt library
49 Summary(pl.UTF-8):      Statyczna biblioteka goVirt
50 Group:          Development/Libraries
51 Requires:       %{name}-devel = %{version}-%{release}
52
53 %description static
54 Static goVirt library.
55
56 %description static -l pl.UTF-8
57 Statyczna biblioteka goVirt.
58
59 %prep
60 %setup -q
61
62 %build
63 %configure \
64         --disable-silent-rules \
65         %{!?with_static_libs:--disable-static}
66 %{__make}
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70
71 %{__make} install \
72         DESTDIR=$RPM_BUILD_ROOT
73
74 # obsoleted by pkg-config
75 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %post   -p /sbin/ldconfig
81 %postun -p /sbin/ldconfig
82
83 %files
84 %defattr(644,root,root,755)
85 %doc AUTHORS MAINTAINERS NEWS README
86 %attr(755,root,root) %{_libdir}/libgovirt.so.*.*.*
87 %attr(755,root,root) %ghost %{_libdir}/libgovirt.so.2
88 %{_libdir}/girepository-1.0/GoVirt-1.0.typelib
89
90 %files devel
91 %defattr(644,root,root,755)
92 %attr(755,root,root) %{_libdir}/libgovirt.so
93 %{_includedir}/govirt-1.0
94 %{_datadir}/gir-1.0/GoVirt-1.0.gir
95 %{_pkgconfigdir}/govirt-1.0.pc
96
97 %if %{with static_libs}
98 %files static
99 %defattr(644,root,root,755)
100 %{_libdir}/libgovirt.a
101 %endif
This page took 0.104636 seconds and 3 git commands to generate.