]> git.pld-linux.org Git - packages/libgoffice.git/blob - libgoffice.spec
- updated to 0.10.47
[packages/libgoffice.git] / libgoffice.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 #
5 %define         orgname goffice
6 %define         api_version     0.10
7 Summary:        Glib/Gtk+ set of document centric objects and utilities
8 Summary(pl.UTF-8):      Zestaw zorientowanych dokumentowo obiektów i narzędzi Glib/Gtk+
9 Name:           libgoffice
10 Version:        0.10.47
11 Release:        1
12 License:        GPL v2+
13 Group:          Libraries
14 Source0:        http://ftp.gnome.org/pub/GNOME/sources/goffice/0.10/%{orgname}-%{version}.tar.xz
15 # Source0-md5:  01d54519e7357d6f756f32c31754dfa4
16 URL:            https://developer.gnome.org/goffice/
17 BuildRequires:  autoconf >= 2.54
18 BuildRequires:  automake >= 1:1.7.2
19 BuildRequires:  cairo-devel >= 1.10.0
20 BuildRequires:  gdk-pixbuf2-devel >= 2.22.0
21 BuildRequires:  gettext-tools
22 BuildRequires:  ghostscript-devel >= 9.06
23 BuildRequires:  glib2-devel >= 1:2.40.0
24 BuildRequires:  gobject-introspection-devel >= 1.0.0
25 BuildRequires:  gtk+3-devel >= 3.8.7
26 BuildRequires:  gtk-doc >= 1.12
27 BuildRequires:  intltool >= 0.35.0
28 BuildRequires:  lasem-devel >= 0.4.1
29 BuildRequires:  libgsf-devel >= 1.14.24
30 BuildRequires:  librsvg-devel >= 2.22.0
31 BuildRequires:  libspectre-devel >= 0.2.6
32 BuildRequires:  libtool >= 2:2.2.6
33 BuildRequires:  libxml2-devel >= 1:2.6.26
34 BuildRequires:  libxslt-devel
35 BuildRequires:  pango-devel >= 1:1.24.0
36 BuildRequires:  pkgconfig
37 BuildRequires:  pkgconfig(cairo-pdf) >= 1.10.0
38 BuildRequires:  pkgconfig(cairo-ps) >= 1.10.0
39 BuildRequires:  pkgconfig(cairo-svg) >= 1.10.0
40 BuildRequires:  xorg-lib-libXext-devel
41 BuildRequires:  xorg-lib-libXrender-devel
42 Requires:       cairo >= 1.10.0
43 Requires:       gdk-pixbuf2 >= 2.22.0
44 Requires:       glib2 >= 1:2.40.0
45 Requires:       gtk+3 >= 3.8.7
46 Requires:       lasem >= 0.4.1
47 Requires:       libgsf >= 1.14.24
48 Requires:       librsvg >= 2.22.0
49 Requires:       libspectre >= 0.2.6
50 Requires:       libxml2 >= 1:2.6.26
51 Requires:       pango >= 1:1.24.0
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %description
55 GOffice - a Glib/Gtk+ set of document centric objects and utilities.
56
57 %description -l pl.UTF-8
58 GOffice - Zestaw zorientowanych dokumentowo obiektów i narzędzi
59 Glib/Gtk+.
60
61 %package devel
62 Summary:        Header files for GOffice library
63 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GOffice
64 Group:          Development/Libraries
65 Requires:       %{name} = %{version}-%{release}
66 Requires:       cairo-devel >= 1.10.0
67 Requires:       glib2-devel >= 1:2.40.0
68 Requires:       gtk+3-devel >= 3.8.7
69 Requires:       lasem-devel >= 0.4.1
70 Requires:       libgsf-devel >= 1.14.24
71 Requires:       libspectre-devel >= 0.2.6
72 Requires:       libxml2-devel >= 1:2.6.26
73 Requires:       libxslt-devel
74 Requires:       pango-devel >= 1:1.24.0
75
76 %description devel
77 This is the package containing the header files for GOffice.
78
79 %description devel -l pl.UTF-8
80 Ten pakiet zawiera pliki nagłówkowe GOffice.
81
82 %package static
83 Summary:        Static GOffice library
84 Summary(pl.UTF-8):      Statyczna biblioteka GOffice
85 Group:          Development/Libraries
86 Requires:       %{name}-devel = %{version}-%{release}
87
88 %description static
89 Static GOffice library.
90
91 %description static -l pl.UTF-8
92 Statyczna biblioteka GOffice.
93
94 %package apidocs
95 Summary:        GOffice library API documentation
96 Summary(pl.UTF-8):      Dokumentacja API biblioteki GOffice
97 Group:          Documentation
98 Requires:       gtk-doc-common
99 %if "%{_rpmversion}" >= "4.6"
100 BuildArch:      noarch
101 %endif
102
103 %description apidocs
104 GOffice library API documentation.
105
106 %description apidocs -l pl.UTF-8
107 Dokumentacja API biblioteki GOffice.
108
109 %prep
110 %setup -qn %{orgname}-%{version}
111
112 %build
113 %{__gtkdocize}
114 %{__intltoolize}
115 %{__libtoolize}
116 %{__aclocal}
117 %{__autoconf}
118 %{__autoheader}
119 %{__automake}
120 %configure \
121         --enable-introspection \
122         --disable-silent-rules \
123         %{?with_static_libs:--enable-static} \
124         --with-html-dir=%{_gtkdocdir}
125 %{__make}
126
127 %install
128 rm -rf $RPM_BUILD_ROOT
129 install -d $RPM_BUILD_ROOT%{_libdir}/goffice/%{api_version}/plugins
130
131 %{__make} install \
132         DESTDIR=$RPM_BUILD_ROOT
133
134 %{__rm} $RPM_BUILD_ROOT%{_libdir}/goffice/%{version}/plugins/*/*.la \
135         $RPM_BUILD_ROOT%{_libdir}/*.la
136 %if %{with static_libs}
137 %{__rm} $RPM_BUILD_ROOT%{_libdir}/goffice/%{version}/plugins/*/*.a
138 %endif
139
140 %find_lang %{orgname}-%{version}
141
142 %clean
143 rm -rf $RPM_BUILD_ROOT
144
145 %post   -p /sbin/ldconfig
146 %postun -p /sbin/ldconfig
147
148 %files -f %{orgname}-%{version}.lang
149 %defattr(644,root,root,755)
150 %doc AUTHORS BUGS ChangeLog MAINTAINERS NEWS README
151 %attr(755,root,root) %{_libdir}/libgoffice-%{api_version}.so.*.*.*
152 %attr(755,root,root) %ghost %{_libdir}/libgoffice-%{api_version}.so.10
153 %{_libdir}/girepository-1.0/GOffice-%{api_version}.typelib
154 %dir %{_libdir}/goffice
155 %dir %{_libdir}/goffice/%{api_version}
156 %dir %{_libdir}/goffice/%{api_version}/plugins
157 %dir %{_libdir}/goffice/%{version}
158 %dir %{_libdir}/goffice/%{version}/plugins
159 %dir %{_libdir}/goffice/%{version}/plugins/*
160 %attr(755,root,root) %{_libdir}/goffice/%{version}/plugins/*/*.so
161 %{_libdir}/goffice/%{version}/plugins/*/*.xml
162 %{_datadir}/goffice
163
164 %files devel
165 %defattr(644,root,root,755)
166 %attr(755,root,root) %{_libdir}/libgoffice-%{api_version}.so
167 %{_includedir}/libgoffice-%{api_version}
168 %{_pkgconfigdir}/libgoffice-%{api_version}.pc
169 %{_datadir}/gir-1.0/GOffice-%{api_version}.gir
170
171 %if %{with static_libs}
172 %files static
173 %defattr(644,root,root,755)
174 %{_libdir}/libgoffice-%{api_version}.a
175 %endif
176
177 %files apidocs
178 %defattr(644,root,root,755)
179 %{_gtkdocdir}/goffice-%{api_version}
This page took 0.07329 seconds and 3 git commands to generate.