]> git.pld-linux.org Git - packages/libgoffice.git/blob - libgoffice.spec
68d9980dc07eeb2e25e8a737b929045f17ff45a5
[packages/libgoffice.git] / libgoffice.spec
1 #
2 # Conditional build:
3 %bcond_without  gnome   # disable all GNOME components
4 #
5 %define         orgname goffice
6 #
7 Summary:        Glib/Gtk+ set of document centric objects and utilities
8 Summary(pl.UTF-8):      Zestaw zorientowanych dokumentowo obiektów i narzędzi Glib/Gtk+
9 Name:           libgoffice
10 Version:        0.8.17
11 Release:        1
12 License:        GPL v2+
13 Group:          Libraries
14 Source0:        http://ftp.gnome.org/pub/GNOME/sources/goffice/0.8/%{orgname}-%{version}.tar.bz2
15 # Source0-md5:  b4c924457163e02daf8a8d2428f51d10
16 URL:            http://www.gtk.org/
17 BuildRequires:  GConf2-devel >= 2.20.0
18 BuildRequires:  autoconf >= 2.54
19 BuildRequires:  automake
20 BuildRequires:  cairo-devel >= 1.2.4
21 BuildRequires:  gettext-devel
22 %{?with_gnome:BuildRequires:    gnome-common >= 2.20.0}
23 BuildRequires:  gtk+2-devel >= 2:2.12.0
24 BuildRequires:  gtk-doc >= 1.4
25 BuildRequires:  intltool >= 0.35.0
26 BuildRequires:  libart_lgpl-devel >= 2.3.11
27 BuildRequires:  libglade2-devel >= 1:2.6.2
28 %{?with_gnome:BuildRequires:    libgnomeui-devel >= 2.20.0}
29 %{?with_gnome:BuildRequires:    libgsf-gnome-devel >= 1.14.6}
30 BuildRequires:  libtool
31 BuildRequires:  libxml2-devel >= 1:2.6.26
32 BuildRequires:  pkgconfig
33 %{?with_gnome:Requires: libgsf-gnome >= 1.14.6}
34 # sr@Latn vs. sr@latin
35 Conflicts:      glibc-misc < 6:2.7
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 GOffice - a Glib/Gtk+ set of document centric objects and utilities.
40
41 %description -l pl.UTF-8
42 GOffice - Zestaw zorientowanych dokumentowo obiektów i narzędzi
43 Glib/Gtk+.
44
45 %package devel
46 Summary:        Header files for GOffice library
47 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GOffice
48 Group:          Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50 Requires:       gtk+2-devel >= 2:2.12.0
51 Requires:       libart_lgpl-devel >= 2.3.11
52 Requires:       libglade2-devel >= 1:2.6.2
53 Requires:       libgsf-gnome-devel >= 1.14.6
54 Requires:       libxml2-devel >= 1:2.6.26
55
56 %description devel
57 This is the package containing the header files for GOffice.
58
59 %description devel -l pl.UTF-8
60 Ten pakiet zawiera pliki nagłówkowe GOffice.
61
62 %package static
63 Summary:        Static GOffice library
64 Summary(pl.UTF-8):      Statyczna biblioteka GOffice
65 Group:          Development/Libraries
66 Requires:       %{name}-devel = %{version}-%{release}
67
68 %description static
69 Static GOffice library.
70
71 %description static -l pl.UTF-8
72 Statyczna biblioteka GOffice.
73
74 %package apidocs
75 Summary:        GOffice library API documentation
76 Summary(pl.UTF-8):      Dokumentacja API biblioteki GOffice
77 Group:          Documentation
78 Requires:       gtk-doc-common
79
80 %description apidocs
81 GOffice library API documentation.
82
83 %description apidocs -l pl.UTF-8
84 Dokumentacja API biblioteki GOffice.
85
86 %prep
87 %setup -qn %{orgname}-%{version}
88
89 %build
90 %{__gtkdocize}
91 %{__intltoolize}
92 %{__libtoolize}
93 %{__aclocal}
94 %{__autoconf}
95 %{__autoheader}
96 %{__automake}
97 %configure \
98         --enable-static \
99         %{?with_gnome:--with-gnome} \
100         --with-html-dir=%{_gtkdocdir} \
101         --disable-silent-rules
102 %{__make}
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106
107 %{__make} install \
108         DESTDIR=$RPM_BUILD_ROOT
109
110 %{__rm} $RPM_BUILD_ROOT%{_libdir}/goffice/%{version}/plugins/*/*.{a,la} \
111         $RPM_BUILD_ROOT%{_libdir}/*.la
112
113 %find_lang %{orgname}-%{version}
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %post   -p /sbin/ldconfig
119 %postun -p /sbin/ldconfig
120
121 %files -f %{orgname}-%{version}.lang
122 %defattr(644,root,root,755)
123 %doc AUTHORS BUGS ChangeLog MAINTAINERS NEWS README
124 %attr(755,root,root) %{_libdir}/libgoffice-0.8.so.*.*.*
125 %attr(755,root,root) %ghost %{_libdir}/libgoffice-0.8.so.8
126 %dir %{_libdir}/goffice
127 %dir %{_libdir}/goffice/%{version}
128 %dir %{_libdir}/goffice/%{version}/plugins
129 %dir %{_libdir}/goffice/%{version}/plugins/*
130 %attr(755,root,root) %{_libdir}/goffice/%{version}/plugins/*/*.so
131 %{_libdir}/goffice/%{version}/plugins/*/*.xml
132 %{_libdir}/goffice/%{version}/plugins/*/*.ui
133 %{_datadir}/goffice
134 %{_pixmapsdir}/goffice
135
136 %files devel
137 %defattr(644,root,root,755)
138 %attr(755,root,root) %{_libdir}/libgoffice-0.8.so
139 %{_includedir}/libgoffice-0.8
140 %{_pkgconfigdir}/libgoffice-0.8.pc
141
142 %files static
143 %defattr(644,root,root,755)
144 %{_libdir}/libgoffice-0.8.a
145
146 %files apidocs
147 %defattr(644,root,root,755)
148 %{_gtkdocdir}/goffice-0.8
This page took 0.042099 seconds and 2 git commands to generate.