]> git.pld-linux.org Git - packages/libgnomesu.git/blob - libgnomesu.spec
Release 12 (by relup.sh)
[packages/libgnomesu.git] / libgnomesu.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs
4
5 Summary:        Library for providing superuser privileges
6 Summary(pl.UTF-8):      Biblioteka do udostępniania uprawnień superużytkownika
7 Name:           libgnomesu
8 Version:        1.0.0
9 Release:        12
10 License:        LGPL v2+
11 Group:          X11/Applications
12 Source0:        http://members.chello.nl/~h.lai/libgnomesu/%{name}-%{version}.tar.gz
13 # Source0-md5:  9f1cb8c3f61ad2fb31ad05a5d3eb211d
14 Patch0:         %{name}-xauth-nolookup.patch
15 Patch1:         %{name}-mainloop.patch
16 Patch2:         %{name}-unsetenv.patch
17 Patch3:         %{name}-modernize.patch
18 Patch4:         %{name}-startup-notification.patch
19 Patch5:         %{name}-pam-handling.patch
20 Patch6:         %{name}-drop-libgnomeui.patch
21 Patch7:         %{name}-safe-path.patch
22 Patch8:         %{name}-remove-prior-cookie.patch
23 Patch9:         %{name}-i18n.patch
24 Patch10:        %{name}-memory-cleaning.patch
25 Patch11:        %{name}-format.patch
26 Patch12:        %{name}-libdir.patch
27 URL:            http://members.chello.nl/~h.lai/libgnomesu/
28 BuildRequires:  GConf2-devel >= 2.0
29 BuildRequires:  gettext-tools
30 BuildRequires:  glib2-devel >= 2.0
31 BuildRequires:  gtk+2-devel >= 1:2.0
32 BuildRequires:  libgnomeui-devel >= 2.10.0-2
33 BuildRequires:  pam-devel
34 BuildRequires:  pkgconfig
35 Requires:       %{name}-libs = %{version}-%{release}
36 Provides:       gnomesu = %{version}-%{release}
37 Obsoletes:      gnomesu
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 libgnomesu is a library for providing superuser privileges to GNOME
42 applications. It supports sudo, consolehelper, PAM and su.
43
44 This package contains actual gnomesu program and backends.
45
46 %description -l pl.UTF-8
47 libgnomesu to biblioteka do udostępniania uprawnień superużytkownika
48 aplikacjom GNOME. Obsługuje sudo, consolehelper, PAM i su.
49
50 Ten pakiet zawiera właściwy program gnomesu i backendy.
51
52 %package libs
53 Summary:        libgnomesu library itself
54 Summary(pl.UTF-8):      Sama biblioteka libgnomesu
55 Group:          X11/Libraries
56
57 %description libs
58 libgnomesu library itself.
59
60 %description libs -l pl.UTF-8
61 Sama biblioteka libgnomesu.
62
63 %package devel
64 Summary:        Headers for libgnomesu
65 Summary(pl.UTF-8):      Pliki nagłówkowe libgnomesu
66 Group:          X11/Development/Libraries
67 Requires:       %{name}-libs = %{version}-%{release}
68 Requires:       glib2-devel >= 2.0
69
70 %description devel
71 Libraries and include files that you will need to use libgnomesu.
72
73 %description devel -l pl.UTF-8
74 Pliki nagłówkowe potrzebne do kompilowania programów korzystających z
75 libgnomesu.
76
77 %package static
78 Summary:        Static libgnomesu libraries
79 Summary(pl.UTF-8):      Statyczne biblioteki libgnomesu
80 Group:          X11/Development/Libraries
81 Requires:       %{name}-devel = %{version}-%{release}
82
83 %description static
84 Static version of libgnomesu libraries.
85
86 %description static -l pl.UTF-8
87 Statyczna wersja bibliotek libgnomesu.
88
89 %prep
90 %setup -q
91 %patch0 -p1
92 %patch1 -p1
93 %patch2 -p1
94 %patch3 -p0
95 %patch4 -p1
96 %patch5 -p1
97 %patch6 -p1
98 %patch7 -p1
99 %patch8 -p1
100 %patch9 -p1
101 %patch10 -p1
102 %patch11 -p1
103 %patch12 -p1
104
105 %build
106 %configure \
107         --disable-schemas-install \
108         --disable-setuid-error \
109         %{?with_static_libs:--enable-static}
110
111 %{__make}
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115
116 %{__make} install \
117         DESTDIR=$RPM_BUILD_ROOT
118
119 chmod 755 $RPM_BUILD_ROOT%{_libexecdir}/gnomesu*backend
120
121 # obsoleted by pkg-config
122 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgnomesu.la
123
124 %{__mv} $RPM_BUILD_ROOT%{_datadir}/locale/{sr@Latn,sr@latin}
125
126 %find_lang %{name}-1.0
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %post   libs -p /sbin/ldconfig
132 %postun libs -p /sbin/ldconfig
133
134 %files -f %{name}-1.0.lang
135 %defattr(644,root,root,755)
136 %doc AUTHORS ChangeLog NEWS README TODO
137 %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/gnomesu-pam
138 %attr(755,root,root) %{_bindir}/gnomesu
139 %attr(4755,root,root) %{_libexecdir}/gnomesu-backend
140 %attr(4755,root,root) %{_libexecdir}/gnomesu-pam-backend
141 %{_datadir}/application-registry/gnomesu-nautilus.applications
142 %{_datadir}/mime-info/gnomesu-nautilus.keys
143
144 %files libs
145 %defattr(644,root,root,755)
146 %attr(755,root,root) %{_libdir}/libgnomesu.so.*.*.*
147 %attr(755,root,root) %ghost %{_libdir}/libgnomesu.so.0
148
149 %files devel
150 %defattr(644,root,root,755)
151 %doc doc/api.html doc/libgnomesu.css
152 %attr(755,root,root) %{_libdir}/libgnomesu.so
153 %{_includedir}/libgnomesu-1.0
154 %{_pkgconfigdir}/libgnomesu-1.0.pc
155
156 %if %{with static_libs}
157 %files static
158 %defattr(644,root,root,755)
159 %{_libdir}/libgnomesu.a
160 %endif
This page took 0.098018 seconds and 3 git commands to generate.