]> git.pld-linux.org Git - packages/libgnome.git/blob - libgnome.spec
7df6877f420e77ec0df7bd27c2577979af7e6527
[packages/libgnome.git] / libgnome.spec
1 #
2 # Conditional build:
3 %bcond_with     esd             # EsounD support (obsolete)
4 %bcond_without  static_libs     # static library
5
6 Summary:        GNOME base library
7 Summary(pl.UTF-8):      Podstawowa biblioteka GNOME
8 Name:           libgnome
9 Version:        2.32.1
10 Release:        5
11 License:        LGPL v2+
12 Group:          Libraries
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/libgnome/2.32/%{name}-%{version}.tar.bz2
14 # Source0-md5:  a4345e6087ae6195d65a4674ffdca559
15 Patch0:         %{name}-load-config.patch
16 Patch1:         %{name}-glib.patch
17 URL:            http://www.gnome.org/
18 BuildRequires:  GConf2-devel >= 2.24.0
19 %{?with_esd:BuildRequires:      audiofile-devel >= 0.2.3}
20 BuildRequires:  autoconf >= 2.54
21 BuildRequires:  automake >= 1:1.9
22 BuildRequires:  docbook-dtd412-xml
23 %{?with_esd:BuildRequires:      esound-devel >= 0.2.26}
24 BuildRequires:  gettext-tools
25 BuildRequires:  glib2-devel >= 1:2.18.0
26 BuildRequires:  gnome-common >= 2.20.0
27 BuildRequires:  gnome-vfs2-devel >= 2.24.0
28 BuildRequires:  gtk-doc >= 1.8
29 BuildRequires:  intltool >= 0.40.0
30 BuildRequires:  libbonobo-devel >= 2.24.0
31 BuildRequires:  libcanberra-devel
32 BuildRequires:  libtool
33 BuildRequires:  perl-base
34 BuildRequires:  pkgconfig
35 BuildRequires:  popt-devel >= 1.5
36 BuildRequires:  rpmbuild(macros) >= 1.197
37 Requires(post,preun):   GConf2
38 Requires:       %{name}-libs = %{version}-%{release}
39 Requires:       libbonobo >= 2.24.0
40 Suggests:       gnome-vfs2
41 Obsoletes:      gnome-objc
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 GNOME (GNU Network Object Model Environment) is a user-friendly set of
46 GUI applications and desktop tools to be used in conjunction with a
47 window manager for the X Window System. The libgnome package includes
48 non-GUI-related libraries that are needed to run GNOME. The libgnomeui
49 package contains X11-dependent GNOME library features.
50
51 %description -l pl.UTF-8
52 GNOME (GNU Network Object Model Environment) jest przyjaznym dla
53 użytkownika zbiorem aplikacji i narzędzi do używania w połączeniu z
54 zarządcą okien pod X Window System. Pakiet libgnome zawiera biblioteki
55 nie związane z graficznym interfejsem potrzebne do uruchomienia GNOME.
56 Pakiet libgnomeui zawiera biblioteki GNOME zależne od X11.
57
58 %package libs
59 Summary:        Base libgnome library and bonobo modules
60 Summary(pl.UTF-8):      Podstawowa biblioteka libgnome oraz moduły bonobo
61 Group:          Libraries
62 Requires:       GConf2-libs >= 2.24.0
63 Requires:       gnome-vfs2-libs >= 2.24.0
64 Requires:       libbonobo-libs >= 2.24.0
65 Requires:       popt >= 1.5
66 Conflicts:      libgnome < 2.32.0-3
67
68 %description libs
69 Base libgnome library and bonobo modules.
70
71 %description libs -l pl.UTF-8
72 Podstawowa biblioteka libgnome oraz moduły bonobo.
73
74 %package devel
75 Summary:        Headers for libgnome
76 Summary(pl.UTF-8):      Pliki nagłówkowe libgnome
77 Group:          Development/Libraries
78 Requires:       %{name}-libs = %{version}-%{release}
79 Requires:       GConf2-devel >= 2.24.0
80 Requires:       gnome-vfs2-devel >= 2.24.0
81 Requires:       libbonobo-devel >= 2.24.0
82 Requires:       libcanberra-devel
83 Requires:       popt-devel >= 1.5
84
85 %description devel
86 This package includes the header files for libgnome applications
87 development.
88
89 %description devel -l pl.UTF-8
90 Pliki nagłówkowe potrzebne do kompilowania programów korzystających z
91 libgnome.
92
93 %package static
94 Summary:        Static libgnome libraries
95 Summary(pl.UTF-8):      Statyczne biblioteki libgnome
96 Group:          Development/Libraries
97 Requires:       %{name}-devel = %{version}-%{release}
98
99 %description static
100 Static version of libgnome libraries.
101
102 %description static -l pl.UTF-8
103 Statyczna wersja bibliotek libgnome.
104
105 %package apidocs
106 Summary:        libgnome API documentation
107 Summary(pl.UTF-8):      Dokumentacja API libgnome
108 Group:          Documentation
109 Requires:       gtk-doc-common
110 BuildArch:      noarch
111
112 %description apidocs
113 libgnome API documentation.
114
115 %description apidocs -l pl.UTF-8
116 Dokumentacja API libgnome.
117
118 %prep
119 %setup -q
120 %patch0 -p1
121 %patch1 -p1
122
123 %build
124 %{__gtkdocize}
125 %{__glib_gettextize}
126 %{__intltoolize}
127 %{__libtoolize}
128 %{__aclocal}
129 %{__autoconf}
130 %{__autoheader}
131 %{__automake}
132 %configure \
133         %{?with_esd:--enable-esd} \
134         --enable-gtk-doc \
135         --disable-schemas-install \
136         --disable-silent-rules \
137         %{!?with_static_libs:--disable-static} \
138         --with-html-dir=%{_gtkdocdir}
139 %{__make}
140
141 %install
142 rm -rf $RPM_BUILD_ROOT
143
144 %{__make} install \
145         DESTDIR=$RPM_BUILD_ROOT
146
147 # no static modules and *.la for bonobo modules
148 # libraries .la obsoleted by pkg-config
149 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la \
150         $RPM_BUILD_ROOT%{_libdir}/bonobo/monikers/*.la
151 %if %{with static_libs}
152 %{__rm} $RPM_BUILD_ROOT%{_libdir}/bonobo/monikers/*.a
153 %endif
154
155 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{sr@ije,sr@ijekavian}
156
157 %find_lang %{name}-2.0
158
159 %clean
160 rm -rf $RPM_BUILD_ROOT
161
162 %post
163 %gconf_schema_install desktop_gnome_accessibility_keyboard.schemas
164 %gconf_schema_install desktop_gnome_accessibility_startup.schemas
165 %gconf_schema_install desktop_gnome_applications_at_mobility.schemas
166 %gconf_schema_install desktop_gnome_applications_at_visual.schemas
167 %gconf_schema_install desktop_gnome_applications_browser.schemas
168 %gconf_schema_install desktop_gnome_applications_office.schemas
169 %gconf_schema_install desktop_gnome_applications_terminal.schemas
170 %gconf_schema_install desktop_gnome_applications_window_manager.schemas
171 %gconf_schema_install desktop_gnome_background.schemas
172 %gconf_schema_install desktop_gnome_file_views.schemas
173 %gconf_schema_install desktop_gnome_interface.schemas
174 %gconf_schema_install desktop_gnome_lockdown.schemas
175 %gconf_schema_install desktop_gnome_peripherals_keyboard.schemas
176 %gconf_schema_install desktop_gnome_peripherals_mouse.schemas
177 %gconf_schema_install desktop_gnome_sound.schemas
178 %gconf_schema_install desktop_gnome_thumbnail_cache.schemas
179 %gconf_schema_install desktop_gnome_thumbnailers.schemas
180 %gconf_schema_install desktop_gnome_typing_break.schemas
181
182 %preun
183 %gconf_schema_uninstall desktop_gnome_accessibility_keyboard.schemas
184 %gconf_schema_uninstall desktop_gnome_accessibility_startup.schemas
185 %gconf_schema_uninstall desktop_gnome_applications_at_mobility.schemas
186 %gconf_schema_uninstall desktop_gnome_applications_at_visual.schemas
187 %gconf_schema_uninstall desktop_gnome_applications_browser.schemas
188 %gconf_schema_uninstall desktop_gnome_applications_office.schemas
189 %gconf_schema_uninstall desktop_gnome_applications_terminal.schemas
190 %gconf_schema_uninstall desktop_gnome_applications_window_manager.schemas
191 %gconf_schema_uninstall desktop_gnome_background.schemas
192 %gconf_schema_uninstall desktop_gnome_file_views.schemas
193 %gconf_schema_uninstall desktop_gnome_interface.schemas
194 %gconf_schema_uninstall desktop_gnome_lockdown.schemas
195 %gconf_schema_uninstall desktop_gnome_peripherals_keyboard.schemas
196 %gconf_schema_uninstall desktop_gnome_peripherals_mouse.schemas
197 %gconf_schema_uninstall desktop_gnome_sound.schemas
198 %gconf_schema_uninstall desktop_gnome_thumbnail_cache.schemas
199 %gconf_schema_uninstall desktop_gnome_thumbnailers.schemas
200 %gconf_schema_uninstall desktop_gnome_typing_break.schemas
201
202 %post   libs -p /sbin/ldconfig
203 %postun libs -p /sbin/ldconfig
204
205 %files -f %{name}-2.0.lang
206 %defattr(644,root,root,755)
207 %doc AUTHORS ChangeLog MAINTAINERS NEWS README
208 %attr(755,root,root) %{_bindir}/gnome-open
209 %dir %{_datadir}/gnome-background-properties
210 %{_datadir}/gnome-background-properties/gnome-default.xml
211 %dir %{_pixmapsdir}/backgrounds
212 %dir %{_pixmapsdir}/backgrounds/gnome
213 %{_pixmapsdir}/backgrounds/gnome/background-default.jpg
214 %{_mandir}/man7/gnome-options*
215 %{_sysconfdir}/gconf/schemas/desktop_gnome_accessibility_keyboard.schemas
216 %{_sysconfdir}/gconf/schemas/desktop_gnome_accessibility_startup.schemas
217 %{_sysconfdir}/gconf/schemas/desktop_gnome_applications_at_mobility.schemas
218 %{_sysconfdir}/gconf/schemas/desktop_gnome_applications_at_visual.schemas
219 %{_sysconfdir}/gconf/schemas/desktop_gnome_applications_browser.schemas
220 %{_sysconfdir}/gconf/schemas/desktop_gnome_applications_office.schemas
221 %{_sysconfdir}/gconf/schemas/desktop_gnome_applications_terminal.schemas
222 %{_sysconfdir}/gconf/schemas/desktop_gnome_applications_window_manager.schemas
223 %{_sysconfdir}/gconf/schemas/desktop_gnome_background.schemas
224 %{_sysconfdir}/gconf/schemas/desktop_gnome_file_views.schemas
225 %{_sysconfdir}/gconf/schemas/desktop_gnome_interface.schemas
226 %{_sysconfdir}/gconf/schemas/desktop_gnome_lockdown.schemas
227 %{_sysconfdir}/gconf/schemas/desktop_gnome_peripherals_keyboard.schemas
228 %{_sysconfdir}/gconf/schemas/desktop_gnome_peripherals_mouse.schemas
229 %{_sysconfdir}/gconf/schemas/desktop_gnome_sound.schemas
230 %{_sysconfdir}/gconf/schemas/desktop_gnome_thumbnail_cache.schemas
231 %{_sysconfdir}/gconf/schemas/desktop_gnome_thumbnailers.schemas
232 %{_sysconfdir}/gconf/schemas/desktop_gnome_typing_break.schemas
233 %dir %{_sysconfdir}/sound
234 %dir %{_sysconfdir}/sound/events
235 %{_sysconfdir}/sound/events/gtk-events-2.soundlist
236 %{_sysconfdir}/sound/events/gnome-2.soundlist
237
238 %files libs
239 %defattr(644,root,root,755)
240 %attr(755,root,root) %{_libdir}/libgnome-2.so.*.*.*
241 %attr(755,root,root) %ghost %{_libdir}/libgnome-2.so.0
242 %attr(755,root,root) %{_libdir}/bonobo/monikers/libmoniker_extra_2.so
243 %{_libdir}/bonobo/servers/GNOME_Moniker_std.server
244
245 %files devel
246 %defattr(644,root,root,755)
247 %attr(755,root,root) %{_libdir}/libgnome-2.so
248 %{_includedir}/libgnome-2.0
249 %{_pkgconfigdir}/libgnome-2.0.pc
250
251 %if %{with static_libs}
252 %files static
253 %defattr(644,root,root,755)
254 %{_libdir}/libgnome-2.a
255 %endif
256
257 %files apidocs
258 %defattr(644,root,root,755)
259 %{_gtkdocdir}/%{name}
This page took 0.098474 seconds and 2 git commands to generate.