]> git.pld-linux.org Git - packages/libgnome.git/blob - libgnome.spec
- updated URLs and libbonobo dependency, fix for current gtk-doc; rel 6
[packages/libgnome.git] / libgnome.spec
1 #
2 # Conditional build:
3 %bcond_with     esd             # EsounD support (obsolete)
4 %bcond_without  static_libs     # static library
5
6 Summary:        GNOME base library
7 Summary(pl.UTF-8):      Podstawowa biblioteka GNOME
8 Name:           libgnome
9 Version:        2.32.1
10 Release:        6
11 License:        LGPL v2+
12 Group:          Libraries
13 Source0:        https://download.gnome.org/sources/libgnome/2.32/%{name}-%{version}.tar.bz2
14 # Source0-md5:  a4345e6087ae6195d65a4674ffdca559
15 Patch0:         %{name}-load-config.patch
16 Patch1:         %{name}-glib.patch
17 URL:            https://www.gnome.org/
18 BuildRequires:  GConf2-devel >= 2.24.0
19 %{?with_esd:BuildRequires:      audiofile-devel >= 0.2.3}
20 BuildRequires:  autoconf >= 2.54
21 BuildRequires:  automake >= 1:1.9
22 BuildRequires:  docbook-dtd412-xml
23 %{?with_esd:BuildRequires:      esound-devel >= 0.2.26}
24 BuildRequires:  gettext-tools
25 BuildRequires:  glib2-devel >= 1:2.18.0
26 BuildRequires:  gnome-common >= 2.20.0
27 BuildRequires:  gnome-vfs2-devel >= 2.24.0
28 BuildRequires:  gtk-doc >= 1.8
29 BuildRequires:  intltool >= 0.40.0
30 BuildRequires:  libbonobo-devel >= 2.24.0
31 BuildRequires:  libcanberra-devel
32 BuildRequires:  libtool
33 BuildRequires:  perl-base
34 BuildRequires:  pkgconfig
35 BuildRequires:  popt-devel >= 1.5
36 BuildRequires:  rpm-build >= 4.6
37 BuildRequires:  rpmbuild(macros) >= 1.197
38 Requires(post,preun):   GConf2
39 Requires:       %{name}-libs = %{version}-%{release}
40 Requires:       libbonobo >= 2.24.0
41 Suggests:       gnome-vfs2
42 Obsoletes:      gnome-objc
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 GNOME (GNU Network Object Model Environment) is a user-friendly set of
47 GUI applications and desktop tools to be used in conjunction with a
48 window manager for the X Window System. The libgnome package includes
49 non-GUI-related libraries that are needed to run GNOME. The libgnomeui
50 package contains X11-dependent GNOME library features.
51
52 %description -l pl.UTF-8
53 GNOME (GNU Network Object Model Environment) jest przyjaznym dla
54 użytkownika zbiorem aplikacji i narzędzi do używania w połączeniu z
55 zarządcą okien pod X Window System. Pakiet libgnome zawiera biblioteki
56 nie związane z graficznym interfejsem potrzebne do uruchomienia GNOME.
57 Pakiet libgnomeui zawiera biblioteki GNOME zależne od X11.
58
59 %package libs
60 Summary:        Base libgnome library and bonobo modules
61 Summary(pl.UTF-8):      Podstawowa biblioteka libgnome oraz moduły bonobo
62 Group:          Libraries
63 Requires:       GConf2-libs >= 2.24.0
64 Requires:       gnome-vfs2-libs >= 2.24.0
65 Requires:       libbonobo >= 2.24.0
66 Requires:       popt >= 1.5
67 Conflicts:      libgnome < 2.32.0-3
68
69 %description libs
70 Base libgnome library and bonobo modules.
71
72 %description libs -l pl.UTF-8
73 Podstawowa biblioteka libgnome oraz moduły bonobo.
74
75 %package devel
76 Summary:        Headers for libgnome
77 Summary(pl.UTF-8):      Pliki nagłówkowe libgnome
78 Group:          Development/Libraries
79 Requires:       %{name}-libs = %{version}-%{release}
80 Requires:       GConf2-devel >= 2.24.0
81 Requires:       gnome-vfs2-devel >= 2.24.0
82 Requires:       libbonobo-devel >= 2.24.0
83 Requires:       libcanberra-devel
84 Requires:       popt-devel >= 1.5
85
86 %description devel
87 This package includes the header files for libgnome applications
88 development.
89
90 %description devel -l pl.UTF-8
91 Pliki nagłówkowe potrzebne do kompilowania programów korzystających z
92 libgnome.
93
94 %package static
95 Summary:        Static libgnome libraries
96 Summary(pl.UTF-8):      Statyczne biblioteki libgnome
97 Group:          Development/Libraries
98 Requires:       %{name}-devel = %{version}-%{release}
99
100 %description static
101 Static version of libgnome libraries.
102
103 %description static -l pl.UTF-8
104 Statyczna wersja bibliotek libgnome.
105
106 %package apidocs
107 Summary:        libgnome API documentation
108 Summary(pl.UTF-8):      Dokumentacja API libgnome
109 Group:          Documentation
110 Requires:       gtk-doc-common
111 BuildArch:      noarch
112
113 %description apidocs
114 libgnome API documentation.
115
116 %description apidocs -l pl.UTF-8
117 Dokumentacja API libgnome.
118
119 %prep
120 %setup -q
121 %patch0 -p1
122 %patch1 -p1
123
124 # gtk-doc no longer handles legacy encodings; use just ascii space instead of nbsp
125 %{__sed} -i -e 's/\xa0/ /' libgnome/gnome-config.h
126
127 %build
128 %{__gtkdocize}
129 %{__glib_gettextize}
130 %{__intltoolize}
131 %{__libtoolize}
132 %{__aclocal}
133 %{__autoconf}
134 %{__autoheader}
135 %{__automake}
136 %configure \
137         %{?with_esd:--enable-esd} \
138         --enable-gtk-doc \
139         --disable-schemas-install \
140         --disable-silent-rules \
141         %{!?with_static_libs:--disable-static} \
142         --with-html-dir=%{_gtkdocdir}
143 %{__make}
144
145 %install
146 rm -rf $RPM_BUILD_ROOT
147
148 %{__make} install \
149         DESTDIR=$RPM_BUILD_ROOT
150
151 # no static modules and *.la for bonobo modules
152 # libraries .la obsoleted by pkg-config
153 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la \
154         $RPM_BUILD_ROOT%{_libdir}/bonobo/monikers/*.la
155 %if %{with static_libs}
156 %{__rm} $RPM_BUILD_ROOT%{_libdir}/bonobo/monikers/*.a
157 %endif
158
159 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{sr@ije,sr@ijekavian}
160
161 %find_lang %{name}-2.0
162
163 %clean
164 rm -rf $RPM_BUILD_ROOT
165
166 %post
167 %gconf_schema_install desktop_gnome_accessibility_keyboard.schemas
168 %gconf_schema_install desktop_gnome_accessibility_startup.schemas
169 %gconf_schema_install desktop_gnome_applications_at_mobility.schemas
170 %gconf_schema_install desktop_gnome_applications_at_visual.schemas
171 %gconf_schema_install desktop_gnome_applications_browser.schemas
172 %gconf_schema_install desktop_gnome_applications_office.schemas
173 %gconf_schema_install desktop_gnome_applications_terminal.schemas
174 %gconf_schema_install desktop_gnome_applications_window_manager.schemas
175 %gconf_schema_install desktop_gnome_background.schemas
176 %gconf_schema_install desktop_gnome_file_views.schemas
177 %gconf_schema_install desktop_gnome_interface.schemas
178 %gconf_schema_install desktop_gnome_lockdown.schemas
179 %gconf_schema_install desktop_gnome_peripherals_keyboard.schemas
180 %gconf_schema_install desktop_gnome_peripherals_mouse.schemas
181 %gconf_schema_install desktop_gnome_sound.schemas
182 %gconf_schema_install desktop_gnome_thumbnail_cache.schemas
183 %gconf_schema_install desktop_gnome_thumbnailers.schemas
184 %gconf_schema_install desktop_gnome_typing_break.schemas
185
186 %preun
187 %gconf_schema_uninstall desktop_gnome_accessibility_keyboard.schemas
188 %gconf_schema_uninstall desktop_gnome_accessibility_startup.schemas
189 %gconf_schema_uninstall desktop_gnome_applications_at_mobility.schemas
190 %gconf_schema_uninstall desktop_gnome_applications_at_visual.schemas
191 %gconf_schema_uninstall desktop_gnome_applications_browser.schemas
192 %gconf_schema_uninstall desktop_gnome_applications_office.schemas
193 %gconf_schema_uninstall desktop_gnome_applications_terminal.schemas
194 %gconf_schema_uninstall desktop_gnome_applications_window_manager.schemas
195 %gconf_schema_uninstall desktop_gnome_background.schemas
196 %gconf_schema_uninstall desktop_gnome_file_views.schemas
197 %gconf_schema_uninstall desktop_gnome_interface.schemas
198 %gconf_schema_uninstall desktop_gnome_lockdown.schemas
199 %gconf_schema_uninstall desktop_gnome_peripherals_keyboard.schemas
200 %gconf_schema_uninstall desktop_gnome_peripherals_mouse.schemas
201 %gconf_schema_uninstall desktop_gnome_sound.schemas
202 %gconf_schema_uninstall desktop_gnome_thumbnail_cache.schemas
203 %gconf_schema_uninstall desktop_gnome_thumbnailers.schemas
204 %gconf_schema_uninstall desktop_gnome_typing_break.schemas
205
206 %post   libs -p /sbin/ldconfig
207 %postun libs -p /sbin/ldconfig
208
209 %files -f %{name}-2.0.lang
210 %defattr(644,root,root,755)
211 %doc AUTHORS ChangeLog MAINTAINERS NEWS README
212 %attr(755,root,root) %{_bindir}/gnome-open
213 %dir %{_datadir}/gnome-background-properties
214 %{_datadir}/gnome-background-properties/gnome-default.xml
215 %dir %{_pixmapsdir}/backgrounds
216 %dir %{_pixmapsdir}/backgrounds/gnome
217 %{_pixmapsdir}/backgrounds/gnome/background-default.jpg
218 %{_mandir}/man7/gnome-options*
219 %{_sysconfdir}/gconf/schemas/desktop_gnome_accessibility_keyboard.schemas
220 %{_sysconfdir}/gconf/schemas/desktop_gnome_accessibility_startup.schemas
221 %{_sysconfdir}/gconf/schemas/desktop_gnome_applications_at_mobility.schemas
222 %{_sysconfdir}/gconf/schemas/desktop_gnome_applications_at_visual.schemas
223 %{_sysconfdir}/gconf/schemas/desktop_gnome_applications_browser.schemas
224 %{_sysconfdir}/gconf/schemas/desktop_gnome_applications_office.schemas
225 %{_sysconfdir}/gconf/schemas/desktop_gnome_applications_terminal.schemas
226 %{_sysconfdir}/gconf/schemas/desktop_gnome_applications_window_manager.schemas
227 %{_sysconfdir}/gconf/schemas/desktop_gnome_background.schemas
228 %{_sysconfdir}/gconf/schemas/desktop_gnome_file_views.schemas
229 %{_sysconfdir}/gconf/schemas/desktop_gnome_interface.schemas
230 %{_sysconfdir}/gconf/schemas/desktop_gnome_lockdown.schemas
231 %{_sysconfdir}/gconf/schemas/desktop_gnome_peripherals_keyboard.schemas
232 %{_sysconfdir}/gconf/schemas/desktop_gnome_peripherals_mouse.schemas
233 %{_sysconfdir}/gconf/schemas/desktop_gnome_sound.schemas
234 %{_sysconfdir}/gconf/schemas/desktop_gnome_thumbnail_cache.schemas
235 %{_sysconfdir}/gconf/schemas/desktop_gnome_thumbnailers.schemas
236 %{_sysconfdir}/gconf/schemas/desktop_gnome_typing_break.schemas
237 %dir %{_sysconfdir}/sound
238 %dir %{_sysconfdir}/sound/events
239 %{_sysconfdir}/sound/events/gtk-events-2.soundlist
240 %{_sysconfdir}/sound/events/gnome-2.soundlist
241
242 %files libs
243 %defattr(644,root,root,755)
244 %attr(755,root,root) %{_libdir}/libgnome-2.so.*.*.*
245 %attr(755,root,root) %ghost %{_libdir}/libgnome-2.so.0
246 %attr(755,root,root) %{_libdir}/bonobo/monikers/libmoniker_extra_2.so
247 %{_libdir}/bonobo/servers/GNOME_Moniker_std.server
248
249 %files devel
250 %defattr(644,root,root,755)
251 %attr(755,root,root) %{_libdir}/libgnome-2.so
252 %{_includedir}/libgnome-2.0
253 %{_pkgconfigdir}/libgnome-2.0.pc
254
255 %if %{with static_libs}
256 %files static
257 %defattr(644,root,root,755)
258 %{_libdir}/libgnome-2.a
259 %endif
260
261 %files apidocs
262 %defattr(644,root,root,755)
263 %{_gtkdocdir}/%{name}
This page took 0.089707 seconds and 3 git commands to generate.