]> git.pld-linux.org Git - packages/libgnome-keyring.git/blob - libgnome-keyring.spec
- release 6 (by relup.sh)
[packages/libgnome-keyring.git] / libgnome-keyring.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  vala            # do not build Vala API
5
6 Summary:        libgnome-keyring library
7 Summary(pl.UTF-8):      Biblioteka libgnome-keyring
8 Name:           libgnome-keyring
9 Version:        3.12.0
10 Release:        6
11 License:        LGPL v2+
12 Group:          Libraries
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/libgnome-keyring/3.12/%{name}-%{version}.tar.xz
14 # Source0-md5:  6696e4f2e9aed4625cdc3af30bd8c238
15 Patch0:         %{name}-vala.patch
16 URL:            http://live.gnome.org/GnomeKeyring
17 BuildRequires:  autoconf >= 2.50
18 BuildRequires:  automake
19 BuildRequires:  dbus-devel >= 1.0
20 BuildRequires:  docbook-dtd412-xml
21 BuildRequires:  gettext-tools
22 BuildRequires:  glib2-devel >= 1:2.16.0
23 BuildRequires:  gobject-introspection-devel >= 1.30.0
24 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.9}
25 BuildRequires:  intltool >= 0.40.0
26 BuildRequires:  libgcrypt-devel >= 1.2.2
27 BuildRequires:  libtool
28 BuildRequires:  pkgconfig
29 BuildRequires:  rpmbuild(macros) >= 1.527
30 BuildRequires:  tar >= 1:1.22
31 %{?with_vala:BuildRequires:     vala >= 2:0.16.0}
32 BuildRequires:  xz
33 Requires:       glib2 >= 1:2.16.0
34 Requires:       libgcrypt >= 1.2.2
35 Conflicts:      gnome-keyring-libs < 2.29.0
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 The libgnome-keyring library is used by applications to integrate with
40 the gnome-keyring system.
41
42 %description -l pl.UTF-8
43 Biblioteka libgnome-keyring jest używana w celu zintegrowania
44 aplikacji z systemem gnome-keyring.
45
46 %package devel
47 Summary:        Header files for libgnome-keyring library
48 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libgnome-keyring
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51 Requires:       glib2-devel >= 1:2.16.0
52 Requires:       libgcrypt-devel >= 1.2.2
53 Conflicts:      gnome-keyring-devel < 2.29.0
54
55 %description devel
56 Header files for libgnome-keyring library.
57
58 %description devel -l pl.UTF-8
59 Pliki nagłówkowe biblioteki libgnome-keyring.
60
61 %package apidocs
62 Summary:        libgnome-keyring library API documentation
63 Summary(pl.UTF-8):      Dokumentacja API biblioteki libgnome-keyring
64 Group:          Documentation
65 Requires:       gtk-doc-common
66 Conflicts:      gnome-keyring-apidocs < 2.29.0
67 %if "%{_rpmversion}" >= "5"
68 BuildArch:      noarch
69 %endif
70
71 %description apidocs
72 libgnome-keyring library API documentation.
73
74 %description apidocs -l pl.UTF-8
75 Dokumentacja API biblioteki libgnome-keyring.
76
77 %package -n vala-libgnome-keyring
78 Summary:        libgnome-keyring API for Vala language
79 Summary(pl.UTF-8):      API libgnome-keyring dla języka Vala
80 Group:          Development/Libraries
81 Requires:       %{name}-devel = %{version}-%{release}
82 Requires:       vala >= 2:0.16.0
83 %if "%{_rpmversion}" >= "5"
84 BuildArch:      noarch
85 %endif
86
87 %description -n vala-libgnome-keyring
88 libgnome-keyring API for Vala language.
89
90 %description -n vala-libgnome-keyring -l pl.UTF-8
91 API libgnome-keyring dla języka Vala.
92
93 %prep
94 %setup -q
95 %patch0 -p1
96
97 %build
98 %{?with_apidocs:%{__gtkdocize}}
99 %{__intltoolize}
100 %{__libtoolize}
101 %{__aclocal} -I build/m4
102 %{__autoconf}
103 %{__autoheader}
104 %{__automake}
105 %configure \
106         %{__enable_disable apidocs gtk-doc} \
107         --disable-silent-rules \
108         %{__enable_disable vala vala} \
109         --with-html-dir=%{_gtkdocdir}
110 %{__make}
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114
115 %{__make} install \
116         DESTDIR=$RPM_BUILD_ROOT
117
118 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
119
120 %if %{without apidocs}
121 rm -rf $RPM_BUILD_ROOT%{_gtkdocdir}
122 %endif
123
124 %find_lang %{name}
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %post   -p /sbin/ldconfig
130 %postun -p /sbin/ldconfig
131
132 %files -f %{name}.lang
133 %defattr(644,root,root,755)
134 %doc AUTHORS ChangeLog HACKING NEWS README
135 %attr(755,root,root) %{_libdir}/libgnome-keyring.so.*.*.*
136 %attr(755,root,root) %ghost %{_libdir}/libgnome-keyring.so.0
137 %{_libdir}/girepository-1.0/GnomeKeyring-1.0.typelib
138
139 %files devel
140 %defattr(644,root,root,755)
141 %attr(755,root,root) %{_libdir}/libgnome-keyring.so
142 %{_datadir}/gir-1.0/GnomeKeyring-1.0.gir
143 %{_includedir}/gnome-keyring-1
144 %{_pkgconfigdir}/gnome-keyring-1.pc
145
146 %if %{with apidocs}
147 %files apidocs
148 %defattr(644,root,root,755)
149 %{_gtkdocdir}/gnome-keyring
150 %endif
151
152 %if %{with vala}
153 %files -n vala-libgnome-keyring
154 %defattr(644,root,root,755)
155 %{_datadir}/vala/vapi/gnome-keyring-1.vapi
156 %endif
This page took 0.116862 seconds and 3 git commands to generate.