]> git.pld-linux.org Git - packages/libgit2.git/blob - libgit2.spec
up to 1.7.2 (fixes CVE-2024-24575 CVE-2024-24577)
[packages/libgit2.git] / libgit2.spec
1 #
2 # Conditional build:
3 %bcond_without  kerberos5       # GSSAPI for SPNEGO auth
4 %bcond_without  libssh          # SSH support via libssh2
5 %bcond_with     tests           # build without tests
6
7 Summary:        C Git library
8 Summary(pl.UTF-8):      Biblioteka Git dla C
9 Name:           libgit2
10 Version:        1.7.2
11 Release:        1
12 License:        GPL v2 with linking exception
13 Group:          Libraries
14 #Source0Download: https://github.com/libgit2/libgit2/releases
15 Source0:        https://github.com/libgit2/libgit2/archive/v%{version}/%{name}-%{version}.tar.gz
16 # Source0-md5:  fa4f30e57c67fabee18c5961af72fb3f
17 Patch0:         %{name}-no-libgit2-test.patch
18 URL:            http://libgit2.github.com/
19 BuildRequires:  cmake >= 3.5.1
20 %{?with_kerberos5:BuildRequires:        heimdal-devel}
21 BuildRequires:  http-parser-devel >= 2
22 %{?with_libssh:BuildRequires:   libssh2-devel}
23 BuildRequires:  openssl-devel
24 BuildRequires:  pcre2-8-devel
25 BuildRequires:  pkgconfig
26 %{?with_tests:BuildRequires:    python}
27 BuildRequires:  rpmbuild(macros) >= 1.742
28 BuildRequires:  zlib-devel
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 libgit2 is a portable, pure C implementation of the Git core methods
33 provided as a re-entrant linkable library with a solid API, allowing
34 you to write native speed custom Git applications in any language with
35 bindings.
36
37 %description -l pl.UTF-8
38 libgit2 to przenośna implementacja w czystym C głównych metod Gita,
39 udostępniona jako bezpieczna dla wątków biblioteka ze stałym API,
40 pozwalająca na pisanie własnych aplikacji dla Gita o natywnej
41 szybkości w dowolnym języku posiadającym odpowiednie wiązania.
42
43 %package devel
44 Summary:        Header files for libgit2 library
45 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libgit2
46 Group:          Development/Libraries
47 Requires:       %{name}%{?_isa} = %{version}-%{release}
48 Requires:       http-parser-devel
49 Requires:       libssh2-devel
50 Requires:       openssl-devel
51 Requires:       zlib-devel
52
53 %description devel
54 Header files for libgit2 library.
55
56 %description devel -l pl.UTF-8
57 Pliki nagłówkowe biblioteki libgit2.
58
59 %package tools
60 Summary:        Tools for libgit2 library
61 Summary(pl.UTF-8):      Narzędzia dla biblioteki libgit2
62 Group:          Application
63 Requires:       %{name}%{?_isa} = %{version}-%{release}
64
65 %description tools
66 Tools for libgit2 library.
67
68 %description tools -l pl.UTF-8
69 Narzędzia dla biblioteki libgit2.
70
71 %prep
72 %setup -q
73 %patch0 -p1
74
75 # Don't test network
76 sed -i '/ADD_TEST(online/s/^/#/' tests/CMakeLists.txt
77
78 %build
79 install -d build
80 cd build
81 # CMakeLists.txt supports only relative LIB_INSTALL_DIR and INCLUDE_INSTALL_DIR
82 # (otherwise .pc file is generated incorrectly).
83 # Type (:PATH or :STRING) must be specified explicitly to avoid expansion
84 # relative to cwd.
85 %cmake .. \
86         %{cmake_on_off tests BUILD_TESTS} \
87         -DREGEX_BACKEND=pcre2 \
88         %{cmake_on_off kerberos5 USE_GSSAPI} \
89         -DUSE_HTTP_PARSER=system \
90         %{cmake_on_off libssh USE_SSH}
91 %{__make}
92
93 %{?with_tests:%{__make} test ARGS="-V"}
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97
98 %{__make} -C build install \
99         DESTDIR=$RPM_BUILD_ROOT
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %post   -p /sbin/ldconfig
105 %postun -p /sbin/ldconfig
106
107 %files
108 %defattr(644,root,root,755)
109 %doc AUTHORS docs/contributing.md COPYING README.md
110 %attr(755,root,root) %{_libdir}/libgit2.so.*.*.*
111 %attr(755,root,root) %ghost %{_libdir}/libgit2.so.1.7
112
113 %files devel
114 %defattr(644,root,root,755)
115 %attr(755,root,root) %{_libdir}/libgit2.so
116 %{_includedir}/git2.h
117 %{_includedir}/git2
118 %{_pkgconfigdir}/libgit2.pc
119
120 %files tools
121 %defattr(644,root,root,755)
122 %attr(755,root,root) %{_bindir}/git2
This page took 0.146599 seconds and 4 git commands to generate.